aboutsummaryrefslogtreecommitdiff
path: root/dns
diff options
context:
space:
mode:
authorSergey A. Osokin <osa@FreeBSD.org>2010-01-13 14:20:09 +0000
committerSergey A. Osokin <osa@FreeBSD.org>2010-01-13 14:20:09 +0000
commit01bb4b3b917781891e0f10b1479f39936cd67d61 (patch)
tree979dbdbd468bf2a9c02fd9f6f2bbd977f136d7b3 /dns
parentf4fb3d948c3d4f3a706df484978d3e41329732d2 (diff)
downloadports-01bb4b3b917781891e0f10b1479f39936cd67d61.tar.gz
ports-01bb4b3b917781891e0f10b1479f39936cd67d61.zip
Notes
Diffstat (limited to 'dns')
-rw-r--r--dns/autotrust/Makefile22
1 files changed, 17 insertions, 5 deletions
diff --git a/dns/autotrust/Makefile b/dns/autotrust/Makefile
index 775dbde70c89..72345db645e1 100644
--- a/dns/autotrust/Makefile
+++ b/dns/autotrust/Makefile
@@ -7,15 +7,17 @@
PORTNAME= autotrust
PORTVERSION= 0.3.1
+PORTREVISION= 1
CATEGORIES= dns
MASTER_SITES= http://www.nlnetlabs.nl/downloads/autotrust/
-DISTNAME= ${PORTNAME}-${PORTVERSION}
MAINTAINER= jaap@bartok.nlnetlabs.nl
-COMMENT= A a tool to automatically update DNSSEC trust anchors
+COMMENT= A tool to automatically update DNSSEC trust anchors
-BUILD_DEPENDS+= ldns:${PORTSDIR}/dns/ldns
-BUILD_DEPENDS+= unbound:${PORTSDIR}/dns/unbound
+LIB_DEPENDS+= ldns.1:${PORTSDIR}/dns/ldns \
+ unbound.2:${PORTSDIR}/dns/unbound
+
+GNU_CONFIGURE= yes
MAN8= autotrust.8
@@ -23,6 +25,16 @@ PLIST_FILES= sbin/autotrust \
etc/autotrust/autotrust.conf.sample
PLIST_DIRS= etc/autotrust
-GNU_CONFIGURE= yes
+do-patch:
+ ${REINPLACE_CMD} \
+ '45s!=!\?=!; \
+ 46s!^\(CFLAGS \)\(= -I.\) @CFLAGS@!\1+\2!' \
+ ${WRKSRC}/Makefile.in
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/sbin
+ ${MKDIR} ${ETCDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.conf.sample ${ETCDIR}
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.8 ${PREFIX}/man/man8
.include <bsd.port.mk>