aboutsummaryrefslogtreecommitdiff
path: root/dns
diff options
context:
space:
mode:
authorMunechika SUMIKAWA <sumikawa@FreeBSD.org>2002-11-03 15:51:39 +0000
committerMunechika SUMIKAWA <sumikawa@FreeBSD.org>2002-11-03 15:51:39 +0000
commit27c90ba30b080ccff55ede715403c1632a5093c4 (patch)
treec37370d787b1714711e1539a1df9be41e2dad084 /dns
parent1e3c877f0532697ca1f59b5b71b6ee70a20a1db6 (diff)
downloadports-27c90ba30b080ccff55ede715403c1632a5093c4.tar.gz
ports-27c90ba30b080ccff55ede715403c1632a5093c4.zip
Notes
Diffstat (limited to 'dns')
-rw-r--r--dns/totd/Makefile4
-rw-r--r--dns/totd/files/totd.sh18
2 files changed, 21 insertions, 1 deletions
diff --git a/dns/totd/Makefile b/dns/totd/Makefile
index 6993c0e5bc51..b48626ff2460 100644
--- a/dns/totd/Makefile
+++ b/dns/totd/Makefile
@@ -6,7 +6,7 @@
PORTNAME= totd
PORTVERSION= 1.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net ipv6
MASTER_SITES= ftp://ftp.pasta.cs.uit.no/pub/Vermicelli/
@@ -18,5 +18,7 @@ GNU_CONFIGURE= YES
post-install:
${INSTALL_DATA} ${FILESDIR}/totd.conf.sample ${PREFIX}/etc
+ @${SED} 's@%PREFIX%@${LOCALBASE}@g' ${FILESDIR}/totd.sh > ${PREFIX}/etc/rc.d/totd.sh
+ @${CHMOD} +x ${PREFIX}/etc/rc.d/totd.sh
.include <bsd.port.mk>
diff --git a/dns/totd/files/totd.sh b/dns/totd/files/totd.sh
new file mode 100644
index 000000000000..9a528db44489
--- /dev/null
+++ b/dns/totd/files/totd.sh
@@ -0,0 +1,18 @@
+#!/bin/sh
+
+case "$1" in
+ start)
+ if [ -x %PREFIX%/sbin/totd ]; then
+ %PREFIX%/sbin/totd && echo -n ' totd'
+ fi
+ ;;
+
+ stop)
+ /usr/bin/killall totd && echo -n ' totd'
+ ;;
+
+ *)
+ echo "Usage: `basename $0` { start | stop }"
+ exit 64
+ ;;
+esac