aboutsummaryrefslogtreecommitdiff
path: root/dns
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2008-03-22 21:35:52 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2008-03-22 21:35:52 +0000
commit79b1a6f7587db86ca7f92968505d689fccf01cdb (patch)
tree91d9a8566dbaadc6333bb404736c250f16fb2da6 /dns
parent3acf65bd2b675b5a6949de41216a40b3f31b1630 (diff)
downloadports-79b1a6f7587db86ca7f92968505d689fccf01cdb.tar.gz
ports-79b1a6f7587db86ca7f92968505d689fccf01cdb.zip
Notes
Diffstat (limited to 'dns')
-rw-r--r--dns/dnsperf/Makefile5
-rw-r--r--dns/dnsperf/files/patch-Makefile.in22
2 files changed, 26 insertions, 1 deletions
diff --git a/dns/dnsperf/Makefile b/dns/dnsperf/Makefile
index 4f33e2904061..fa878f604f96 100644
--- a/dns/dnsperf/Makefile
+++ b/dns/dnsperf/Makefile
@@ -18,7 +18,10 @@ BUILD_DEPENDS= isc-config.sh:${PORTSDIR}/dns/bind9
HAS_CONFIGURE= yes
-PLIST_FILES= bin/dnsperf bin/resperf bin/resperf-report
+MAKE_ENV= INSTALL_PROGRAM="${INSTALL_PROGRAM}" \
+ INSTALL_SCRIPT="${INSTALL_SCRIPT}" \
+ INSTALL_DATA="${INSTALL_DATA}"
+PLIST_FILES= bin/dnsperf bin/resperf bin/resperf-report
MAN1= dnsperf.1 resperf.1
.include <bsd.port.mk>
diff --git a/dns/dnsperf/files/patch-Makefile.in b/dns/dnsperf/files/patch-Makefile.in
new file mode 100644
index 000000000000..af80f2707657
--- /dev/null
+++ b/dns/dnsperf/files/patch-Makefile.in
@@ -0,0 +1,22 @@
+--- Makefile.in.orig 2006-12-22 08:58:01.000000000 +1100
++++ Makefile.in 2008-03-23 08:34:53.000000000 +1100
+@@ -6,8 +6,8 @@
+ mandir = @prefix@/man
+
+ INSTALL = @INSTALL@
+-INSTALL_PROGRAM = @INSTALL_PROGRAM@
+-INSTALL_DATA = @INSTALL_DATA@
++#INSTALL_PROGRAM = @INSTALL_PROGRAM@
++#INSTALL_DATA = @INSTALL_DATA@
+
+
+ CC = @CC@
+@@ -41,7 +41,7 @@
+ install: all installdirs
+ ${INSTALL_PROGRAM} dnsperf ${DESTDIR}${bindir}
+ ${INSTALL_PROGRAM} resperf ${DESTDIR}${bindir}
+- ${INSTALL_PROGRAM} resperf-report ${DESTDIR}${bindir}
++ ${INSTALL_SCRIPT} resperf-report ${DESTDIR}${bindir}
+ ${INSTALL_DATA} dnsperf.1 ${DESTDIR}${mandir}/man1
+ ${INSTALL_DATA} resperf.1 ${DESTDIR}${mandir}/man1
+