aboutsummaryrefslogtreecommitdiff
path: root/dns
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-07-28 22:37:50 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-07-28 22:37:50 +0000
commit3b1a46df55b34326a4542c2d15a61c545f1921f5 (patch)
tree7c22e6179f61f070708f7671a199513c12463ff4 /dns
parent8345b2f46718934abdc99bbe1806d7c9f78acef1 (diff)
downloadports-3b1a46df55b34326a4542c2d15a61c545f1921f5.tar.gz
ports-3b1a46df55b34326a4542c2d15a61c545f1921f5.zip
Notes
Diffstat (limited to 'dns')
-rw-r--r--dns/powerdns-devel/Makefile3
-rw-r--r--dns/powerdns-devel/files/configure.powerdns8
-rw-r--r--dns/powerdns-devel/files/patch-modules_ldapbackend_utils_hh42
-rw-r--r--dns/powerdns/Makefile3
-rw-r--r--dns/powerdns/files/configure.powerdns8
-rw-r--r--dns/powerdns/files/patch-modules_ldapbackend_utils_hh42
6 files changed, 96 insertions, 10 deletions
diff --git a/dns/powerdns-devel/Makefile b/dns/powerdns-devel/Makefile
index b98468facf87..3556b7544cbb 100644
--- a/dns/powerdns-devel/Makefile
+++ b/dns/powerdns-devel/Makefile
@@ -79,9 +79,10 @@ CONFIGURE_ARGS+= --disable-mysql
.if defined(WITH_LDAP)
USE_OPENLDAP?= YES
-USE_LIBTOOL_VER= 13
+USE_LIBTOOL_VER= 15
INSTALLS_SHLIB= YES
CONFIGURE_MODULES+= "ldap"
+CXXFLAGS+= -L${LOCALBASE}/lib
PLIST_SUB+= WITHLDAP=""
.else
PLIST_SUB+= WITHLDAP="@comment "
diff --git a/dns/powerdns-devel/files/configure.powerdns b/dns/powerdns-devel/files/configure.powerdns
index add922f57538..0bf780f4fba6 100644
--- a/dns/powerdns-devel/files/configure.powerdns
+++ b/dns/powerdns-devel/files/configure.powerdns
@@ -16,8 +16,8 @@ PostgreSQL "PostgreSQL driver" ON \
MySQL323 "MySQL 3.23 driver" OFF \
MySQL40 "MySQL 4.0 driver" OFF \
MySQL41 "MySQL 4.1 driver" OFF \
-OpenLDAP21 "OpenLDAP 2.1 backend" OFF \
OpenLDAP22 "OpenLDAP 2.2 backend" OFF \
+OpenLDAP23 "OpenLDAP 2.3 backend" OFF \
SQLite "SQLite backend" OFF \
Recursor "Build Recursor" OFF \
2> /tmp/checklist.tmp.$$
@@ -58,12 +58,12 @@ while [ "$1" ]; do
echo WITH_MYSQL_DRIVER=YES
echo WITH_MYSQL_VER?=41
;;
- \"OpenLDAP21\")
+ \"OpenLDAP22\")
echo WITH_LDAP=YES
;;
- \"OpenLDAP22\")
+ \"OpenLDAP23\")
echo WITH_LDAP=YES
- echo WANT_OPENLDAP_VER?=22
+ echo WANT_OPENLDAP_VER?=23
;;
\"SQLite\")
echo WITH_SQLITE=YES
diff --git a/dns/powerdns-devel/files/patch-modules_ldapbackend_utils_hh b/dns/powerdns-devel/files/patch-modules_ldapbackend_utils_hh
new file mode 100644
index 000000000000..6be2a52534e2
--- /dev/null
+++ b/dns/powerdns-devel/files/patch-modules_ldapbackend_utils_hh
@@ -0,0 +1,42 @@
+--- modules/ldapbackend/utils.hh.orig Sat Apr 23 23:40:15 2005
++++ modules/ldapbackend/utils.hh Thu Jul 28 09:03:14 2005
+@@ -73,7 +73,7 @@
+ }
+
+
+-inline string ip2ptr4( string ip )
++inline string ip2ptr4( const string& ip )
+ {
+ string ptr;
+ vector<string> parts;
+@@ -89,7 +89,7 @@
+ }
+
+
+-inline string ip2ptr6( string ip )
++inline string ip2ptr6( const string& ip )
+ {
+ string ptr, part, defstr;
+ vector<string> parts;
+@@ -114,6 +114,21 @@
+ }
+
+ return ptr + "ip6.arpa";
++}
++
++
++inline string strbind( const string& search, const string& replace, string subject )
++{
++ size_t pos = 0;
++
++
++ while( ( pos = subject.find( search, pos ) ) != string::npos )
++ {
++ subject.replace( pos, search.size(), replace );
++ pos += replace.size();
++ }
++
++ return subject;
+ }
+
+ #endif
diff --git a/dns/powerdns/Makefile b/dns/powerdns/Makefile
index b98468facf87..3556b7544cbb 100644
--- a/dns/powerdns/Makefile
+++ b/dns/powerdns/Makefile
@@ -79,9 +79,10 @@ CONFIGURE_ARGS+= --disable-mysql
.if defined(WITH_LDAP)
USE_OPENLDAP?= YES
-USE_LIBTOOL_VER= 13
+USE_LIBTOOL_VER= 15
INSTALLS_SHLIB= YES
CONFIGURE_MODULES+= "ldap"
+CXXFLAGS+= -L${LOCALBASE}/lib
PLIST_SUB+= WITHLDAP=""
.else
PLIST_SUB+= WITHLDAP="@comment "
diff --git a/dns/powerdns/files/configure.powerdns b/dns/powerdns/files/configure.powerdns
index add922f57538..0bf780f4fba6 100644
--- a/dns/powerdns/files/configure.powerdns
+++ b/dns/powerdns/files/configure.powerdns
@@ -16,8 +16,8 @@ PostgreSQL "PostgreSQL driver" ON \
MySQL323 "MySQL 3.23 driver" OFF \
MySQL40 "MySQL 4.0 driver" OFF \
MySQL41 "MySQL 4.1 driver" OFF \
-OpenLDAP21 "OpenLDAP 2.1 backend" OFF \
OpenLDAP22 "OpenLDAP 2.2 backend" OFF \
+OpenLDAP23 "OpenLDAP 2.3 backend" OFF \
SQLite "SQLite backend" OFF \
Recursor "Build Recursor" OFF \
2> /tmp/checklist.tmp.$$
@@ -58,12 +58,12 @@ while [ "$1" ]; do
echo WITH_MYSQL_DRIVER=YES
echo WITH_MYSQL_VER?=41
;;
- \"OpenLDAP21\")
+ \"OpenLDAP22\")
echo WITH_LDAP=YES
;;
- \"OpenLDAP22\")
+ \"OpenLDAP23\")
echo WITH_LDAP=YES
- echo WANT_OPENLDAP_VER?=22
+ echo WANT_OPENLDAP_VER?=23
;;
\"SQLite\")
echo WITH_SQLITE=YES
diff --git a/dns/powerdns/files/patch-modules_ldapbackend_utils_hh b/dns/powerdns/files/patch-modules_ldapbackend_utils_hh
new file mode 100644
index 000000000000..6be2a52534e2
--- /dev/null
+++ b/dns/powerdns/files/patch-modules_ldapbackend_utils_hh
@@ -0,0 +1,42 @@
+--- modules/ldapbackend/utils.hh.orig Sat Apr 23 23:40:15 2005
++++ modules/ldapbackend/utils.hh Thu Jul 28 09:03:14 2005
+@@ -73,7 +73,7 @@
+ }
+
+
+-inline string ip2ptr4( string ip )
++inline string ip2ptr4( const string& ip )
+ {
+ string ptr;
+ vector<string> parts;
+@@ -89,7 +89,7 @@
+ }
+
+
+-inline string ip2ptr6( string ip )
++inline string ip2ptr6( const string& ip )
+ {
+ string ptr, part, defstr;
+ vector<string> parts;
+@@ -114,6 +114,21 @@
+ }
+
+ return ptr + "ip6.arpa";
++}
++
++
++inline string strbind( const string& search, const string& replace, string subject )
++{
++ size_t pos = 0;
++
++
++ while( ( pos = subject.find( search, pos ) ) != string::npos )
++ {
++ subject.replace( pos, search.size(), replace );
++ pos += replace.size();
++ }
++
++ return subject;
+ }
+
+ #endif