aboutsummaryrefslogtreecommitdiff
path: root/editors/AbiWord
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2003-04-03 02:55:05 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2003-04-03 02:55:05 +0000
commit1e829055ffa354671b6c071843c5574508a6b96e (patch)
tree070f2ff3488990c8e927416c45d74bab1ff062db /editors/AbiWord
parent89d89ea85e4d163fdd2210a2196c3a741b3e104a (diff)
downloadports-1e829055ffa354671b6c071843c5574508a6b96e.tar.gz
ports-1e829055ffa354671b6c071843c5574508a6b96e.zip
Notes
Diffstat (limited to 'editors/AbiWord')
-rw-r--r--editors/AbiWord/Makefile13
-rw-r--r--editors/AbiWord/distinfo2
-rw-r--r--editors/AbiWord/files/patch-autogen.sh17
-rw-r--r--editors/AbiWord/files/patch-src_wp_ap_unix_gnome_ap_UnixGnomeApp.cpp11
4 files changed, 30 insertions, 13 deletions
diff --git a/editors/AbiWord/Makefile b/editors/AbiWord/Makefile
index 99352424f313..a9bda8c80bf9 100644
--- a/editors/AbiWord/Makefile
+++ b/editors/AbiWord/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= AbiWord
-PORTVERSION= 1.0.4
+PORTVERSION= 1.0.5
CATEGORIES= editors
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
http://www.abisource.com/downloads/Version-${PORTVERSION}/lf/
@@ -20,7 +20,8 @@ COMMENT= An open-source, cross-platform WYSIWYG word processor
BUILD_DEPENDS= unzip:${PORTSDIR}/archivers/unzip
LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png \
iconv.3:${PORTSDIR}/converters/libiconv \
- psiconv.8:${PORTSDIR}/converters/psiconv
+ psiconv.8:${PORTSDIR}/converters/psiconv \
+ aspell.15:${PORTSDIR}/textproc/aspell
DIST_SUBDIR= AbiWord
@@ -28,11 +29,14 @@ WRKSRC= ${WRKDIR}/abiword-${PORTVERSION}/abi
USE_X_PREFIX= yes
USE_AUTOMAKE= yes
+USE_AUTOMAKE_VER=14
+USE_AUTOCONF_VER=213
USE_GMAKE= yes
USE_REINPLACE= yes
USE_GNOMENG= yes
USE_GNOME= gtk12 gnomehier
WANT_GNOME= yes
+CONFIGURE_ARGS= --with-expat
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib -liconv"
MAKEFILE= GNUmakefile
@@ -57,6 +61,11 @@ PKGNAMESUFFIX= -gnome
BROKEN= "This port cannot be built when textproc/wv is installed because of a header conflict. Please remove textproc/wv, and resume the build. If textproc/wv is no longer installed, please remove ${LOCALBASE}/include/wv.h, and resume the AbiWord build"
.endif
+post-patch:
+ @${REINPLACE_CMD} -e 's|%%AUTOMAKE%%|${AUTOMAKE}|g ; \
+ s|%%ACLOCAL%%|${ACLOCAL}|g ; \
+ s|%%AUTOCONF%%|${AUTOCONF}|g' ${WRKSRC}/autogen.sh
+
pre-configure:
@cd ${WRKSRC} && ${TOUCH} NEWS README AUTHORS ChangeLog INSTALL
@cd ${WRKSRC}/ac-helpers && ${RM} -f install-sh mkinstalldirs missing
diff --git a/editors/AbiWord/distinfo b/editors/AbiWord/distinfo
index 6dd051c40b56..a53f6ba81ff8 100644
--- a/editors/AbiWord/distinfo
+++ b/editors/AbiWord/distinfo
@@ -1 +1 @@
-MD5 (AbiWord/abiword-1.0.4.tar.gz) = fec2f2770c29afe0d30e653b5d1d40bb
+MD5 (AbiWord/abiword-1.0.5.tar.gz) = dfe86fb72afc4008e51504fd693b224e
diff --git a/editors/AbiWord/files/patch-autogen.sh b/editors/AbiWord/files/patch-autogen.sh
index 57a58a879794..03097391244d 100644
--- a/editors/AbiWord/files/patch-autogen.sh
+++ b/editors/AbiWord/files/patch-autogen.sh
@@ -1,14 +1,11 @@
-
-$FreeBSD$
-
--- autogen.sh.orig Mon Mar 25 07:41:49 2002
-+++ autogen.sh Tue Apr 9 12:35:41 2002
++++ autogen.sh Mon Mar 24 15:53:30 2003
@@ -10,20 +10,20 @@
set -e
-automake --version | perl -ne 'if (/\(GNU automake\) ([0-9].[0-9])/) {print; if ($1 < 1.4) {exit 1;}}'
-+automake14 --version | perl -ne 'if (/\(GNU automake\) ([0-9].[0-9])/) {print; if ($1 < 1.4) {exit 1;}}'
++%%AUTOMAKE%% --version | perl -ne 'if (/\(GNU automake\) ([0-9].[0-9])/) {print; if ($1 < 1.4) {exit 1;}}'
if [ $? -ne 0 ]; then
echo "Error: you need automake 1.4 or later. Please upgrade."
@@ -16,14 +13,14 @@ $FreeBSD$
fi
-if test ! -d `aclocal --print-ac-dir`; then
-+if test ! -d `aclocal14 --print-ac-dir`; then
++if test ! -d `%%ACLOCAL%% --print-ac-dir`; then
echo "Bad aclocal (automake) installation"
exit 1
fi
for script in `cd ac-helpers/fallback; echo *.m4`; do
- if test -r `aclocal --print-ac-dir`/$script; then
-+ if test -r `aclocal14 --print-ac-dir`/$script; then
++ if test -r `%%ACLOCAL%% --print-ac-dir`/$script; then
# Perhaps it was installed recently
rm -f ac-helpers/$script
else
@@ -32,14 +29,14 @@ $FreeBSD$
# Produce aclocal.m4, so autoconf gets the automake macros it needs
echo "Creating aclocal.m4..."
-aclocal -I ac-helpers
-+aclocal14 -I ac-helpers
++%%ACLOCAL%% -I ac-helpers
# autoheader
# Produce all the `GNUmakefile.in's and create neat missing things
# like `install-sh', etc.
-automake --add-missing --copy --foreign
-+automake14 --add-missing --copy --foreign
++%%AUTOMAKE%% --add-missing --copy --foreign
# If there's a config.cache file, we may need to delete it.
# If we have an existing configure script, save a copy for comparison.
@@ -48,7 +45,7 @@ $FreeBSD$
# Produce ./configure
echo "Creating configure..."
-autoconf
-+autoconf213
++%%AUTOCONF%%
echo ""
echo "You can run ./configure now."
diff --git a/editors/AbiWord/files/patch-src_wp_ap_unix_gnome_ap_UnixGnomeApp.cpp b/editors/AbiWord/files/patch-src_wp_ap_unix_gnome_ap_UnixGnomeApp.cpp
new file mode 100644
index 000000000000..046837b5cee2
--- /dev/null
+++ b/editors/AbiWord/files/patch-src_wp_ap_unix_gnome_ap_UnixGnomeApp.cpp
@@ -0,0 +1,11 @@
+--- src/wp/ap/unix/gnome/ap_UnixGnomeApp.cpp.orig Mon Mar 24 16:09:59 2003
++++ src/wp/ap/unix/gnome/ap_UnixGnomeApp.cpp Mon Mar 24 16:10:31 2003
+@@ -933,7 +933,7 @@
+ // actually print
+ s_actuallyPrint ( pDoc, pGraphics,
+ pPrintView, "bonobo_printed_document",
+- 1, false,
++ 1, false, false,
+ width, height,
+ 1, iPagesToPrint ) ;
+