aboutsummaryrefslogtreecommitdiff
path: root/editors/abiword-devel/files
diff options
context:
space:
mode:
authorAlexander Langer <alex@FreeBSD.org>2000-06-27 15:59:36 +0000
committerAlexander Langer <alex@FreeBSD.org>2000-06-27 15:59:36 +0000
commit160c7c4226c4539db08828b89066aa1a09a66e7e (patch)
treec80eab4339667668e802c3ca96602a9af88dad70 /editors/abiword-devel/files
parent004b543e664c08c1aa05de7329c602e8ce560004 (diff)
downloadports-160c7c4226c4539db08828b89066aa1a09a66e7e.tar.gz
ports-160c7c4226c4539db08828b89066aa1a09a66e7e.zip
Notes
Diffstat (limited to 'editors/abiword-devel/files')
-rw-r--r--editors/abiword-devel/files/patch-ap26
-rw-r--r--editors/abiword-devel/files/patch-aq28
2 files changed, 31 insertions, 23 deletions
diff --git a/editors/abiword-devel/files/patch-ap b/editors/abiword-devel/files/patch-ap
index a006ac936e31..6a8bcc348fe0 100644
--- a/editors/abiword-devel/files/patch-ap
+++ b/editors/abiword-devel/files/patch-ap
@@ -1,22 +1,30 @@
---- wp/Makefile Tue Feb 29 07:34:31 2000
-+++ wp/Makefile.new Sun May 14 21:15:19 2000
-@@ -44,10 +44,16 @@
+--- wp/Makefile Fri May 26 13:51:51 2000
++++ wp/Makefile.new Thu Jun 22 17:11:49 2000
+@@ -44,10 +44,24 @@
@$(subst xxxx,$(CANON_AppDir),$(VERIFY_DIRECTORY))
@$(subst xxxx,$(CANON_AppDir)/strings,$(VERIFY_DIRECTORY))
@$(subst xxxx,$(CANON_AppDir)/help,$(VERIFY_DIRECTORY))
+ @$(subst xxxx,$(CANON_AppDir)/help/en-US,$(VERIFY_DIRECTORY))
++ @$(subst xxxx,$(CANON_AppDir)/help/en-US/images,$(VERIFY_DIRECTORY))
++ @$(subst xxxx,$(CANON_AppDir)/help/fr-FR,$(VERIFY_DIRECTORY))
++ @$(subst xxxx,$(CANON_AppDir)/help/fr-FR/images,$(VERIFY_DIRECTORY))
++ @$(subst xxxx,$(CANON_AppDir)/help/es-ES,$(VERIFY_DIRECTORY))
@$(subst xxxx,$(CANON_AppDir)/sample,$(VERIFY_DIRECTORY))
+ @$(subst xxxx,$(CANON_AppDir)/sample/en-US,$(VERIFY_DIRECTORY))
@$(ABICOPY) $(USERDIR)/wp/readme.txt $(CANON_AppDir)
-+ @$(ABICHMOD) ugo=r $(CANON_AppDir)/readme.txt
@$(ABICOPY) $(USERDIR)/wp/system.profile $(CANON_AppDir)
-+ @$(ABICHMOD) ugo=r $(CANON_AppDir)/system.profile
@$(ABICOPY) $(USERDIR)/wp/strings/*.strings $(CANON_AppDir)/strings
-- (cd $(USERDIR)/wp/help; tar cf - $(CANON_Lang)/*.*) | (cd $(CANON_AppDir)/help; tar xf -)
+- (cd $(USERDIR)/wp/help; tar cf - ./*.* $(CANON_Lang)/*.* $(CANON_Lang)/*/*.*) | (cd $(CANON_AppDir)/help; tar xf -)
- (cd $(USERDIR)/wp/sample; tar cf - $(CANON_Lang)/*.*) | (cd $(CANON_AppDir)/sample; tar xf -)
-
-+ @$(ABICHMOD) ugo=r $(CANON_AppDir)/strings/*.strings
++ @$(ABICOPY) $(USERDIR)/wp/help/*.html $(CANON_AppDir)/help
++ @$(ABICOPY) $(USERDIR)/wp/help/*.gif $(CANON_AppDir)/help
+ @$(ABICOPY) $(USERDIR)/wp/help/en-US/*.html $(CANON_AppDir)/help/en-US
-+ @$(ABICHMOD) ugo=r $(CANON_AppDir)/help/en-US/*.html
++ @$(ABICOPY) $(USERDIR)/wp/help/en-US/images/*.gif $(CANON_AppDir)/help/en-US/images
++ @$(ABICOPY) $(USERDIR)/wp/help/en-US/images/*.jpg $(CANON_AppDir)/help/en-US/images
++ @$(ABICOPY) $(USERDIR)/wp/help/en-US/images/*.png $(CANON_AppDir)/help/en-US/images
++ @$(ABICOPY) $(USERDIR)/wp/help/fr-FR/*.html $(CANON_AppDir)/help/fr-FR
++ @$(ABICOPY) $(USERDIR)/wp/help/fr-FR/images/*.gif $(CANON_AppDir)/help/fr-FR/images
++ @$(ABICOPY) $(USERDIR)/wp/help/fr-FR/images/*.jpg $(CANON_AppDir)/help/fr-FR/images
++ @$(ABICOPY) $(USERDIR)/wp/help/es-ES/*.html $(CANON_AppDir)/help/es-ES
+ @$(ABICOPY) $(USERDIR)/wp/sample/en-US/*.abw $(CANON_AppDir)/sample/en-US
-+ @$(ABICHMOD) ugo=r $(CANON_AppDir)/sample/en-US/*.abw
diff --git a/editors/abiword-devel/files/patch-aq b/editors/abiword-devel/files/patch-aq
index c541d8b5d2f3..cef4e383e24a 100644
--- a/editors/abiword-devel/files/patch-aq
+++ b/editors/abiword-devel/files/patch-aq
@@ -1,17 +1,6 @@
---- config/abi_defs.mk Mon Mar 13 14:48:16 2000
-+++ config/abi_defs.mk.new Sat May 13 16:07:19 2000
-@@ -121,7 +121,9 @@
- ##################################################################
- ##################################################################
-
--ABICOPY=cp
-+ABICOPY = cp
-+ABICHMOD = chmod
-+ABIMKDIR = mkdir -m u=rwx,go=rx
-
- ifdef ABISOURCE_LICENSED_TRADEMARKS
- ABI_TMDEFS= -DABISOURCE_LICENSED_TRADEMARKS
-@@ -287,11 +289,11 @@
+--- config/abi_defs.mk Fri Jun 9 15:48:49 2000
++++ config/abi_defs.mk.new Thu Jun 22 16:32:03 2000
+@@ -124,11 +124,11 @@
## INSTALL program...
define MAKE_OBJDIR
@@ -24,4 +13,15 @@
+if test ! -d xxxx; then rm -rf xxxx; $(ABIMKDIR) -p xxxx; fi
endef
+ ifeq ($(OS_NAME), WIN32)
+@@ -160,7 +160,9 @@
##################################################################
+ ##################################################################
+
+-ABICOPY=cp
++ABICOPY = cp
++ABICHMOD = chmod
++ABIMKDIR = mkdir -m u=rwx,go=rx
+
+ ifdef ABISOURCE_LICENSED_TRADEMARKS
+ ABI_TMDEFS= -DABISOURCE_LICENSED_TRADEMARKS