aboutsummaryrefslogtreecommitdiff
path: root/editors/abiword-plugins
diff options
context:
space:
mode:
authorJeremy Messenger <mezz@FreeBSD.org>2004-12-04 22:20:53 +0000
committerJeremy Messenger <mezz@FreeBSD.org>2004-12-04 22:20:53 +0000
commit1b74ed420c4dd36b4e27b7813d5542c247447335 (patch)
tree92bed9c02cba6913729152af68d2a9598f9dc044 /editors/abiword-plugins
parent31547964e9a8002c597c2441930d5d91fee0efa9 (diff)
downloadports-1b74ed420c4dd36b4e27b7813d5542c247447335.tar.gz
ports-1b74ed420c4dd36b4e27b7813d5542c247447335.zip
Notes
Diffstat (limited to 'editors/abiword-plugins')
-rw-r--r--editors/abiword-plugins/Makefile358
-rw-r--r--editors/abiword-plugins/files/patch-tools::aiksaurus::xp::AiksaurusABI.cpp16
-rw-r--r--editors/abiword-plugins/pkg-descr9
-rw-r--r--editors/abiword-plugins/pkg-plist30
4 files changed, 413 insertions, 0 deletions
diff --git a/editors/abiword-plugins/Makefile b/editors/abiword-plugins/Makefile
new file mode 100644
index 000000000000..20953c389748
--- /dev/null
+++ b/editors/abiword-plugins/Makefile
@@ -0,0 +1,358 @@
+# New ports collection makefile for: abiword-plugins
+# Date created: 13 June 2004
+# Whom: FreeBSD GNOME Team <gnome@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= abiword
+PORTVERSION= 2.2.1
+CATEGORIES= editors
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
+ http://www.abisource.com/downloads/Version-${PORTVERSION}/lf/
+MASTER_SITE_SUBDIR= abiword
+PKGNAMESUFFIX= -plugins
+DIST_SUBDIR= AbiWord
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= Multi-plugins for AbiWord
+
+BUILD_DEPENDS= abiword:${PORTSDIR}/editors/abiword
+RUN_DEPENDS= abiword:${PORTSDIR}/editors/abiword
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_GNOME= gnometarget gtk20
+WANT_GNOME= yes
+USE_X_PREFIX= yes
+USE_REINPLACE= yes
+USE_LIBTOOL_VER=15
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_ARGS= --disable-all
+MAKEFILE= GNUmakefile
+
+WRKSRC= ${WRKDIR}/abiword-${PORTVERSION}/abiword-plugins
+MD5_FILE= ${.CURDIR}/../abiword/distinfo
+
+ABIVERSION= 2.2
+PLIST_SUB+= "ABIVERSION=${ABIVERSION}"
+
+# NOTE: Please, keep those knobs in the ABC's order.
+
+.if defined(WITH_AIKSAURUS) || defined(PACKAGE_BUILDING)
+LIB_DEPENDS+= AiksaurusGTK-1.2.0:${PORTSDIR}/textproc/aiksaurus-gtk
+CONFIGURE_ARGS+= --enable-aiksaurus
+PLIST_SUB+= AIKSAURUS:=""
+.else
+PLIST_SUB+= AIKSAURUS:="@comment "
+.endif
+
+.if defined(WITH_APPLIX) || defined(PACKAGE_BUILDING)
+CONFIGURE_ARGS+= --enable-applix
+PLIST_SUB+= APPLIX:=""
+.else
+PLIST_SUB+= APPLIX:="@comment "
+.endif
+
+.if defined(WITH_BABELFISH) || defined(PACKAGE_BUILDING)
+CONFIGURE_ARGS+= --enable-babelfish
+PLIST_SUB+= BABELFISH:=""
+.else
+PLIST_SUB+= BABELFISH:="@comment "
+.endif
+
+.if defined(WITH_BMP) || defined(PACKAGE_BUILDING)
+CONFIGURE_ARGS+= --enable-bmp
+PLIST_SUB+= BMP:=""
+.else
+PLIST_SUB+= BMP:="@comment "
+.endif
+
+.if defined(WITH_BZ2ABW) || defined(PACKAGE_BUILDING)
+CONFIGURE_ARGS+= --enable-bz2abw \
+ --with-bzip2=/usr
+PLIST_SUB+= BZ2ABW:=""
+.else
+PLIST_SUB+= BZ2ABW:="@comment "
+.endif
+
+.if defined(WITH_CLARISWORKS) # Untest...
+CONFIGURE_ARGS+= --enable-clarisworks
+PLIST_SUB+= CLARISWORKS:=""
+.else
+PLIST_SUB+= CLARISWORKS:="@comment "
+.endif
+
+.if defined(WITH_COMMAND) || defined(PACKAGE_BUILDING)
+CONFIGURE_ARGS+= --enable-abicommand
+PLIST_SUB+= COMMAND:=""
+.else
+PLIST_SUB+= COMMAND:="@comment "
+.endif
+
+.if defined(WITH_DOCBOOK) # Untest...
+CONFIGURE_ARGS+= --enable-docbook
+PLIST_SUB+= DOCBOOK:=""
+.else
+PLIST_SUB+= DOCBOOK:="@comment "
+.endif
+
+.if defined(WITH_EML) # Untest...
+CONFIGURE_ARGS+= --enable-eml
+PLIST_SUB+= EML:=""
+.else
+PLIST_SUB+= EML:="@comment "
+.endif
+
+.if defined(WITH_FREETRANSLATION) || defined(PACKAGE_BUILDING)
+CONFIGURE_ARGS+= --enable-freetranslation
+PLIST_SUB+= FREETRANSLATION:=""
+.else
+PLIST_SUB+= FREETRANSLATION:="@comment "
+.endif
+
+.if defined(WITH_GDICT)
+RUN_DEPENDS+= gnome-dictionary:${PORTSDIR}/deskutils/gnomeutils2
+CONFIGURE_ARGS+= --enable-gdict
+PLIST_SUB+= GDICT:=""
+.else
+PLIST_SUB+= GDICT:="@comment "
+.endif
+
+.if defined(WITH_GOOGLE) || defined(PACKAGE_BUILDING)
+CONFIGURE_ARGS+= --enable-google
+PLIST_SUB+= GOOGLE:=""
+.else
+PLIST_SUB+= GOOGLE:="@comment "
+.endif
+
+.if defined(WITH_HANCOM) # Untest...
+CONFIGURE_ARGS+= --enable-hancom
+PLIST_SUB+= HANCOM:=""
+.else
+PLIST_SUB+= HANCOM:="@comment "
+.endif
+
+.if defined(WITH_HRTEXT) # Untest...
+CONFIGURE_ARGS+= --enable-hrtext
+PLIST_SUB+= HRTEXT:=""
+.else
+PLIST_SUB+= HRTEXT:="@comment "
+.endif
+
+.if defined(WITH_JPEG) || defined(PACKAGE_BUILDING)
+CONFIGURE_ARGS+= --enable-jpeg
+PLIST_SUB+= JPEG:=""
+.else
+PLIST_SUB+= JPEG:="@comment "
+.endif
+
+.if defined(WITH_LATEX) # Untest...
+CONFIGURE_ARGS+= --enable-latex
+PLIST_SUB+= LATEX:=""
+.else
+PLIST_SUB+= LATEX:="@comment "
+.endif
+
+.if defined(WITH_MSWRITE) || defined(PACKAGE_BUILDING)
+CONFIGURE_ARGS+= --enable-mswrite
+PLIST_SUB+= MSWRITE:=""
+.else
+PLIST_SUB+= MSWRITE:="@comment "
+.endif
+
+.if defined(WITH_NROFF) # Untest...
+CONFIGURE_ARGS+= --enable-nroff
+PLIST_SUB+= NROFF:=""
+.else
+PLIST_SUB+= NROFF:="@comment "
+.endif
+
+.if defined(WITH_OPENWRITER) || defined(PACKAGE_BUILDING)
+CONFIGURE_ARGS+= --enable-OpenWriter
+PLIST_SUB+= OPENWRITER:=""
+.else
+PLIST_SUB+= OPENWRITER:="@comment "
+.endif
+
+.if defined(WITH_PDB) # Untest...
+CONFIGURE_ARGS+= --enable-pdb
+PLIST_SUB+= PDB:=""
+.else
+PLIST_SUB+= PDB:="@comment "
+.endif
+
+.if defined(WITH_SDW)
+USE_GNOME+= libgsf
+CONFIGURE_ARGS+= --enable-sdw
+PLIST_SUB+= SDW:=""
+.else
+PLIST_SUB+= SDW:="@comment "
+.endif
+
+.if defined(WITH_SHELL) || defined(PACKAGE_BUILDING)
+CONFIGURE_ARGS+= --enable-shell
+PLIST_SUB+= SHELL:=""
+.else
+PLIST_SUB+= SHELL:="@comment "
+.endif
+
+.if defined(WITH_T602) # Untest...
+CONFIGURE_ARGS+= --enable-t602
+PLIST_SUB+= T602:=""
+.else
+PLIST_SUB+= T602:="@comment "
+.endif
+
+.if defined(WITH_URLDICT) || defined(PACKAGE_BUILDING)
+CONFIGURE_ARGS+= --enable-urldict
+PLIST_SUB+= URLDICT:=""
+.else
+PLIST_SUB+= URLDICT:="@comment "
+.endif
+
+.if defined(WITH_WIKIPEDIA) || defined(PACKAGE_BUILDING)
+CONFIGURE_ARGS+= --enable-wikipedia
+PLIST_SUB+= WIKIPEDIA:=""
+.else
+PLIST_SUB+= WIKIPEDIA:="@comment "
+.endif
+
+.if defined(WITH_WMF) || defined(PACKAGE_BUILDING)
+LIB_DEPENDS+= wmf.2:${PORTSDIR}/graphics/libwmf
+CONFIGURE_ARGS+= --enable-wmf
+PLIST_SUB+= WMF:=""
+.else
+PLIST_SUB+= WMF:="@comment "
+.endif
+
+.if defined(WITH_WORDPERFECT) || defined(PACKAGE_BUILDING)
+LIB_DEPENDS+= wpd-1.7:${PORTSDIR}/textproc/libwpd
+CONFIGURE_ARGS+= --enable-wordperfect
+PLIST_SUB+= WORDPERFECT:=""
+.else
+PLIST_SUB+= WORDPERFECT:="@comment "
+.endif
+
+.if defined(WITH_XSLFO) || defined(PACKAGE_BUILDING)
+CONFIGURE_ARGS+= --enable-xsl-fo
+PLIST_SUB+= XSLFO:=""
+.else
+PLIST_SUB+= XSLFO:="@comment "
+.endif
+
+.include <bsd.port.pre.mk>
+
+.if ${HAVE_GNOME:Mnautilus2}!="" && ${HAVE_GNOME:Mlibgnomeprintui}!=""
+USE_GNOME+= nautilus2 libgnomeprintui
+CONFIGURE_ARGS+= --enable-gnome
+.endif
+
+.if ${HAVE_GNOME:Mgtk20}!=""
+CONFIGURE_ARGS+= --enable-AbiGdkPixbuf
+PLIST_SUB+= GTKPIXBUF:=""
+.else
+PLIST_SUB+= GTKPIXBUF:="@comment "
+.endif
+
+.if ${HAVE_GNOME:Mlibrsvg2}!=""
+CONFIGURE_ARGS+= --enable-librsvg
+PLIST_SUB+= SVG:=""
+.else
+PLIST_SUB+= SVG:="@comment "
+.endif
+
+pre-everything::
+ @${ECHO_MSG} "You may specify the following on the command line:"
+ @${ECHO_MSG} ""
+.if !defined(WITH_AIKSAURUS)
+ @${ECHO_MSG} "WITH_AIKSAURUS=yes English language thesaurus."
+.endif
+.if !defined(WITH_APPLIX)
+ @${ECHO_MSG} "WITH_APPLIX=yes Import/Export Applix Word files."
+.endif
+.if !defined(WITH_BABELFISH)
+ @${ECHO_MSG} "WITH_BABELFISH=yes Translate selected text."
+.endif
+.if !defined(WITH_BMP)
+ @${ECHO_MSG} "WITH_BMP=yes View Bitmap Images."
+.endif
+.if !defined(WITH_BZ2ABW)
+ @${ECHO_MSG} "WITH_BZ2ABW=yes Import/Export BZ2 compressed AbiWord files."
+.endif
+.if !defined(WITH_CLARISWORKS)
+ @${ECHO_MSG} "WITH_CLARISWORKS=yes Import/Export Clarisworks files."
+.endif
+.if !defined(WITH_COMMAND)
+ @${ECHO_MSG} "WITH_COMMAND=yes Allows command line control of AbiWord."
+.endif
+.if !defined(WITH_DOCBOOK)
+ @${ECHO_MSG} "WITH_DOCBOOK=yes Import/export Docbook files."
+.endif
+.if !defined(WITH_EML)
+ @${ECHO_MSG} "WITH_EML=yes Import/export as MS Outlook Email files."
+.endif
+.if !defined(WITH_FREETRANSLATION)
+ @${ECHO_MSG} "WITH_FREETRANSLATION=yes Translate selected text."
+.endif
+.if !defined(WITH_GDICT)
+ @${ECHO_MSG} "WITH_GDICT=yes Look up definitions of selected text."
+.endif
+.if !defined(WITH_GOOGLE)
+ @${ECHO_MSG} "WITH_GOOGLE=yes Search Google for your selected text."
+.endif
+.if !defined(WITH_HANCOM)
+ @${ECHO_MSG} "WITH_HANCOM=yes Hancom Word Importer. Only does text."
+.endif
+.if !defined(WITH_HRTEXT)
+ @${ECHO_MSG} "WITH_HRTEXT=yes Export text with "newsgroup" markup."
+.endif
+.if !defined(WITH_JPEG)
+ @${ECHO_MSG} "WITH_JPEG=yes View JPEG Images."
+.endif
+.if !defined(WITH_LATEX)
+ @${ECHO_MSG} "WITH_LATEX=yes LaTeX export."
+.endif
+.if !defined(WITH_MSWRITE)
+ @${ECHO_MSG} "WITH_MSWRITE=yes Import MSWrite files."
+.endif
+.if !defined(WITH_NROFF)
+ @${ECHO_MSG} "WITH_NROFF=yes Nroff/Man file format."
+.endif
+.if !defined(WITH_OPENWRITER)
+ @${ECHO_MSG} "WITH_OPENWRITER=yes Import/export OpenOffice files."
+.endif
+.if !defined(WITH_PDB)
+ @${ECHO_MSG} "WITH_PDB=yes Import/export Palm Database files."
+.endif
+.if !defined(WITH_SDW)
+ @${ECHO_MSG} "WITH_SDW=yes Import StarOffice 5.x files."
+.endif
+.if !defined(WITH_SHELL)
+ @${ECHO_MSG} "WITH_SHELL=yes Execute shell commands from within AbiWord."
+.endif
+.if !defined(WITH_T602)
+ @${ECHO_MSG} "WITH_T602=yes Import T602 files."
+.endif
+.if !defined(WITH_URLDICT)
+ @${ECHO_MSG} "WITH_URLDICT=yes Url dictionary."
+.endif
+.if !defined(WITH_WIKIPEDIA)
+ @${ECHO_MSG} "WITH_WIKIPEDIA=yes Search online encyclopedia for selected text."
+.endif
+.if !defined(WITH_WMF)
+ @${ECHO_MSG} "WITH_WMF=yes View Windows Metafiles."
+.endif
+.if !defined(WITH_WORDPERFECT)
+ @${ECHO_MSG} "WITH_WORDPERFECT=yes Import/export Wordperfect files."
+.endif
+.if !defined(WITH_XSLFO)
+ @${ECHO_MSG} "WITH_XSLFO=yes Import/export XSL-FO."
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|[$$]abi_plugin_source/../wv|${LOCALBASE}/include/wv|g' \
+ ${WRKSRC}/configure
+
+.include <bsd.port.post.mk>
diff --git a/editors/abiword-plugins/files/patch-tools::aiksaurus::xp::AiksaurusABI.cpp b/editors/abiword-plugins/files/patch-tools::aiksaurus::xp::AiksaurusABI.cpp
new file mode 100644
index 000000000000..a395724db32f
--- /dev/null
+++ b/editors/abiword-plugins/files/patch-tools::aiksaurus::xp::AiksaurusABI.cpp
@@ -0,0 +1,16 @@
+--- tools/aiksaurus/xp/AiksaurusABI.cpp.orig Fri Aug 13 21:09:34 2004
++++ tools/aiksaurus/xp/AiksaurusABI.cpp Fri Aug 13 21:10:33 2004
+@@ -310,11 +310,11 @@
+ pView->extSelTo(FV_DOCPOS_EOW_SELECT);
+
+ // Now we will figure out what word to look up when we open our dialog.
+- char* search = "";
++ char* search = NULL;
+ if (!pView->isSelectionEmpty())
+ {
+ // We need to get the Ascii version of the current word.
+- UT_UCS4Char * ucs4ST;
++ UT_UCS4Char * ucs4ST;
+ pView->getSelectionText(*&ucs4ST);
+ search = AiksaurusABI_ucsToAscii(
+ ucs4ST
diff --git a/editors/abiword-plugins/pkg-descr b/editors/abiword-plugins/pkg-descr
new file mode 100644
index 000000000000..e2e64357ca76
--- /dev/null
+++ b/editors/abiword-plugins/pkg-descr
@@ -0,0 +1,9 @@
+AbiWord Plugins extend AbiWord in various ways. Note that some of these
+plugins are not available on all platforms that AbiWord supports.
+
+The plugins are often packaged as bundles for your convenience. One bundle is
+comprised of import and export plugins, which read and write various file and
+component formats, and the other bundle is comprised of tools and utilities
+that perform various helpful tasks from within AbiWord.
+
+WWW: http://www.abisource.com/twiki/bin/view/Abiword/PluginMatrix
diff --git a/editors/abiword-plugins/pkg-plist b/editors/abiword-plugins/pkg-plist
new file mode 100644
index 000000000000..28c8a67f4a93
--- /dev/null
+++ b/editors/abiword-plugins/pkg-plist
@@ -0,0 +1,30 @@
+%%AIKSAURUS:%%lib/AbiWord-%%ABIVERSION%%/plugins/libAbiAikSaurus.so
+%%APPLIX:%%lib/AbiWord-%%ABIVERSION%%/plugins/libAbiApplix.so
+%%BMP:%%lib/AbiWord-%%ABIVERSION%%/plugins/libAbiBMP.so
+%%BZ2ABW:%%lib/AbiWord-%%ABIVERSION%%/plugins/libAbiBZ2.so
+%%BABELFISH:%%lib/AbiWord-%%ABIVERSION%%/plugins/libAbiBabelfish.so
+%%CLARISWORKS:%%lib/AbiWord-%%ABIVERSION%%/plugins/libAbiClarisWorks.so
+%%COMMAND:%%lib/AbiWord-%%ABIVERSION%%/plugins/libAbiCommand.so
+%%DOCBOOK:%%lib/AbiWord-%%ABIVERSION%%/plugins/libAbiDocBook.so
+%%EML:%%lib/AbiWord-%%ABIVERSION%%/plugins/libAbiEML.so
+%%FREETRANSLATION:%%lib/AbiWord-%%ABIVERSION%%/plugins/libAbiFreeTranslation.so
+%%GDICT:%%lib/AbiWord-%%ABIVERSION%%/plugins/libAbiGdict.so
+%%GTKPIXBUF:%%lib/AbiWord-%%ABIVERSION%%/plugins/libAbiGdkPixbuf.so
+%%GOOGLE:%%lib/AbiWord-%%ABIVERSION%%/plugins/libAbiGoogle.so
+%%HRTEXT:%%lib/AbiWord-%%ABIVERSION%%/plugins/libAbiHRText.so
+%%HANCOM:%%lib/AbiWord-%%ABIVERSION%%/plugins/libAbiHancom.so
+%%JPEG:%%lib/AbiWord-%%ABIVERSION%%/plugins/libAbiJPEG.so
+%%LATEX:%%lib/AbiWord-%%ABIVERSION%%/plugins/libAbiLaTeX.so
+%%MSWRITE:%%lib/AbiWord-%%ABIVERSION%%/plugins/libAbiMSWrite.so
+%%NROFF:%%lib/AbiWord-%%ABIVERSION%%/plugins/libAbiNroff.so
+%%OPENWRITER:%%lib/AbiWord-%%ABIVERSION%%/plugins/libAbiOpenWriter.so
+%%PDB:%%lib/AbiWord-%%ABIVERSION%%/plugins/libAbiPalmDoc.so
+%%SVG:%%lib/AbiWord-%%ABIVERSION%%/plugins/libAbiRSVG.so
+%%SDW:%%lib/AbiWord-%%ABIVERSION%%/plugins/libAbiSDW.so
+%%SHELL:%%lib/AbiWord-%%ABIVERSION%%/plugins/libAbiScriptHappy.so
+%%T602:%%lib/AbiWord-%%ABIVERSION%%/plugins/libAbiT602.so
+%%URLDICT:%%lib/AbiWord-%%ABIVERSION%%/plugins/libAbiURLDict.so
+%%WMF:%%lib/AbiWord-%%ABIVERSION%%/plugins/libAbiWMF.so
+%%WIKIPEDIA:%%lib/AbiWord-%%ABIVERSION%%/plugins/libAbiWikipedia.so
+%%WORDPERFECT:%%lib/AbiWord-%%ABIVERSION%%/plugins/libAbiWordPerfect.so
+%%XSLFO:%%lib/AbiWord-%%ABIVERSION%%/plugins/libAbiXSLFO.so