aboutsummaryrefslogtreecommitdiff
path: root/editors/abiword-plugins
diff options
context:
space:
mode:
authorJeremy Messenger <mezz@FreeBSD.org>2007-10-21 03:04:37 +0000
committerJeremy Messenger <mezz@FreeBSD.org>2007-10-21 03:04:37 +0000
commit421763ddb45c6ed246e3e2ad80c1a8ef96232d6c (patch)
treee27604bcd644d0fee4c9b1e97e83dffb45a44f78 /editors/abiword-plugins
parent28c8e95f4a6aa1b4d061f3bf1d8018433f41c608 (diff)
downloadports-421763ddb45c6ed246e3e2ad80c1a8ef96232d6c.tar.gz
ports-421763ddb45c6ed246e3e2ad80c1a8ef96232d6c.zip
Notes
Diffstat (limited to 'editors/abiword-plugins')
-rw-r--r--editors/abiword-plugins/Makefile12
-rw-r--r--editors/abiword-plugins/options31
2 files changed, 40 insertions, 3 deletions
diff --git a/editors/abiword-plugins/Makefile b/editors/abiword-plugins/Makefile
index 50a7d2da82e0..106faae4edd5 100644
--- a/editors/abiword-plugins/Makefile
+++ b/editors/abiword-plugins/Makefile
@@ -32,7 +32,7 @@ CONFIGURE_ARGS= --disable-all
MAKEFILE= GNUmakefile
WRKSRC= ${WRKDIR}/abiword-${PORTVERSION}/abiword-plugins
-MD5_FILE= ${.CURDIR}/../abiword/distinfo
+MD5_FILE= ${.CURDIR}/usr/ports/editors/abiword/distinfo
ABIVERSION= 2.4
PLIST_SUB+= ABIVERSION=${ABIVERSION}
@@ -41,6 +41,12 @@ EXTERNALS= MSVC* abipbx abiword-docs expat fribidi libiconv libpng pbx \
popt wv zlib
EXTRACT_AFTER_ARGS=| ${TAR} -xpf - ${EXTERNALS:C,^,--exclude ${DISTNAME}/,}
+.if !defined(WITHOUT_OPTIONS)
+.include "${.CURDIR}/options"
+.endif
+
+.include <bsd.port.pre.mk>
+
# NOTE: Please, keep those knobs in the ABC's order.
.if defined(WITH_AIKSAURUS) || defined(PACKAGE_BUILDING)
@@ -270,8 +276,6 @@ PLIST_SUB+= XSLFO:=""
PLIST_SUB+= XSLFO:="@comment "
.endif
-.include <bsd.port.pre.mk>
-
#.if ${HAVE_GNOME:Mnautilus2}!="" && ${HAVE_GNOME:Mlibgnomeprintui}!=""
#USE_GNOME+= nautilus2 libgnomeprintui
#CONFIGURE_ARGS+= --enable-gnome
@@ -284,6 +288,7 @@ PLIST_SUB+= SVG:=""
PLIST_SUB+= SVG:="@comment "
.endif
+.if defined(WITHOUT_OPTIONS)
pre-everything::
@${ECHO_MSG} "You may specify the following on the command line:"
@${ECHO_MSG} ""
@@ -385,6 +390,7 @@ pre-everything::
.if !defined(WITHOUT_XSLFO)
@${ECHO_MSG} "WITHOUT_XSLFO=yes Import/export XSL-FO."
.endif
+.endif # WITH_OPTIONS
post-patch:
@${REINPLACE_CMD} -e 's|[$$]abi_plugin_source/../wv|${LOCALBASE}/include/wv|g ; \
diff --git a/editors/abiword-plugins/options b/editors/abiword-plugins/options
new file mode 100644
index 000000000000..5e0fe31bf6c9
--- /dev/null
+++ b/editors/abiword-plugins/options
@@ -0,0 +1,31 @@
+OPTIONS= APPLIX "Import/Export Applix Word files" on \
+ BABELFISH "Translate selected text" on \
+ BMP "View Bitmap Images" on \
+ BZ2ABW "Import/Export BZ2 compressed AbiWord files" on \
+ COMMAND "Allows command line control of AbiWord" on \
+ FREETRANSLATION "Translate selected text" on \
+ GOOGLE "Search Google for your selected text" on \
+ MSWRITE "Import MSWrite files" on \
+ SHELL "Execute shell commands from within AbiWord" on \
+ URLDICT "URL dictionary" on \
+ WIKIPEDIA "Search online encyclopedia for selected text" on \
+ XSLFO "Import/export XSL-FO" on \
+ AIKSAURUS "English language thesaurus" off \
+ CLARISWORKS "Import/Export Clarisworks files" off \
+ DOCBOOK "Import/export Docbook files" off \
+ EML "Import/export as MS Outlook Email files" off \
+ GDICT "Look up definitions of selected text" off \
+ GRAMMAR "Allows AbiWord to be Grammar checked" off \
+ HANCOM "Hancom Word Importer. Only does text" off \
+ HRTEXT "Export text with \"newsgroup\" markup" off \
+ JPEG "View JPEG Images" off \
+ LATEX "LaTeX export" off \
+ NROFF "Nroff/Man file format" off \
+ OPENDOCUMENT "Iport/export OpenDocument files" off \
+ OPENWRITER "Import/export OpenOffice files" off \
+ PDB "Import/export Palm Database files" off \
+ PSION "Import/export Psion files" off \
+ SDW "Import StarOffice 5.x files" off \
+ T602 "Import T602 files" off \
+ WMF "View Windows Metafiles" off \
+ WORDPERFECT "Import/export Wordperfect files" off