aboutsummaryrefslogtreecommitdiff
path: root/editors/apel-xemacs21-mule/Makefile
diff options
context:
space:
mode:
authorShigeyuki Fukushima <shige@FreeBSD.org>1999-09-10 15:35:39 +0000
committerShigeyuki Fukushima <shige@FreeBSD.org>1999-09-10 15:35:39 +0000
commit1e51884226ccfd6119b2b035faa84b2e6fd4979d (patch)
treedc643ffd4e3fb81d8dff8b67262a287f16e8fb43 /editors/apel-xemacs21-mule/Makefile
parent70bc3d6aac98bb6377357fc4db1642468e0b55ee (diff)
Notes
Diffstat (limited to 'editors/apel-xemacs21-mule/Makefile')
-rw-r--r--editors/apel-xemacs21-mule/Makefile12
1 files changed, 10 insertions, 2 deletions
diff --git a/editors/apel-xemacs21-mule/Makefile b/editors/apel-xemacs21-mule/Makefile
index 07cf5a4f8b9c..b0c6d8cd5de2 100644
--- a/editors/apel-xemacs21-mule/Makefile
+++ b/editors/apel-xemacs21-mule/Makefile
@@ -17,8 +17,11 @@ MASTERDIR= ${.CURDIR}/../../editors/apel-emacs
EMACS_NAME= xemacs
EMACS_PORT= xemacs-mule
EMACS_VER= 21.1.6
-EMACS_LIBDIR= lib/${EMACS_NAME}-${EMACS_VER}
-EMACS_LIBDIR_WITH_VER= lib/${EMACS_NAME}-${EMACS_VER}
+EMACS_PACKAGESDIR= lib/${EMACS_NAME}/${EMACS_NAME}-packages
+
+# how to install
+ALL_TARGET= package
+INSTALL_TARGET= install-package
# RUN_DEPENDS port name's suffix is '-common'.
HAVE_COMMON_PORT= YES
@@ -26,4 +29,9 @@ HAVE_COMMON_PORT= YES
# use pkg/* files in ${.CURDIR}
PKGDIR= ${.CURDIR}/pkg
+# package info manifest
+MANIFEST= MANIFEST.apel
+# package documents
+APELDOCDIR= ${EMACS_PACKAGESDIR}/lisp/apel
+
.include <${MASTERDIR}/Makefile>