aboutsummaryrefslogtreecommitdiff
path: root/editors/apel
diff options
context:
space:
mode:
authorShigeyuki Fukushima <shige@FreeBSD.org>2000-07-12 15:26:12 +0000
committerShigeyuki Fukushima <shige@FreeBSD.org>2000-07-12 15:26:12 +0000
commit0cbd5f0e7301900c517ffe98191cdbc0d43181eb (patch)
tree11cc8ebe0d2f3513535bef713fb0b0519405916a /editors/apel
parentbc239c983f572170372ae8d85aa574ae2c47a046 (diff)
downloadports-0cbd5f0e7301900c517ffe98191cdbc0d43181eb.tar.gz
ports-0cbd5f0e7301900c517ffe98191cdbc0d43181eb.zip
Notes
Diffstat (limited to 'editors/apel')
-rw-r--r--editors/apel/Makefile50
-rw-r--r--editors/apel/files/apel-setupel.el.in4
-rw-r--r--editors/apel/pkg-descr.emacs194
-rw-r--r--editors/apel/scripts/configure2
4 files changed, 30 insertions, 30 deletions
diff --git a/editors/apel/Makefile b/editors/apel/Makefile
index b05ddb8990a7..88a4add5cf70 100644
--- a/editors/apel/Makefile
+++ b/editors/apel/Makefile
@@ -5,12 +5,12 @@
# $FreeBSD$
#
-PORTNAME= apel-${EMACS_PORT_NAME}
+PORTNAME= apel
PORTVERSION= ${APEL_VER}
CATEGORIES= editors elisp
MASTER_SITES= ftp://ftp.etl.go.jp/pub/mule/apel/ \
ftp://ftp.center.osaka-u.ac.jp/mule/apel/
-DISTNAME= apel-${APEL_VER}
+PKGNAMESUFFIX= -${EMACS_PORT_NAME}
MAINTAINER?= shige@FreeBSD.org
@@ -31,30 +31,30 @@ EMACS_PORT_NAME= emacs
REQUIRE_SETUPEL= YES
.endif
-.include <bsd.port.pre.mk>
-
# target name for make build
ALL_TARGET?= elc
+# environments
+SCRIPTS_ENV+= TARGETS="${APEL_SETUPEL}"
+PLIST_SUB+= APELDOCDIR=${APELDOCDIR} APEL_SETUPEL=${APEL_SETUPEL}
+
+.include <bsd.port.pre.mk>
+.if defined(EMACS_PORT_NAME)
# depends on custom: emacs-19.34 or mule-19.34
.if (${EMACS_VER} == "19.34")
-BUILD_DEPENDS+= ${PREFIX}/${EMACS_LIBDIR_WITH_VER}/site-lisp/custom.el:${PORTSDIR}/editors/custom-${EMACS_PORT_NAME}
-RUN_DEPENDS+= ${PREFIX}/${EMACS_LIBDIR_WITH_VER}/site-lisp/custom.el:${PORTSDIR}/editors/custom-${EMACS_PORT_NAME}
+BUILD_DEPENDS+= ${LOCALBASE}/${EMACS_LIBDIR_WITH_VER}/site-lisp/custom.el:${PORTSDIR}/editors/custom-${EMACS_PORT_NAME}
+RUN_DEPENDS+= ${LOCALBASE}/${EMACS_LIBDIR_WITH_VER}/site-lisp/custom.el:${PORTSDIR}/editors/custom-${EMACS_PORT_NAME}
.endif
.if defined(EMACS_PACKAGESDIR)
-BUILD_DEPENDS+= ${PREFIX}/${EMACS_LIBDIR}/xemacs-packages/lisp/xemacs-base/advice.el:${PORTSDIR}/editors/xemacs-sumo-packages
-RUN_DEPENDS+= ${PREFIX}/${EMACS_LIBDIR}/xemacs-packages/lisp/xemacs-base/advice.el:${PORTSDIR}/editors/xemacs-sumo-packages
+BUILD_DEPENDS+= ${LOCALBASE}/${EMACS_LIBDIR}/xemacs-packages/lisp/xemacs-base/advice.el:${PORTSDIR}/editors/xemacs-sumo-packages
+RUN_DEPENDS+= ${LOCALBASE}/${EMACS_LIBDIR}/xemacs-packages/lisp/xemacs-base/advice.el:${PORTSDIR}/editors/xemacs-sumo-packages
+.endif
+.else
+.BEGIN:
+ @${ECHO} "Error: Bad port."
+ @${ECHO} "You must define EMACS_PORT_NAME."
+ @${FALSE}
.endif
-
-SCRIPTS_ENV+= EMACS_LIBDIR=${EMACS_LIBDIR} EMACS_VER=${EMACS_VER} \
- EMACS_LIBDIR_WITH_VER=${EMACS_LIBDIR_WITH_VER} \
- EMACS_PACKAGESDIR=${EMACS_PACKAGESDIR} \
- TARGETS="${APEL_SETUPEL}"
-PLIST_SUB+= EMACS_LIBDIR=${EMACS_LIBDIR} EMACS_VER=${EMACS_VER} \
- EMACS_LIBDIR_WITH_VER=${EMACS_LIBDIR_WITH_VER} \
- EMACS_PACKAGESDIR=${EMACS_PACKAGESDIR} \
- APELDOCDIR=${APELDOCDIR} APEL_SETUPEL=${APEL_SETUPEL}
-MAKE_FLAGS+= EMACS=${EMACS_CMD} XEMACS=${EMACS_CMD}
pre-configure:
.if defined(REQUIRE_SETUPEL) && (${REQUIRE_SETUPEL} == "YES")
@@ -87,32 +87,32 @@ post-install:
#
mkdir-site-packages:
@(for i in ${EMACS_PACKAGES_SUBDIRS} ; do \
- ${MKDIR} ${PREFIX}/${EMACS_PACKAGESDIR}/$${i} ; \
+ ${MKDIR} ${LOCALBASE}/${EMACS_PACKAGESDIR}/$${i} ; \
done)
pkg-el-install:
@(if [ -f ${FILESDIR}/_pkg.el ] ; then \
- ${MKDIR} ${PREFIX}/${EMACS_PACKAGESDIR}/lisp/${XEMACS_PKGNAME} ;\
+ ${MKDIR} ${LOCALBASE}/${EMACS_PACKAGESDIR}/lisp/${XEMACS_PKGNAME} ;\
${INSTALL_DATA} ${FILESDIR}/_pkg.el \
- ${PREFIX}/${EMACS_PACKAGESDIR}/lisp/${XEMACS_PKGNAME}/_pkg.el ;\
+ ${LOCALBASE}/${EMACS_PACKAGESDIR}/lisp/${XEMACS_PKGNAME}/_pkg.el ;\
fi)
doc-install:
- @${MKDIR} ${PREFIX}/${APELDOCDIR}
+ @${MKDIR} ${LOCALBASE}/${APELDOCDIR}
@(cd ${WRKSRC} ; \
for i in ChangeLog README.* ; do \
- ${INSTALL_DATA} $${i} ${PREFIX}/${APELDOCDIR}/ ; \
+ ${INSTALL_DATA} $${i} ${LOCALBASE}/${APELDOCDIR}/ ; \
done)
setupel-install:
@${INSTALL_DATA} ${WRKDIR}/${APEL_SETUPEL} \
- ${PREFIX}/${EMACS_LIBDIR_WITH_VER}/site-lisp
+ ${LOCALBASE}/${EMACS_LIBDIR_WITH_VER}/site-lisp
manifest-install:
@${RM} -f ${WRKDIR}/${MANIFEST}
@${CAT} ${PKGDIR}/PLIST | ${GREP} -e "^%%EMACS_PACKAGESDIR%%" | \
${SED} -e "s;^%%EMACS_PACKAGESDIR%%/;;" > ${WRKDIR}/${MANIFEST}
@${INSTALL_DATA} ${WRKDIR}/${MANIFEST} \
- ${PREFIX}/${EMACS_PACKAGESDIR}/pkginfo/
+ ${LOCALBASE}/${EMACS_PACKAGESDIR}/pkginfo/
.include <bsd.port.post.mk>
diff --git a/editors/apel/files/apel-setupel.el.in b/editors/apel/files/apel-setupel.el.in
index 0207489c0b94..1047e259b991 100644
--- a/editors/apel/files/apel-setupel.el.in
+++ b/editors/apel/files/apel-setupel.el.in
@@ -3,7 +3,7 @@
;; -- by shige@FreeBSD.ORG
(setq load-path (append '(
- "@@PREFIX@@/@@EMACS_LIBDIR@@/site-lisp/apel"
- "@@PREFIX@@/@@EMACS_LIBDIR_WITH_VER@@/site-lisp/emu"
+ "@@LOCALBASE@@/@@EMACS_LIBDIR@@/site-lisp/apel"
+ "@@LOCALBASE@@/@@EMACS_LIBDIR_WITH_VER@@/site-lisp/emu"
) load-path))
(provide 'apel-setupel)
diff --git a/editors/apel/pkg-descr.emacs19 b/editors/apel/pkg-descr.emacs19
index 6d82f4e598d2..ecf711decd8c 100644
--- a/editors/apel/pkg-descr.emacs19
+++ b/editors/apel/pkg-descr.emacs19
@@ -26,8 +26,8 @@ APEL is programed by MORIOKA Tomohiko <tomo@m17n.org>.
- static: utility for static evaluation
APEL is installed the following directory tree:
- ${PREFIX}/share/emacs/site-lisp/apel/ --- apel
- ${PREFIX}/share/emacs/19.34/site-lisp/emu/ --- emu
+ ${LOCALBASE}/share/emacs/site-lisp/apel/ --- apel
+ ${LOCALBASE}/share/emacs/19.34/site-lisp/emu/ --- emu
To use apel, put the following setup into your ~/.emacs:
diff --git a/editors/apel/scripts/configure b/editors/apel/scripts/configure
index 04796ae5df87..083bc7164d33 100644
--- a/editors/apel/scripts/configure
+++ b/editors/apel/scripts/configure
@@ -4,7 +4,7 @@ for i in ${TARGETS}
do
if [ -f ${WRKDIR}/${i}.in ]; then
cat ${WRKDIR}/${i}.in | /usr/bin/sed \
- -e "s;@@PREFIX@@;${PREFIX};g" \
+ -e "s;@@LOCALBASE@@;${LOCALBASE};g" \
-e "s;@@EMACS_LIBDIR@@;${EMACS_LIBDIR};g" \
-e "s;@@EMACS_VER@@;${EMACS_VER};g" \
-e "s;@@EMACS_LIBDIR_WITH_VER@@;${EMACS_LIBDIR_WITH_VER};g" \