aboutsummaryrefslogtreecommitdiff
path: root/editors/bed/Makefile
diff options
context:
space:
mode:
authorGreg Lewis <glewis@FreeBSD.org>2003-10-07 20:26:18 +0000
committerGreg Lewis <glewis@FreeBSD.org>2003-10-07 20:26:18 +0000
commit4b6524e62974e8123aaf5854a42ed10298ecb142 (patch)
treed7d4df5bc80406b70cd5f3929241712cc5a4b6ea /editors/bed/Makefile
parent1eddf5f1c2dd2bf050d5a513a75e712e17a1b818 (diff)
downloadports-4b6524e62974e8123aaf5854a42ed10298ecb142.tar.gz
ports-4b6524e62974e8123aaf5854a42ed10298ecb142.zip
Notes
Diffstat (limited to 'editors/bed/Makefile')
-rw-r--r--editors/bed/Makefile50
1 files changed, 50 insertions, 0 deletions
diff --git a/editors/bed/Makefile b/editors/bed/Makefile
new file mode 100644
index 000000000000..f309672cf648
--- /dev/null
+++ b/editors/bed/Makefile
@@ -0,0 +1,50 @@
+# New ports collection makefile for: bed
+# Date created: 2001/05/07
+# Whom: jkaltes@hetnet.nl
+#
+# $FreeBSD$
+#
+
+PORTNAME= bed
+PORTVERSION= 0.2.19
+CATEGORIES= editors
+MASTER_SITES= ${MASTER_SITE_SUNSITE}
+MASTER_SITE_SUBDIR= apps/editors/terminal
+EXTRACT_SUFX= .src.tar.gz
+
+MAINTAINER= jkaltes@hetnet.nl
+COMMENT= Variable dataformat binary editor
+
+.if !defined(WITHOUT_X11)
+CONFIGURE_DEPENDS= ${X11BASE}/bin/rxvt:${PORTSDIR}/x11/rxvt
+.endif
+
+GNU_CONFIGURE= yes
+
+USE_GMAKE= yes
+
+MAN1= bed.1 xbed.1
+MANCOMPRESSED= yes
+
+.if defined(WITHOUT_X11)
+CONFIGURE_ARGS+= --without-x
+PLIST_SUB+= X11="@comment "
+.else
+PLIST_SUB+= X11=""
+
+pre-configure:
+ @if "${X11BASE}/bin/rxvt" -h 2>&1 | ${GREP} -qi menubar; then \
+ else \
+ ${ECHO_MSG} "${PORTSDIR}/x11/rxvt must be compiled with the option"; \
+ ${ECHO_MSG} " WITH_MENUBAR=yes"; \
+ ${ECHO_MSG} "to enable X11 support."; \
+ exit 1; \
+ fi
+.endif
+
+post-configure:
+ ${ECHO_MSG} 'CONFIG_DEBUG=n' >> ${WRKSRC}/config
+ ${ECHO_MSG} 'CONFIG_MMAP=y' >> ${WRKSRC}/config
+ ${GMAKE} -C ${WRKSRC} dep
+
+.include <bsd.port.mk>