aboutsummaryrefslogtreecommitdiff
path: root/editors/bed/Makefile
diff options
context:
space:
mode:
authorGreg Lewis <glewis@FreeBSD.org>2004-01-22 17:39:08 +0000
committerGreg Lewis <glewis@FreeBSD.org>2004-01-22 17:39:08 +0000
commita7012e14236070976620fc8b7557fc5c549bc448 (patch)
treeee436621dff8daf0929537f5a26cb9e58c745333 /editors/bed/Makefile
parent94e6e6740db47f0b6f30c2ad8965dbcf673d3828 (diff)
downloadports-a7012e14236070976620fc8b7557fc5c549bc448.tar.gz
ports-a7012e14236070976620fc8b7557fc5c549bc448.zip
Notes
Diffstat (limited to 'editors/bed/Makefile')
-rw-r--r--editors/bed/Makefile15
1 files changed, 9 insertions, 6 deletions
diff --git a/editors/bed/Makefile b/editors/bed/Makefile
index 3b6c8250d356..b172c243b98d 100644
--- a/editors/bed/Makefile
+++ b/editors/bed/Makefile
@@ -15,20 +15,23 @@ EXTRACT_SUFX= .src.tar.gz
MAINTAINER= ports@FreeBSD.org
COMMENT= Variable dataformat binary editor
-BUILD_DEPENDS= ${LOCALBASE}/bin/bash:${PORTSDIR}/shells/bash2
+# Cannot guarantee rxvt will have menubar enabled on bento.
+.if defined(PACKAGE_BUILDING)
+WITHOUT_X11= yes
+.endif
+
+BUILD_DEPENDS= ${LOCALBASE}/bin/bash:${PORTSDIR}/shells/bash2
.if !defined(WITHOUT_X11)
-BUILD_DEPENDS+= ${X11BASE}/bin/rxvt:${PORTSDIR}/x11/rxvt
+PATCH_DEPENDS+= ${X11BASE}/bin/rxvt:${PORTSDIR}/x11/rxvt
RUN_DEPENDS= ${X11BASE}/bin/rxvt:${PORTSDIR}/x11/rxvt
.endif
-BROKEN= "Broken pkg-plist on 4.x, does not build on 5.x; will be removed after Feb 2"
-
GNU_CONFIGURE= yes
USE_GMAKE= yes
-MAN1= bed.1 xbed.1
-MANCOMPRESSED= yes
+MAN1= bed.1 xbed.1
+MANCOMPRESSED= yes
.if defined(WITHOUT_X11)
CONFIGURE_ARGS+= --without-x