aboutsummaryrefslogtreecommitdiff
path: root/editors/biew
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2009-06-28 11:25:35 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2009-06-28 11:25:35 +0000
commit799c297ecd7fd84e73ab1666d05674a29df7ed49 (patch)
treece3e7a0703817f529341b8735f1784c80d51f102 /editors/biew
parent514689dd31be0d42bf8d608bb1b2c13fc191b244 (diff)
downloadports-799c297ecd7fd84e73ab1666d05674a29df7ed49.tar.gz
ports-799c297ecd7fd84e73ab1666d05674a29df7ed49.zip
Notes
Diffstat (limited to 'editors/biew')
-rw-r--r--editors/biew/Makefile7
-rw-r--r--editors/biew/distinfo6
-rw-r--r--editors/biew/files/patch-ab11
-rw-r--r--editors/biew/files/patch-configure169
-rw-r--r--editors/biew/files/patch-tools_biewhlp_makefile16
-rw-r--r--editors/biew/files/patch-tools_lzss_makefile16
6 files changed, 36 insertions, 189 deletions
diff --git a/editors/biew/Makefile b/editors/biew/Makefile
index f2dbde52022c..5bd97265568a 100644
--- a/editors/biew/Makefile
+++ b/editors/biew/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= biew
-PORTVERSION= 5.6.4
+PORTVERSION= 5.7.3.1
CATEGORIES= editors
MASTER_SITES= SF
DISTNAME= ${PORTNAME}-${PORTVERSION:S/.//g}
@@ -15,9 +15,12 @@ MAINTAINER= danfe@FreeBSD.org
COMMENT= Binary file viewer and editor
HAS_CONFIGURE= yes
-CONFIGURE_ARGS= --cc="${CC}" --ld="${CC}" --prefix="${PREFIX}"
+CONFIGURE_ARGS= --cc="${CC}" --with-extraincdir="${LOCALBASE}/include" \
+ --ld="${CC}" --with-extralibdir="${LOCALBASE}/lib" \
+ --prefix="${PREFIX}" --datadir="${DATADIR}"
USE_BZIP2= yes
USE_GMAKE= yes
+USE_ICONV= yes
MAKEFILE= makefile
PLIST_FILES= bin/biew \
diff --git a/editors/biew/distinfo b/editors/biew/distinfo
index 3bebe2fa6912..b5436a8992df 100644
--- a/editors/biew/distinfo
+++ b/editors/biew/distinfo
@@ -1,3 +1,3 @@
-MD5 (biew-564.tar.bz2) = 807c691fa9372ffd1b0840523c27c23a
-SHA256 (biew-564.tar.bz2) = 787c8128de0ba589e6f7ad1547f1c46c86975a41c72bc187918a30f28deaba5e
-SIZE (biew-564.tar.bz2) = 626711
+MD5 (biew-5731.tar.bz2) = ed9b2b9b4c69e469970b9e6f88b0e74b
+SHA256 (biew-5731.tar.bz2) = 34a2cb66f1b2da8f3f208ae0010e8ad0706d425e62ce8eb13d7814c859e1cb49
+SIZE (biew-5731.tar.bz2) = 739607
diff --git a/editors/biew/files/patch-ab b/editors/biew/files/patch-ab
deleted file mode 100644
index c6d956d04ea6..000000000000
--- a/editors/biew/files/patch-ab
+++ /dev/null
@@ -1,11 +0,0 @@
---- tools/biewhlp/biewhlp.c.orig Fri Jun 2 21:01:18 2000
-+++ tools/biewhlp/biewhlp.c Fri Jun 9 08:01:32 2000
-@@ -32,7 +32,7 @@
- BGLOBAL bOutput;
-
- #define BBIO_CACHE_SIZE 0x1000
--#define ARCHIVER "lzss e"
-+#define ARCHIVER "./lzss e"
- #define COMPNAME "temp_fil.tmp"
- #define TEMPFNAME "temp_hlp.tmp"
-
diff --git a/editors/biew/files/patch-configure b/editors/biew/files/patch-configure
index b850fe302eea..acccad560c63 100644
--- a/editors/biew/files/patch-configure
+++ b/editors/biew/files/patch-configure
@@ -1,141 +1,28 @@
---- configure.orig 2007-04-11 13:26:12.000000000 +0700
-+++ configure 2008-06-14 23:02:43.000000000 +0700
-@@ -199,7 +199,7 @@
- if test $? -eq 0
- then
- _target_system=qnx
-- host_arch=ia32
-+ _target_arch=ia32
- _install=cp
- else
- _target_system=qnxnto
-@@ -217,45 +217,16 @@
- ;;
- *msdosdjgpp*)
- _target_system=dos
-- host_arch=ia32
-+ _target_arch=ia32
- _tee=
- ;;
- # |FreeBSD|NetBSD|BSD/OS|OpenBSD|SunOS|BeOS)
--# *)
--# _target_system=unix
--# ;;
-- esac
-- else
-- _target_system=auto
-- fi
--fi
--
--if test "$_target_system" = auto ; then
-- if test -z "$system_name" ; then
-- # OS name
-- system_name=`/bin/sh --version 2>&1 | sed -n 's/^.*\([(]\)./\1/p'`
-- case "$system_name" in
-- *linux*)
-- _target_system=linux
-- ;;
-- *[cC][yY][gG][wW][iI][nN]*)
-- _target_system=win32
-- ;;
-- *[eE][mM][xX]*)
-- _target_system=os2
-- ;;
-- *msdosdjgpp*)
-- _target_system=dos
-- host_arch=ia32
-- _tee=
-- ;;
--# |FreeBSD|NetBSD|BSD/OS|OpenBSD|SunOS|BeOS)
- *)
- _target_system=unix
- ;;
- esac
- else
-- _target_system=unix
-+ _target_system=$system_name
- fi
- fi
- echores "$_target_system"
-@@ -263,33 +234,21 @@
- echocheck "architecture"
- if test "$_target_arch" = auto ; then
- if test -z "$host_arch" ; then
-- host_arch=`( uname -p ) 2>&1`
-- case "$host_arch" in
-- i*86|sparc|ppc|alpha|arm|mips)
-- ;;
--
-- *) # uname -p on Linux returns 'unknown' for the processor type,
-- # OpenBSD returns 'Intel Pentium/MMX ("Genuine Intel" 586-class)'
--
-- # Maybe uname -m (machine hardware name) returns something we
-- # recognize.
--
-- case "`( uname -m ) 2>&1`" in
-- i*86|x86*|amd64*) host_arch=ia32 ;;
-- ppc) host_arch=ppc ;;
-- alpha) host_arch=alpha ;;
-- sparc*) host_arch=sparc ;;
-- arm*) host_arch=arm ;;
-- *) host_arch=generic ;;
-+ # Host architecture
-+ host_arch=`uname -m`
-+ case "$host_arch" in
-+ i*86|x86*|amd64*) _target_arch=ia32 ;;
-+ ppc) _target_arch=ppc ;;
-+ alpha) _target_arch=alpha ;;
-+ sparc*) _target_arch=sparc ;;
-+ arm*) _target_arch=arm ;;
-+ *) _target_arch=generic ;;
- esac
-- ;;
-- esac
-+ else
-+ _target_arch=$host_arch
- fi
--else
-- host_arch=$_target_arch
- fi
--echores "$host_arch"
--echo "Detected host..."$system_name
-+echores "$_target_arch"
-
- if test -z "$_x11incdir" ; then
- echocheck "X11 headers"
-@@ -474,7 +433,7 @@
-
- # Printout architecture
- _cdefsys=
--case "$host_arch" in
-+case "$_target_arch" in
- ia32)
- # TODO: enable >386 optimizations here
- _cdefsys="-D__MACHINE__=ia32 -D__CPU_NAME__='\"ia32\"' -D__CPU__=386 -D__DEFAULT_DISASM=0 -DCAN_COMPILE_X86_GAS=1"
-@@ -487,7 +446,7 @@
-
- *)
- echo "It seems noone has ported biew to your OS or CPU type yet."
-- echo "using $host_arch architecture"
-+ echo "using $_target_arch architecture"
- ;;
- esac
-
-@@ -517,7 +476,7 @@
- DATADIR=$_datadir
- LIBDIR=$_libdir
- HOST=$_target_system
--MACHINE=$host_arch
-+MACHINE=$_target_arch
- CDEFOS=$_cdefos $_extraincdir $_x11incdir
- OSLDEF=$_osldef
- OS_LIBS=$_extralibdir $_x11libdir $_oslibs
-@@ -539,7 +498,7 @@
- Remover: $_rm
- TARGETS
- system: $_target_system
-- arch: $host_arch
-+ arch: $_target_arch
-
- EOF
-
+--- configure.orig
++++ configure
+@@ -544,10 +544,10 @@
+ echocheck "slang.h"
+ check_header slang.h
+ enabled slang_h && _cdefos="-D_SLANG_ -D__OS_NAME__='\"Unix/Slang\"' $_cdefos"
+- enabled slang_h && _oslibs="-lslang $_oslibs" || disable _slang
++ enabled slang_h && _oslibs="-lslang -ltermcap $_oslibs" || disable _slang
+ echores "$slang_h"
+ fi
+- if enabled _curses -a disabled _slang; then
++ if enabled _curses && disabled _slang; then
+ echocheck "curses.h"
+ cat > $TMPC << EOF
+ #include <curses.h>
+@@ -566,8 +566,10 @@
+ fi
+ echores "$_curses"
+ fi
+- disabled _curses -a disabled _slang && _cdefos="-D_VT100_ -D__OS_NAME__='\"Unix/VT100\"' $_cdefos"
+- disabled _curses -a disabled _slang && echo "Defaulting to VT100"
++ if disabled _curses && disabled _slang ; then
++ _cdefos="-D_VT100_ -D__OS_NAME__='\"Unix/VT100\"' $_cdefos"
++ echo "Defaulting to VT100"
++ fi
+ ;;
+ *)
+ ;;
diff --git a/editors/biew/files/patch-tools_biewhlp_makefile b/editors/biew/files/patch-tools_biewhlp_makefile
deleted file mode 100644
index 74a6f68e15b5..000000000000
--- a/editors/biew/files/patch-tools_biewhlp_makefile
+++ /dev/null
@@ -1,16 +0,0 @@
---- tools/biewhlp/makefile.orig 2002-11-29 23:06:55.000000000 +0600
-+++ tools/biewhlp/makefile 2008-06-16 15:34:45.000000000 +0700
-@@ -46,9 +46,12 @@
- ifeq ($(findstring qnx,$(TARGET_OS)),qnx)
- include ../../make_qnx.inc
- else
--include ../../makefile.inc
-+include ../../config.mak
- endif
-
-+CFLAGS = $(CDEFOS) $(CDEFSYS) $(HOST_CFLAGS)
-+LDFLAGS = $(OSLDEF) $(HOST_LDFLAGS)
-+
- ###########################################################################
- # TARGET: put name of executable image here #
- ###########################################################################
diff --git a/editors/biew/files/patch-tools_lzss_makefile b/editors/biew/files/patch-tools_lzss_makefile
deleted file mode 100644
index dad903898c4e..000000000000
--- a/editors/biew/files/patch-tools_lzss_makefile
+++ /dev/null
@@ -1,16 +0,0 @@
---- tools/lzss/makefile.orig 2002-11-29 23:06:56.000000000 +0600
-+++ tools/lzss/makefile 2008-06-16 15:35:53.000000000 +0700
-@@ -45,9 +45,12 @@
- ifeq ($(findstring qnx,$(TARGET_OS)),qnx)
- include ../../make_qnx.inc
- else
--include ../../makefile.inc
-+include ../../config.mak
- endif
-
-+CFLAGS = $(CDEFOS) $(CDEFSYS) $(HOST_CFLAGS)
-+LDFLAGS = $(OSLDEF) $(HOST_LDFLAGS)
-+
- ###########################################################################
- # TARGET: put name of executable image here #
- ###########################################################################