aboutsummaryrefslogtreecommitdiff
path: root/editors/biew
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2013-06-10 11:35:00 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2013-06-10 11:35:00 +0000
commit0a72f771855a342b1225bcd0eddce9fce8db819f (patch)
treecace4fa47a499128138b4ed3b6d72a57969f89fa /editors/biew
parentbe8cec3726ecdd3fe69a1c0320b1b3b935372b4d (diff)
downloadports-0a72f771855a342b1225bcd0eddce9fce8db819f.tar.gz
ports-0a72f771855a342b1225bcd0eddce9fce8db819f.zip
Notes
Diffstat (limited to 'editors/biew')
-rw-r--r--editors/biew/Makefile9
-rw-r--r--editors/biew/files/patch-configure42
-rw-r--r--editors/biew/pkg-descr2
3 files changed, 48 insertions, 5 deletions
diff --git a/editors/biew/Makefile b/editors/biew/Makefile
index 103c7fff54c1..9f5412bd4002 100644
--- a/editors/biew/Makefile
+++ b/editors/biew/Makefile
@@ -51,9 +51,16 @@ post-patch:
# Allow it to find definition of `uintmax_t' (required at least for ia64)
@${REINPLACE_CMD} -e 's,<sys/types,<stdint,' \
${WRKSRC}/biewlib/sysdep/generic/__config.h
-# Fix BTx group of x86 opcodes disasm bug (sf.net bug id 3150304)
+# Fix BTx group of x86 opcodes disasm bug (upstream ticket #44, closed)
@${REINPLACE_CMD} -e 's,DisP->codelen++),++DisP->codelen),' \
${WRKSRC}/plugins/disasm/ix86/ix86_fun.c
+# Fix inline assembly to make Clang happy (ticket #49)
+ @${REINPLACE_CMD} -e '/srcptr/s,::"g",::"r",' \
+ ${WRKSRC}/biewlib/sysdep/ia32/aclib_template.c \
+ ${WRKSRC}/biewlib/sysdep/x86_64/aclib_template.c
+ @${REINPLACE_CMD} -E 's,fild|fistp,&s,' \
+ ${WRKSRC}/biewlib/sysdep/ia32/cpu_info.c \
+ ${WRKSRC}/biewlib/sysdep/x86_64/cpu_info.c
post-build:
# Convert Russian text files to UTF-8 encoding (doing it in post-build
diff --git a/editors/biew/files/patch-configure b/editors/biew/files/patch-configure
index ac68b5d46645..b10365953e6d 100644
--- a/editors/biew/files/patch-configure
+++ b/editors/biew/files/patch-configure
@@ -1,6 +1,42 @@
--- configure.orig
+++ configure
-@@ -583,10 +583,10 @@
+@@ -100,7 +100,7 @@
+ # Use this before starting a check
+ echocheck() {
+ echo "============ Checking for $@ ============" >> "$TMPLOG"
+- echo ${_echo_n} "Checking for $@ ... ${_echo_c}"
++ echo ${_echo_n} "Checking for $@... ${_echo_c}"
+ }
+
+ # Use this to echo the results of a check
+@@ -493,20 +493,21 @@
+ echores "$_target_system"
+
+
+-echo "Detected host..."$system_name
++echo "Detected host..." $system_name
+
+ _cdefos="-DDATADIR='\"$_datadir\"'"
+
+-cc_name=`$_cc -v 2>&1 | tail -n 1 | cut -d ' ' -f 1`
+-cc_version=`$_cc -dumpversion`
++eval `$_cc -v 2>&1 | sed -En \
++ '/version/s,(FreeBSD )?(.*) version ([0-9.]*).*,\2 \3,p' | (read cc_name \
++ cc_version ; echo cc_name=$cc_name \; cc_version=$cc_version)`
+
+ echocheck "C compiler name"
+ echores $cc_name
+ case $cc_name in
+- gcc)
++ gcc|clang)
+ ;;
+ *)
+- die "Unknown compiler name $cc_name. Project required GCC"
++ die "Unknown compiler name $cc_name. Project requires GCC or Clang"
+ ;;
+ esac
+
+@@ -583,10 +584,10 @@
_osldef="$_debug $_profile $_osldef"
elif test -z "$CFLAGS" ; then
_cdefos="-DNDEBUG=1 -O2 -ffast-math -fomit-frame-pointer $_cdefos"
@@ -12,7 +48,7 @@
test -n "$LDFLAGS" && _osldef="$LDFLAGS $_osldef"
test -n "$LIBS" && _osldef="$LIBS $_osldef"
-@@ -656,10 +656,10 @@
+@@ -656,10 +657,10 @@
echocheck "slang.h"
check_header slang.h
enabled slang_h && _cdefos="-D_SLANG_ -D__OS_NAME__='\"Unix/Slang\"' $_cdefos"
@@ -25,7 +61,7 @@
echocheck "curses.h"
cat > $TMPC << EOF
#include <curses.h>
-@@ -678,8 +678,10 @@
+@@ -678,8 +679,10 @@
fi
echores "$_curses"
fi
diff --git a/editors/biew/pkg-descr b/editors/biew/pkg-descr
index 7bac2e7e36c2..a11ae86ad3e6 100644
--- a/editors/biew/pkg-descr
+++ b/editors/biew/pkg-descr
@@ -5,4 +5,4 @@ for AVR/Java/x86-AMD64/ARM-XScale/PPC-64 code, Russian codepage converter,
full preview of formats MZ, NE, PE, NLM, COFF32, ELF (and partially a.out,
LE, LX, PharLap), code navigator, and much more.
-WWW: http://biew.sourceforge.net/
+WWW: http://beye.sourceforge.net/