aboutsummaryrefslogtreecommitdiff
path: root/editors/calligra-l10n
diff options
context:
space:
mode:
authorAlberto Villa <avilla@FreeBSD.org>2012-05-31 00:09:24 +0000
committerAlberto Villa <avilla@FreeBSD.org>2012-05-31 00:09:24 +0000
commit7b4e1ec4a5950c12e703456521df41ff4b698fd2 (patch)
tree23df0789e394e66dc29f4a94ba2d01086142182d /editors/calligra-l10n
parent77e4ccd8f07053850940fe7c052b9e91fe7c30de (diff)
downloadports-7b4e1ec4a5950c12e703456521df41ff4b698fd2.tar.gz
ports-7b4e1ec4a5950c12e703456521df41ff4b698fd2.zip
Notes
Diffstat (limited to 'editors/calligra-l10n')
-rw-r--r--editors/calligra-l10n/Makefile46
-rw-r--r--editors/calligra-l10n/files/bsd.l10n.mk19
-rw-r--r--editors/calligra-l10n/pkg-descr4
3 files changed, 35 insertions, 34 deletions
diff --git a/editors/calligra-l10n/Makefile b/editors/calligra-l10n/Makefile
index bde1dc236ba2..cbd45c7a780a 100644
--- a/editors/calligra-l10n/Makefile
+++ b/editors/calligra-l10n/Makefile
@@ -5,44 +5,44 @@
# $FreeBSD$
#
-PORTNAME= koffice-l10n
-PORTVERSION= ${KOFFICE2_VERSION}
-PORTREVISION= 1
+PORTNAME= calligra-l10n
+PORTVERSION= ${CALLIGRA_VERSION}
CATEGORIES= editors kde
MASTER_SITES= # none
DISTFILES= # none
EXTRACT_ONLY= # none
MAINTAINER= kde@FreeBSD.org
-COMMENT= Localized messages and documentation for KOffice2
+COMMENT= Localized messages and documentation for Calligra
NO_BUILD= yes
# NO_INSTALL= yes
USE_KDE4= kdeprefix
-KOFFICE2_LANG_ALL= ca ca@valencia da de el en_GB es et fr gl hu it ja kk \
- nb nds nl pl pt pt_BR ru sv tr uk wa zh_CN zh_TW
-
-ca@valencia_PORT= editors/koffice-kde4-l10n-ca_valencia
-de_PORT= german/koffice-kde4-l10n
-fr_PORT= french/koffice-kde4-l10n
-hu_PORT= hungarian/koffice-kde4-l10n
-ja_PORT= japanese/koffice-kde4-l10n
-pl_PORT= polish/koffice-kde4-l10n
-pt_BR_PORT= portuguese/koffice-kde4-l10n-pt_BR
-pt_PORT= portuguese/koffice-kde4-l10n
-ru_PORT= russian/koffice-kde4-l10n
-uk_PORT= ukrainian/koffice-kde4-l10n
-zh_CN_PORT= chinese/koffice-kde4-l10n-zh_CN
-zh_TW_PORT= chinese/koffice-kde4-l10n-zh_TW
+CALLIGRA_LANG_ALL= ca ca@valencia cs da de el en_GB es et fi fr \
+ hu it kk nb nds nl pl pt pt_BR ru sk sv uk \
+ zh_CN zh_TW
+
+ca@valencia_PORT= editors/calligra-l10n-ca_valencia
+de_PORT= german/calligra-l10n
+fr_PORT= french/calligra-l10n
+hu_PORT= hungarian/calligra-l10n
+ja_PORT= japanese/calligra-l10n
+pl_PORT= polish/calligra-l10n
+pt_BR_PORT= portuguese/calligra-l10n-pt_BR
+pt_PORT= portuguese/calligra-l10n
+ru_PORT= russian/calligra-l10n
+uk_PORT= ukrainian/calligra-l10n
+zh_CN_PORT= chinese/calligra-l10n-zh_CN
+zh_TW_PORT= chinese/calligra-l10n-zh_TW
.include <${.CURDIR}/../../misc/kde4-l10n/files/kde4-lang-names>
nb_NAME= Norwegian Bokmal
OPTIONS= ALL "All localizations" on
-.for lang in ${KOFFICE2_LANG_ALL}
-${lang}_DETECT?= ${KDE4_PREFIX}/share/locale/${lang}/LC_MESSAGES/koffice.mo
-${lang}_PORT?= editors/koffice-kde4-l10n-${lang}
+.for lang in ${CALLIGRA_LANG_ALL}
+${lang}_DETECT?= ${KDE4_PREFIX}/share/locale/${lang}/LC_MESSAGES/calligra.mo
+${lang}_PORT?= editors/calligra-l10n-${lang}
${lang}_NAME?= ${lang}
${lang}_OPTION= ${lang:S/@/_/}
OPTIONS+= ${${lang}_OPTION} "${${lang}_NAME} localization" off
@@ -50,7 +50,7 @@ OPTIONS+= ${${lang}_OPTION} "${${lang}_NAME} localization" off
.include <bsd.port.options.mk>
-.for lang in ${KOFFICE2_LANG_ALL}
+.for lang in ${CALLIGRA_LANG_ALL}
.if defined(WITH_ALL) || defined(WITH_${${lang}_OPTION})
RUN_DEPENDS+= ${${lang}_DETECT}:${PORTSDIR}/${${lang}_PORT}
.endif
diff --git a/editors/calligra-l10n/files/bsd.l10n.mk b/editors/calligra-l10n/files/bsd.l10n.mk
index d25c266004c5..bf7caf90ee2e 100644
--- a/editors/calligra-l10n/files/bsd.l10n.mk
+++ b/editors/calligra-l10n/files/bsd.l10n.mk
@@ -1,14 +1,15 @@
-.if defined(KOFFICE2_L10N)
+.if defined(CALLIGRA_L10N)
MASTER_SITES?= ${MASTER_SITE_KDE}
-MASTER_SITE_SUBDIR?= ${KOFFICE2_BRANCH}/koffice-${PORTVERSION}/koffice-l10n/
-PKGNAMEPREFIX= ${KOFFICE2_L10N:S/@/_/}-
-DISTNAME= ${PORTNAME}-${KOFFICE2_L10N}-${PORTVERSION}
-DIST_SUBDIR= KDE/koffice-l10n
+MASTER_SITE_SUBDIR?= ${CALLIGRA_BRANCH}/calligra-${PORTVERSION}/calligra-l10n/
+PKGNAMEPREFIX= ${CALLIGRA_L10N:S/@/_/}-
+DISTNAME= ${PORTNAME}-${CALLIGRA_L10N}-${PORTVERSION}
+DIST_SUBDIR= KDE/calligra-l10n
+
+CONFLICTS= ${PKGNAMEPREFIX}koffice-l10n-2.*
-USE_BZIP2= yes
-USE_QT_VER= 4
-QT_COMPONENTS= uic_build moc_build qmake_build rcc_build xml
USE_GETTEXT= yes
-USE_KDE4= kdelibs kdehier kdeprefix automoc4
+USE_KDE4= kdehier kdelibs kdeprefix automoc4
+USE_QT4= xml moc_build qmake_build rcc_build uic_build
+USE_BZIP2= yes
USE_CMAKE= yes
.endif
diff --git a/editors/calligra-l10n/pkg-descr b/editors/calligra-l10n/pkg-descr
index 455372463720..b8f8785a6a78 100644
--- a/editors/calligra-l10n/pkg-descr
+++ b/editors/calligra-l10n/pkg-descr
@@ -1,3 +1,3 @@
-Localized messages and documentation for KDE.
+Localized messages and documentation for Calligra.
-WWW: http://koffice.kde.org/
+WWW: http://calligra.org