aboutsummaryrefslogtreecommitdiff
path: root/editors/calligra/Makefile
diff options
context:
space:
mode:
authorAdriaan de Groot <adridg@FreeBSD.org>2017-11-25 20:43:39 +0000
committerAdriaan de Groot <adridg@FreeBSD.org>2017-11-25 20:43:39 +0000
commit6f93e882b2a25ba2038f0f622765cb2158383e21 (patch)
tree1c39665f16f5c8ee6a3596e15350038f8f38cbc6 /editors/calligra/Makefile
parent1d3e38688318ce112a430600afdb2832348d3f42 (diff)
downloadports-6f93e882b2a25ba2038f0f622765cb2158383e21.tar.gz
ports-6f93e882b2a25ba2038f0f622765cb2158383e21.zip
Notes
Diffstat (limited to 'editors/calligra/Makefile')
-rw-r--r--editors/calligra/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/editors/calligra/Makefile b/editors/calligra/Makefile
index c8691853bc5e..1a36f4bb33a7 100644
--- a/editors/calligra/Makefile
+++ b/editors/calligra/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= calligra
PORTVERSION= 3.0.1
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= editors kde
MASTER_SITES= KDE/stable/${PORTNAME}/${PORTVERSION}
DIST_SUBDIR= KDE/${PORTNAME}
@@ -14,8 +14,7 @@ DIST_SUBDIR= KDE/${PORTNAME}
MAINTAINER= kde@FreeBSD.org
COMMENT= KDE office suite
-LIB_DEPENDS= libIlmImf.so:graphics/OpenEXR \
- libImath-2_2.so:graphics/ilmbase \
+LIB_DEPENDS= libImath-2_2.so:graphics/ilmbase \
libKPropertyCore3.so:x11-toolkits/kproperty \
libKReport3.so:textproc/kreport \
libboost_thread.so:devel/boost-libs \
@@ -58,6 +57,11 @@ USE_QT5= buildtools_build core dbus gui network opengl \
USE_XORG= ice sm x11 xext
USE_LDCONFIG= yes
+OPTIONS_DEFINE= OPENEXR
+OPTIONS_DEFAULT= OPENEXR
+
+OPENEXR_LIB_DEPENDS= libIlmImf.so:graphics/OpenEXR
+
CMAKE_ARGS= -DCMAKE_INCLUDE_PATH:STRING="${QT_INCDIR} ${LOCALBASE}/include" \
-DPRODUCTSET:STRING="DESKTOP"