aboutsummaryrefslogtreecommitdiff
path: root/editors/calligra/Makefile
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2017-06-17 13:44:51 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2017-06-17 13:44:51 +0000
commita842d469243bc265e68c14c19cdf2648a2aaac95 (patch)
treed722a6757db1136f92f82f7b7d4e4d968a16b536 /editors/calligra/Makefile
parent4f68d0d44822e3c276d674d30164f29889b27351 (diff)
Update the Calligra ports to 3.0.1.
The 3.x series is based on KDE Frameworks 5, and some programs have been split into separate ports: - Sheets, Words & co are in editors/calligra. - Krita is in graphics/krita. - Kexi is in databases/kexi. - The calligra-l10n* ports are now part of editors/calligra itself. Okular support in editors/calligra and Marble support in textproc/kreport have been disabled for now because they need the KF5 version of those ports. Thanks to everyone who's tested it and worked on it in our area51 repository. Submitted by: Adrian de Groot <groot@kde.org>, tcberner, rakuco Reviewed by: rakuco, mat (earlier versions) Differential Revision: https://reviews.freebsd.org/D10167
Notes
Notes: svn path=/head/; revision=443772
Diffstat (limited to 'editors/calligra/Makefile')
-rw-r--r--editors/calligra/Makefile136
1 files changed, 50 insertions, 86 deletions
diff --git a/editors/calligra/Makefile b/editors/calligra/Makefile
index c440c571e146..3e566ca299ab 100644
--- a/editors/calligra/Makefile
+++ b/editors/calligra/Makefile
@@ -1,110 +1,74 @@
# $FreeBSD$
+# TODO (when these parts are available in KF5):
+# - add calendarcore to USE_KDE when KDE PIM is available
+# - add libOkular5Core.so:graphics/okular to LIB_DEPENDS
+#
PORTNAME= calligra
-PORTVERSION= ${CALLIGRA_VERSION}
-PORTREVISION= 11
+PORTVERSION= 3.0.1
CATEGORIES= editors kde
-MASTER_SITES= KDE/${CALLIGRA_BRANCH}/${PORTNAME}-${PORTVERSION}/
-DIST_SUBDIR= KDE/${PORTNAME}/${PORTVERSION}
+MASTER_SITES= KDE/stable/${PORTNAME}/${PORTVERSION}
+DIST_SUBDIR= KDE/${PORTNAME}
MAINTAINER= kde@FreeBSD.org
-COMMENT= KDE graphic art and office suite
+COMMENT= KDE office suite
-LIB_DEPENDS= libpng.so:graphics/png \
- libIlmImf.so:graphics/OpenEXR \
+LIB_DEPENDS= libIlmImf.so:graphics/OpenEXR \
+ libImath-2_2.so:graphics/ilmbase \
+ libKPropertyCore3.so:x11-toolkits/kproperty \
+ libKReport3.so:textproc/kreport \
libboost_thread.so:devel/boost-libs \
- libqca.so:devel/qca \
- libexiv2.so:graphics/exiv2 \
- liblcms2.so:graphics/lcms2 \
+ libetonyek-0.1.so:graphics/libetonyek01 \
libfontconfig.so:x11-fonts/fontconfig \
libfreetype.so:print/freetype2 \
- libwpd-0.10.so:textproc/libwpd010 \
- libwpg-0.3.so:graphics/libwpg03 \
- libpoppler-qt4.so:graphics/poppler-qt4 \
+ libgsl.so:math/gsl \
+ liblcms2.so:graphics/lcms2 \
+ libKGantt.so:graphics/kdiagram \
+ libodfgen-0.1.so:textproc/libodfgen01 \
libopenjpeg.so:graphics/openjpeg15 \
- libfftw3.so:math/fftw3 \
+ libpng.so:graphics/png \
+ libpoppler-qt5.so:graphics/poppler-qt5 \
+ libpoppler.so:graphics/poppler \
+ libqca-qt5.so:devel/qca-qt5 \
+ librevenge-0.0.so:textproc/librevenge \
libtiff.so:graphics/tiff \
- libgsl.so:math/gsl \
- libwps-0.3.so:textproc/libwps03 \
libvisio-0.1.so:textproc/libvisio01 \
- libOpenColorIO.so:graphics/opencolorio \
- libodfgen-0.1.so:textproc/libodfgen01 \
- libetonyek-0.1.so:graphics/libetonyek01 \
- librevenge-0.0.so:textproc/librevenge
+ libwpd-0.10.so:textproc/libwpd010 \
+ libwpg-0.3.so:graphics/libwpg03 \
+ libwps-0.3.so:textproc/libwps03
+
BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/eigen3.pc:math/eigen3 \
pstoedit:graphics/pstoedit
RUN_DEPENDS= pstoedit:graphics/pstoedit
-USE_GL= glew
-USE_GNOME= glib20 libxml2 libxslt
-USE_KDE= kactivities kdelibs libkdcraw \
- okular pimlibs attica automoc4 soprano
-USE_QT4= corelib dbus designer_build gui opengl phonon \
- qtestlib_build script sql svg webkit xml \
- moc_build qmake_build rcc_build uic_build
-USES= cmake:outsource cpe compiler:c++11-lang iconv:translit jpeg \
- kde:4 perl5 pkgconfig shared-mime-info sqlite tar:xz
-CMAKE_ARGS= -DCMAKE_INCLUDE_PATH:STRING="${QT_INCDIR} ${LOCALBASE}/include" \
- -DPRODUCTSET:STRING="DESKTOP"
+USES= cmake:outsource cpe compiler:c++11-lib desktop-file-utils \
+ gettext iconv:translit jpeg kde:5 localbase:ldflags perl5 pkgconfig \
+ shared-mime-info sqlite tar:xz
+USE_KDE= activities archive auth bookmarks codecs completion config \
+ configwidgets coreaddons crash dbusaddons doctools ecm \
+ emoticons guiaddons i18n iconthemes init itemmodels itemviews \
+ jobwidgets js kcmutils kdelibs4support khtml kio \
+ kross notifications notifyconfig parts service solid sonnet \
+ texteditor textwidgets threadweaver unitconversion wallet \
+ widgetsaddons windowsystem xmlgui
+USE_QT5= buildtools_build core dbus gui network opengl \
+ phonon4 printsupport qmake_build qml \
+ quick script sql svg testlib webkit widgets x11extras xml
+USE_XORG= ice sm x11 xext
USE_LDCONFIG= yes
-PLIST_SUB+= SHLIB_VER=14.0.0 \
- SHLIB_SHVER=14
-
-OPTIONS_DEFINE= GMIC MARBLE MYSQL PGSQL SYBASE
-OPTIONS_DEFAULT=MARBLE MYSQL PGSQL
-OPTIONS_SUB= yes
-
-# GMIC does not mix well with clang as compiler. It needs >20GB of memory to be
-# built, which is not sensible on most systems
-# See bug report: https://llvm.org/bugs/show_bug.cgi?id=22199
-GMIC_DESC= Build the G'Mic plugin (needs lots and lots of RAM)
-GMIC_CMAKE_ON= -DWITH_GMIC:BOOL=ON
-GMIC_CMAKE_OFF= -DWITH_GMIC:BOOL=OFF
-
-MARBLE_DESC= World globe widget support via Marble
-MARBLE_USE= KDE=marble
-MARBLE_CMAKE_OFF=-DWITH_Marble:BOOL=FALSE
-
-MYSQL_DESC= MySQL database support in Kexi
-MYSQL_USE= MYSQL=yes
-MYSQL_CMAKE_OFF=-DWITH_MySQL:BOOL=FALSE
+CMAKE_ARGS= -DCMAKE_INCLUDE_PATH:STRING="${QT_INCDIR} ${LOCALBASE}/include" \
+ -DPRODUCTSET:STRING="DESKTOP"
-PGSQL_DESC= PostgreSQL database support in Kexi
-PGSQL_LIB_DEPENDS=libpqxx-3.1.so:databases/postgresql-libpqxx3
-PGSQL_USES= pgsql
-PGSQL_CMAKE_OFF=-DWITH_PostgreSQL:BOOL=FALSE
+# Requested by upstream, to not include unfinished modules
+CMAKE_ARGS+= -DRELEASE_BUILD:BOOL=TRUE
+# Performance increase according to README.PACKAGERS
+CMAKE_ARGS+= -DCMAKE_CXX_FLAGS="-DKDE_NO_DEBUG_OUTPUT"
-SYBASE_DESC= Sybase database support in Kexi
-SYBASE_LIB_DEPENDS=libsybdb.so:databases/freetds
-SYBASE_CMAKE_OFF=-DWITH_FreeTDS:BOOL=FALSE
+# Disable KDE Pim support
+CMAKE_ARGS+= -DCMAKE_DISABLE_FIND_PACKAGE_KF5Akonadi:BOOL=FALSE \
+ -DCMAKE_DISABLE_FIND_PACKAGE_KF5AkonadiContact:BOOL=FALSE
-post-patch:
-# They require memalign() to build; as they're not installed, they're just a
-# waste of CPU cycles.
- @${REINPLACE_CMD} -e '/add_subdirectory.*benchmarks/ d' \
- ${PATCH_WRKSRC}/krita/CMakeLists.txt
-# Prevent updating MIME during build/install.
- @${REINPLACE_CMD} -e '/^update_xdg_mimetypes/ d' \
- ${PATCH_WRKSRC}/filters/libmsooxml/CMakeLists.txt \
- ${PATCH_WRKSRC}/filters/plan/mpxj/import/CMakeLists.txt \
- ${PATCH_WRKSRC}/filters/stage/keynote/import/CMakeLists.txt \
- ${PATCH_WRKSRC}/filters/words/wiki/CMakeLists.txt \
- ${PATCH_WRKSRC}/krita/data/CMakeLists.txt \
- ${PATCH_WRKSRC}/krita/plugins/formats/ora/CMakeLists.txt \
- ${PATCH_WRKSRC}/krita/plugins/formats/ora/CMakeLists.txt \
- ${PATCH_WRKSRC}/plugins/vectorshape/CMakeLists.txt
-# Enteigen krita: Do not use the complete 'Eigen' namespace, as it conflicts
-# with opencv now, but only include the qualified class names.
-# This is a simplified version of upstreams:
-# https://phabricator.kde.org/R37:2db4438671e17002c7b02e3ad3a5208930765e4f
- @${REINPLACE_CMD} -e 's|using namespace Eigen;|using Eigen::Matrix;using Eigen::Dynamic;using Eigen::Vector2i;|' \
- ${PATCH_WRKSRC}/krita/plugins/extensions/dockers/advancedcolorselector/kis_color_selector_ring.cpp \
- ${PATCH_WRKSRC}/krita/plugins/filters/blur/kis_gaussian_blur_filter.h \
- ${PATCH_WRKSRC}/krita/plugins/filters/blur/kis_motion_blur_filter.h \
- ${PATCH_WRKSRC}/krita/plugins/filters/blur/kis_lens_blur_filter.h \
- ${PATCH_WRKSRC}/krita/plugins/filters/convolutionfilters/convolutionfilters.cpp \
- ${PATCH_WRKSRC}/krita/image/kis_convolution_kernel.h \
- ${PATCH_WRKSRC}/krita/image/kis_gaussian_kernel.h
+PLIST_SUB+= SHLIB_VER=15.0.0
.include <bsd.port.mk>