aboutsummaryrefslogtreecommitdiff
path: root/editors/calligra
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2019-11-01 21:51:36 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2019-11-01 21:51:36 +0000
commit3ca3ffe4551bee0f510c9d301bf4f312959dcf25 (patch)
treece13218697645e8981b36e7589f64b42e3049ce5 /editors/calligra
parent19c0b79bf443eb706820ac162b35b88fcf9088fd (diff)
downloadports-3ca3ffe4551bee0f510c9d301bf4f312959dcf25.tar.gz
ports-3ca3ffe4551bee0f510c9d301bf4f312959dcf25.zip
graphics/poppler: update to 0.82.0
Release 0.82.0: core: * Fix not being able to open some files. Issue #832 * Fix crashes in malformed files * Fix memory leak on broken files * Minor performance improvements * Minor code improvements glib: * Add poppler_document_new_from_bytes * PopplerAttachment: Silence deprecation warnings for ctime/mtime build system: * pdf-inspector: Support builddir != srcdir * Install Cairo* headers if Cairo has been found Thanks to adridg@ for fixing all the fallout. Exp-run by: antoine PR: 241532 Approved by: gnome (kwm, implicit)
Notes
Notes: svn path=/head/; revision=516270
Diffstat (limited to 'editors/calligra')
-rw-r--r--editors/calligra/Makefile6
-rw-r--r--editors/calligra/files/patch-filters_karbon_pdf_SvgOutputDev.cpp26
-rw-r--r--editors/calligra/files/patch-sheets_plugins_calendar_CalendarToolWidget.cpp (renamed from editors/calligra/files/patch-gentoo-kf5-5.61-headers)10
-rw-r--r--editors/calligra/files/patch-stage_part_KPrPresentationTool.cpp (renamed from editors/calligra/files/patch-git_70be8c4)0
4 files changed, 26 insertions, 16 deletions
diff --git a/editors/calligra/Makefile b/editors/calligra/Makefile
index 701b7037368c..102b3b16cdfe 100644
--- a/editors/calligra/Makefile
+++ b/editors/calligra/Makefile
@@ -2,7 +2,7 @@
PORTNAME= calligra
DISTVERSION= 3.1.0
-PORTREVISION= 26
+PORTREVISION= 28
CATEGORIES= editors kde
MASTER_SITES= KDE/stable/${PORTNAME}/${PORTVERSION}
DIST_SUBDIR= KDE/${PORTNAME}
@@ -69,8 +69,4 @@ CMAKE_ARGS+= -DCMAKE_CXX_FLAGS="-DKDE_NO_DEBUG_OUTPUT"
PLIST_SUB+= SHLIB_VER=16.0.0
-post-patch:
- # Fix with poppler 0.73
- ${REINPLACE_CMD} -e 's|Guchar|unsigned char|g' \
- ${WRKSRC}/filters/karbon/pdf/SvgOutputDev.cpp
.include <bsd.port.mk>
diff --git a/editors/calligra/files/patch-filters_karbon_pdf_SvgOutputDev.cpp b/editors/calligra/files/patch-filters_karbon_pdf_SvgOutputDev.cpp
index 911bedf7e936..6cba91fffbb2 100644
--- a/editors/calligra/files/patch-filters_karbon_pdf_SvgOutputDev.cpp
+++ b/editors/calligra/files/patch-filters_karbon_pdf_SvgOutputDev.cpp
@@ -101,7 +101,7 @@
{
int render = state->getRender();
// check for invisible text -- this is used by Acrobat Capture
-@@ -402,7 +408,7 @@ void SvgOutputDev::drawString(GfxState * state, GooStr
+@@ -402,10 +408,10 @@ void SvgOutputDev::drawString(GfxState * state, GooStr
QString str;
@@ -109,7 +109,11 @@
+ const char * p = s->c_str();
int len = s->getLength();
CharCode code;
- Unicode *u = nullptr;
+- Unicode *u = nullptr;
++ const Unicode *u = nullptr;
+ int uLen;
+ double dx, dy, originX, originY;
+ while (len > 0) {
@@ -429,7 +435,7 @@ void SvgOutputDev::drawString(GfxState * state, GooStr
double x = state->getCurX();
double y = state->getCurY();
@@ -144,6 +148,24 @@
{
ImageStream * imgStr = new ImageStream(str, width, colorMap->getNumPixelComps(), colorMap->getBits());
imgStr->reset();
+@@ -488,7 +494,7 @@ void SvgOutputDev::drawImage(GfxState *state, Object *
+ if (maskColors) {
+ for (int y = 0; y < height; y++) {
+ dest = (unsigned int *)(buffer + y * 4 * width);
+- Guchar * pix = imgStr->getLine();
++ unsigned char * pix = imgStr->getLine();
+ colorMap->getRGBLine(pix, dest, width);
+
+ for (int x = 0; x < width; x++) {
+@@ -507,7 +513,7 @@ void SvgOutputDev::drawImage(GfxState *state, Object *
+ } else {
+ for (int y = 0; y < height; y++) {
+ dest = (unsigned int *)(buffer + y * 4 * width);
+- Guchar * pix = imgStr->getLine();
++ unsigned char * pix = imgStr->getLine();
+ colorMap->getRGBLine(pix, dest, width);
+ }
+
@@ -522,7 +528,7 @@ void SvgOutputDev::drawImage(GfxState *state, Object *
return;
}
diff --git a/editors/calligra/files/patch-gentoo-kf5-5.61-headers b/editors/calligra/files/patch-sheets_plugins_calendar_CalendarToolWidget.cpp
index 004cf6df8802..8e75ffc7f720 100644
--- a/editors/calligra/files/patch-gentoo-kf5-5.61-headers
+++ b/editors/calligra/files/patch-sheets_plugins_calendar_CalendarToolWidget.cpp
@@ -3,13 +3,7 @@ From: David Faure <faure@kde.org>
Date: Tue, 23 Jul 2019 13:02:34 +0200
Subject: Fix compilation with Qt 5.13 (missing include)
----
- sheets/plugins/calendar/CalendarToolWidget.cpp | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/sheets/plugins/calendar/CalendarToolWidget.cpp b/sheets/plugins/calendar/CalendarToolWidget.cpp
-index b10b230..0c5eeb6 100644
---- sheets/plugins/calendar/CalendarToolWidget.cpp
+--- sheets/plugins/calendar/CalendarToolWidget.cpp.orig 2018-01-26 09:24:44 UTC
+++ sheets/plugins/calendar/CalendarToolWidget.cpp
@@ -30,6 +30,7 @@
#include <kdatepicker.h>
@@ -19,5 +13,3 @@ index b10b230..0c5eeb6 100644
namespace Calligra
{
---
-cgit v1.1
diff --git a/editors/calligra/files/patch-git_70be8c4 b/editors/calligra/files/patch-stage_part_KPrPresentationTool.cpp
index e8f74261cff9..e8f74261cff9 100644
--- a/editors/calligra/files/patch-git_70be8c4
+++ b/editors/calligra/files/patch-stage_part_KPrPresentationTool.cpp