aboutsummaryrefslogtreecommitdiff
path: root/editors/codelite/files
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2013-04-17 08:16:10 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2013-04-17 08:16:10 +0000
commita6bbbd1624610dd295834dd6f9b9c315ec9cc7d9 (patch)
tree82f3906935bc187f97350bbe9f01dfdb23f4358f /editors/codelite/files
parent4f8a9771742fdb317dd180e9e00b61ad1226e529 (diff)
Notes
Diffstat (limited to 'editors/codelite/files')
-rw-r--r--editors/codelite/files/patch-CMakeLists.txt15
-rw-r--r--editors/codelite/files/patch-CodeLite_unixprocess_impl.cpp17
-rw-r--r--editors/codelite/files/patch-LiteEditor_CMakeLists.txt11
-rw-r--r--editors/codelite/files/patch-Plugin_wxterminal.cpp16
-rw-r--r--editors/codelite/files/patch-Runtime_codelite_kill_children17
-rw-r--r--editors/codelite/files/patch-clang45
-rw-r--r--editors/codelite/files/patch-configure35
-rw-r--r--editors/codelite/files/patch-sdk-codelite_indexer_utils.cpp18
8 files changed, 40 insertions, 134 deletions
diff --git a/editors/codelite/files/patch-CMakeLists.txt b/editors/codelite/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..94ee53871bd0
--- /dev/null
+++ b/editors/codelite/files/patch-CMakeLists.txt
@@ -0,0 +1,15 @@
+--- CMakeLists.txt.orig 2013-04-02 15:50:03.000000000 +0200
++++ CMakeLists.txt 2013-04-02 15:51:59.000000000 +0200
+@@ -212,9 +212,9 @@
+ set( CLANG_BINARY "${CL_SRC_ROOT}/sdk/clang/lib/libclang.dylib")
+
+ elseif (UNIX)
+- set( CLANG_INCLUDE "${CL_SRC_ROOT}/sdk/clang/Linux/${ARCH_NAME}/include" )
+- set( CLANG_LIBRARY "-L${CL_SRC_ROOT}/sdk/clang/Linux/${ARCH_NAME}/lib -lclang" )
+- set( CLANG_BINARY "${CL_SRC_ROOT}/sdk/clang/Linux/${ARCH_NAME}/lib/libclang.so")
++ set( CLANG_INCLUDE "%%LOCALBASE%%/include" )
++ set( CLANG_LIBRARY "-L%%LOCALBASE%%/lib/ -lclang" )
++ set( CLANG_BINARY "%%LOCALBASE%%/lib/libclang.so")
+ endif()
+
+ message( "-- clang link line ${CLANG_LIBRARY} ")
diff --git a/editors/codelite/files/patch-CodeLite_unixprocess_impl.cpp b/editors/codelite/files/patch-CodeLite_unixprocess_impl.cpp
deleted file mode 100644
index af5b4c65c2f7..000000000000
--- a/editors/codelite/files/patch-CodeLite_unixprocess_impl.cpp
+++ /dev/null
@@ -1,17 +0,0 @@
---- CodeLite/unixprocess_impl.cpp.orig 2011-10-11 18:58:27.000000000 +0200
-+++ CodeLite/unixprocess_impl.cpp 2012-02-17 17:14:25.000000000 +0100
-@@ -15,8 +15,14 @@
- #include "procutils.h"
-
- #ifdef __WXGTK__
-+#ifdef __FreeBSD__
-+# include <sys/ioctl.h>
-+# include <termios.h>
-+# include <libutil.h>
-+#else
- # include <pty.h>
- # include <utmp.h>
-+#endif
- #else
- # include <util.h>
- #endif
diff --git a/editors/codelite/files/patch-LiteEditor_CMakeLists.txt b/editors/codelite/files/patch-LiteEditor_CMakeLists.txt
new file mode 100644
index 000000000000..35ac356e88f6
--- /dev/null
+++ b/editors/codelite/files/patch-LiteEditor_CMakeLists.txt
@@ -0,0 +1,11 @@
+--- LiteEditor/CMakeLists.txt.orig 2013-04-03 11:54:27.000000000 +0200
++++ LiteEditor/CMakeLists.txt 2013-04-03 11:54:07.000000000 +0200
+@@ -69,7 +69,7 @@
+
+ if (UNIX)
+ if ( IS_FREEBSD )
+- set(ADDITIONAL_LIBRARIES "-lkvm")
++ set(ADDITIONAL_LIBRARIES "-lkvm -lutil")
+ elseif ( UNIX AND NOT APPLE )
+ set(ADDITIONAL_LIBRARIES "-ldl -lutil")
+ else ( )
diff --git a/editors/codelite/files/patch-Plugin_wxterminal.cpp b/editors/codelite/files/patch-Plugin_wxterminal.cpp
deleted file mode 100644
index 1625370b0de2..000000000000
--- a/editors/codelite/files/patch-Plugin_wxterminal.cpp
+++ /dev/null
@@ -1,16 +0,0 @@
---- Plugin/wxterminal.cpp.orig 2013-01-12 18:39:52.000000000 +0100
-+++ Plugin/wxterminal.cpp 2013-02-01 14:55:54.000000000 +0100
-@@ -23,7 +23,13 @@
- #endif
-
- #if defined(__WXGTK__)
-+#ifdef __FreeBSD__
-+# include <sys/ioctl.h>
-+# include <termios.h>
-+# include <libutil.h>
-+#else
- # include <pty.h>
-+#endif
- # include "unixprocess_impl.h"
- #elif defined(__WXMAC__)
- # include <util.h>
diff --git a/editors/codelite/files/patch-Runtime_codelite_kill_children b/editors/codelite/files/patch-Runtime_codelite_kill_children
deleted file mode 100644
index 721c4f787daa..000000000000
--- a/editors/codelite/files/patch-Runtime_codelite_kill_children
+++ /dev/null
@@ -1,17 +0,0 @@
---- Runtime/codelite_kill_children.orig 2013-02-01 14:56:41.000000000 +0100
-+++ Runtime/codelite_kill_children 2013-02-01 15:04:59.000000000 +0100
-@@ -4,8 +4,13 @@
- ## for "hard kills"
-
- sig_options=$2
-+osname=$(uname -o)
-
--procs=`ps --ppid $1 | grep -v PID | awk '{print $1;}'`
-+if [ "$osname" = "FreeBSD" ]; then
-+ procs=`ps -A -o ppid,pid | sed -e '1d' | awk '{print $1" "$2}' | grep "^$1 " | awk '{print $2}' | xargs`
-+else
-+ procs=`ps --ppid $1 | grep -v PID | awk '{print $1;}'`
-+fi
- for p in $procs
- do
- kill $sig_options $p 2> /dev/null
diff --git a/editors/codelite/files/patch-clang b/editors/codelite/files/patch-clang
index 3126e9a1a3ae..6992273a531e 100644
--- a/editors/codelite/files/patch-clang
+++ b/editors/codelite/files/patch-clang
@@ -1,33 +1,16 @@
---- LiteEditor/clang_driver.cpp.orig 2013-02-01 17:27:10.000000000 +0100
-+++ LiteEditor/clang_driver.cpp 2013-02-01 17:28:50.000000000 +0100
-@@ -533,6 +533,7 @@
- tag->SetSignature (entrySignature);
-
- // Add support for clang comment parsing
+--- LiteEditor/clang_pch_maker_thread.cpp.orig 2013-04-02 16:55:25.000000000 +0200
++++ LiteEditor/clang_pch_maker_thread.cpp 2013-04-02 17:16:02.000000000 +0200
+@@ -391,8 +391,11 @@
+ // First time, need to create it
+ unsigned flags;
+ if(reparse) {
+- flags = CXTranslationUnit_CXXPrecompiledPreamble
+- | CXTranslationUnit_CacheCompletionResults
++ flags =
+#ifndef __FreeBSD__
- CXString BriefComment = clang_getCompletionBriefComment(str);
- const char* comment = clang_getCString(BriefComment);
- if( comment && comment[0] != '\0' ) {
-@@ -540,6 +541,7 @@
- }
-
- clang_disposeString(BriefComment);
++ CXTranslationUnit_CXXPrecompiledPreamble |
+#endif
-
- switch(kind) {
- case CXCursor_EnumConstantDecl:
---- LiteEditor/clang_pch_maker_thread.cpp.orig 2013-02-01 17:29:21.000000000 +0100
-+++ LiteEditor/clang_pch_maker_thread.cpp 2013-02-01 17:32:18.000000000 +0100
-@@ -130,7 +130,11 @@
- task->GetColumn(),
- usf.GetUnsavedFiles(),
- usf.GetCount(),
-- clang_defaultCodeCompleteOptions() | CXCodeComplete_IncludeBriefComments);
-+ clang_defaultCodeCompleteOptions()
-+#ifndef __FreeBSD__
-+ | CXCodeComplete_IncludeBriefComments
-+#endif
-+ );
-
- cacheEntry.lastReparse = time(NULL);
-
++ CXTranslationUnit_CacheCompletionResults
+ | CXTranslationUnit_PrecompiledPreamble
+ | CXTranslationUnit_Incomplete
+ | CXTranslationUnit_DetailedPreprocessingRecord
diff --git a/editors/codelite/files/patch-configure b/editors/codelite/files/patch-configure
deleted file mode 100644
index 15d929eccd43..000000000000
--- a/editors/codelite/files/patch-configure
+++ /dev/null
@@ -1,35 +0,0 @@
---- configure.orig 2013-01-23 17:10:11.000000000 +0100
-+++ configure 2013-02-01 15:11:13.000000000 +0100
-@@ -84,6 +84,20 @@
- with_clang="yes"
-
- fi
-+ elif [ "$os_name" = "FreeBSD" ]; then
-+ arch=$(uname -m)
-+ if [ $arch = "amd64" -o $arch = "sparc64" ]; then
-+ compiler_extras="-m64 -DON_64_BIT "
-+ c_compiler_extras="-m64 -DON_64_BIT "
-+ else
-+ compiler_extras="-m32 "
-+ c_compiler_extras="-m32 "
-+ fi
-+ ## clang
-+ %%ENABLE_CLANG%% with_clang="yes"
-+ %%ENABLE_CLANG%% lib_clang_cmp_flags=" -DHAS_LIBCLANG -I%%LOCALBASE%%/include "
-+ %%ENABLE_CLANG%% lib_clang_link_flags=" -L%%LOCALBASE%%/lib -lclang "
-+ %%ENABLE_CLANG%% lib_clang="%%LOCALBASE%%/lib/libclang.so"
- else # Not darwin
- if [ "$is_64bit" = "yes" ]; then
-
-@@ -785,9 +799,9 @@
- elif [ "$rule_name" = "DatabaseLayerSQLite" ] ; then
- createVariables "yes" "-I${base_dir}/sdk/databaselayer/src/sqlite3"
- elif [ "$rule_name" = "DatabaseLayerMySQL" ] ; then
-- createVariables "yes" "-I/usr/include/mysql"
-+ createVariables "yes" "-I%%LOCALBASE%%/include/mysql"
- elif [ "$rule_name" = "DatabaseLayerPostgres" ] ; then
-- createVariables "yes" "-I/usr/include/postgresql"
-+ createVariables "yes" "-I%%LOCALBASE%%/include/postgresql"
- elif [ "$rule_name" = "DatabaseExplorer" ] ; then
-
- if [ "$os_name" != "Darwin" ];then
diff --git a/editors/codelite/files/patch-sdk-codelite_indexer_utils.cpp b/editors/codelite/files/patch-sdk-codelite_indexer_utils.cpp
deleted file mode 100644
index e7b574829d17..000000000000
--- a/editors/codelite/files/patch-sdk-codelite_indexer_utils.cpp
+++ /dev/null
@@ -1,18 +0,0 @@
---- sdk/codelite_indexer/utils.cpp.orig 2010-08-02 08:43:19.000000000 +0200
-+++ sdk/codelite_indexer/utils.cpp 2012-02-17 17:18:13.000000000 +0100
-@@ -17,6 +17,15 @@
- # include <signal.h>
- #endif
-
-+#ifdef __FreeBSD__
-+#include <fcntl.h>
-+#include <paths.h>
-+#include <kvm.h>
-+#include <sys/param.h>
-+#include <sys/sysctl.h>
-+#include <sys/user.h>
-+#endif
-+
- /**
- * helper string methods
- */