aboutsummaryrefslogtreecommitdiff
path: root/editors/codelite
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2014-01-23 08:59:45 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2014-01-23 08:59:45 +0000
commitda9077f2d26a54a32c8e3ef547b7dd885fdc2f62 (patch)
tree1071f7c44f42422e9da9eb9e3d0fba6036cde7ff /editors/codelite
parent400463d85212f29ff329fa5abd67320e2a1c5bf0 (diff)
downloadports-da9077f2d26a54a32c8e3ef547b7dd885fdc2f62.tar.gz
ports-da9077f2d26a54a32c8e3ef547b7dd885fdc2f62.zip
Notes
Diffstat (limited to 'editors/codelite')
-rw-r--r--editors/codelite/Makefile29
-rw-r--r--editors/codelite/distinfo4
-rw-r--r--editors/codelite/files/patch-CMakeLists.txt28
-rw-r--r--editors/codelite/files/patch-CodeLite_cpptoken.h11
-rw-r--r--editors/codelite/files/patch-codelite_terminal_CMakeLists.txt11
-rw-r--r--editors/codelite/files/patch-codelite_terminal_MainFrame.cpp16
-rw-r--r--editors/codelite/pkg-plist22
7 files changed, 89 insertions, 32 deletions
diff --git a/editors/codelite/Makefile b/editors/codelite/Makefile
index bb5b27c29e45..7bcb01b34d41 100644
--- a/editors/codelite/Makefile
+++ b/editors/codelite/Makefile
@@ -2,10 +2,8 @@
# $FreeBSD$
PORTNAME= codelite
-DISTVERSION= 5.2
+DISTVERSION= 5.4
CATEGORIES= editors devel
-MASTER_SITES= SF/${PORTNAME}/Releases/${PORTNAME}-${PORTVERSION}/
-DISTNAME= ${PORTNAME}-${PORTVERSION}-gtk.src
MAINTAINER= gahr@FreeBSD.org
COMMENT= An Open Source IDE for C/C++
@@ -15,22 +13,30 @@ LICENSE= GPLv2
LIB_DEPENDS= libcurl.so:${PORTSDIR}/ftp/curl
RUN_DEPENDS= xterm:${PORTSDIR}/x11/xterm
-OPTIONS_DEFINE= CSCOPE CLANG
-
+OPTIONS_DEFINE= CSCOPE CLANG NLS
CSCOPE_DESC= CScope integration
CLANG_DESC= Clang code-completion
+OPTIONS_SUB= yes
+
+USE_GITHUB= yes
+GH_ACCOUNT= eranif
+GH_PROJECT= ${PORTNAME}
+GH_COMMIT= 41e98e5
+GH_TAGNAME= 5.4
-USE_WX= 2.9
+USE_WX= 3.0
WX_UNICODE= yes
-USES= gettext cmake:outsource dos2unix
+USES= gettext cmake:outsource dos2unix shebangfix
+DOS2UNIX_GLOB= *.cpp *.txt
USE_LDCONFIG= ${PREFIX}/lib/codelite
+SHEBANG_FILES= Runtime/clg++ Runtime/clgcc
+
+CXXFLAGS+= -I${LOCALBASE}/include
CMAKE_ARGS+= -DIS_FREEBSD=1 \
-DPREFIX=${PREFIX}
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-SVN_REVISION= 6213
-
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MCSCOPE}
@@ -40,10 +46,8 @@ RUN_DEPENDS+= cscope:${PORTSDIR}/devel/cscope
.if ${PORT_OPTIONS:MCLANG}
BUILD_DEPENDS+= ${LOCALBASE}/llvm-devel/lib/libclang.so:${PORTSDIR}/lang/clang-devel
RUN_DEPENDS+= ${LOCALBASE}/llvm-devel/lib/libclang.so:${PORTSDIR}/lang/clang-devel
-PLIST_SUB+= CLANG=""
CMAKE_ARGS+= -DENABLE_CLANG=1
.else
-PLIST_SUB+= CLANG="@comment "
CMAKE_ARGS+= -DENABLE_CLANG=0
.endif
@@ -52,9 +56,8 @@ post-patch:
${REINPLACE_CMD} -e \
's|wx-config|${WX_CONFIG}|; \
s|%%LOCALBASE%%|${LOCALBASE}|g; \
+ s|%%PREFIX%%|${PREFIX}|g; \
/IS_FREEBSD/s|0|1|' \
${WRKSRC}/CMakeLists.txt
- ${REINPLACE_CMD} -e 's|$${cur_rev}|${SVN_REVISION}|' \
- ${WRKSRC}/le_makerevision.sh
.include <bsd.port.mk>
diff --git a/editors/codelite/distinfo b/editors/codelite/distinfo
index d2249f725a53..d871833d337d 100644
--- a/editors/codelite/distinfo
+++ b/editors/codelite/distinfo
@@ -1,2 +1,2 @@
-SHA256 (codelite-5.2-gtk.src.tar.gz) = 8fdb4bb1bcb984aacead7b7d3c7087f2008303297ea90a6299e4deff196cf084
-SIZE (codelite-5.2-gtk.src.tar.gz) = 22710705
+SHA256 (codelite-5.4.tar.gz) = 2bdb6cfd1239a7fcaf476a215c9f7d775e8814f0930828b66e9acd4799cc5002
+SIZE (codelite-5.4.tar.gz) = 37950862
diff --git a/editors/codelite/files/patch-CMakeLists.txt b/editors/codelite/files/patch-CMakeLists.txt
index 1989460ead69..51347115b917 100644
--- a/editors/codelite/files/patch-CMakeLists.txt
+++ b/editors/codelite/files/patch-CMakeLists.txt
@@ -1,6 +1,28 @@
---- CMakeLists.txt.orig 2013-04-02 15:50:03.000000000 +0200
-+++ CMakeLists.txt 2013-04-02 15:51:59.000000000 +0200
-@@ -212,9 +212,9 @@
+--- CMakeLists.txt.orig 2014-01-22 15:20:56.000000000 +0100
++++ CMakeLists.txt 2014-01-22 17:21:28.000000000 +0100
+@@ -34,7 +34,7 @@
+ #############################################
+ project( "CodeLite" )
+
+-set( CL_PREFIX "/usr" )
++set( CL_PREFIX "%%PREFIX%%" )
+ if (CMAKE_CURRENT_LIST_DIR) # since cmake 2.8.3
+ set( CL_SRC_ROOT ${CMAKE_CURRENT_LIST_DIR})
+ else()
+@@ -42,10 +42,10 @@
+ endif()
+
+ set( USE_CLANG 1 )
+-set( IS_FREEBSD 0 )
++set( IS_FREEBSD 1 )
+ set( BUILD_WXC 0 )
+ set( CL_COPY_WX_LIBS 0 )
+-set( WITH_SFTP 1 )
++set( WITH_SFTP 0 )
+
+ if ( UNIX )
+ execute_process(COMMAND pwd OUTPUT_VARIABLE BUILD_DIRECTORY OUTPUT_STRIP_TRAILING_WHITESPACE)
+@@ -329,9 +329,9 @@
set( CLANG_BINARY "${CL_SRC_ROOT}/sdk/clang/lib/libclang.dylib")
elseif (UNIX)
diff --git a/editors/codelite/files/patch-CodeLite_cpptoken.h b/editors/codelite/files/patch-CodeLite_cpptoken.h
deleted file mode 100644
index 085de87482e1..000000000000
--- a/editors/codelite/files/patch-CodeLite_cpptoken.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- CodeLite/cpptoken.h.orig 2014-01-21 10:05:01.000000000 +0100
-+++ CodeLite/cpptoken.h 2014-01-21 10:05:10.000000000 +0100
-@@ -87,7 +87,7 @@
- void print();
-
- // Provide lower-than operator so we can use std::list::sort method
-- bool operator < (const CppToken& rhs) {
-+ bool operator < (const CppToken& rhs) const {
- return filename < rhs.filename;
- }
- };
diff --git a/editors/codelite/files/patch-codelite_terminal_CMakeLists.txt b/editors/codelite/files/patch-codelite_terminal_CMakeLists.txt
new file mode 100644
index 000000000000..6d69b9c13d41
--- /dev/null
+++ b/editors/codelite/files/patch-codelite_terminal_CMakeLists.txt
@@ -0,0 +1,11 @@
+--- codelite_terminal/CMakeLists.txt.orig 2014-01-22 16:36:20.000000000 +0100
++++ codelite_terminal/CMakeLists.txt 2014-01-22 16:36:35.000000000 +0100
+@@ -28,7 +28,7 @@
+ add_executable(codelite-terminal ${SRCS})
+ set ( UTIL_LIB "" )
+ if ( UNIX )
+- set( UTIL_LIB "-lutil")
++ set( UTIL_LIB "-lutil -lkvm")
+ endif ( UNIX )
+
+ target_link_libraries(codelite-terminal ${LINKER_OPTIONS} ${wxWidgets_LIBRARIES} ${UTIL_LIB} )
diff --git a/editors/codelite/files/patch-codelite_terminal_MainFrame.cpp b/editors/codelite/files/patch-codelite_terminal_MainFrame.cpp
new file mode 100644
index 000000000000..3c988ba09c89
--- /dev/null
+++ b/editors/codelite/files/patch-codelite_terminal_MainFrame.cpp
@@ -0,0 +1,16 @@
+--- codelite_terminal/MainFrame.cpp.orig 2014-01-22 16:15:29.000000000 +0100
++++ codelite_terminal/MainFrame.cpp 2014-01-22 16:17:57.000000000 +0100
+@@ -8,7 +8,12 @@
+ #include <wx/filedlg.h>
+
+ #ifndef __WXMSW__
+-#if defined(__WXGTK__)
++#if defined(__FreeBSD__)
++# include <sys/types.h>
++# include <sys/ioctl.h>
++# include <termios.h>
++# include <libutil.h>
++#elif defined(__WXGTK__)
+ # include <pty.h>
+ #else
+ # include <util.h>
diff --git a/editors/codelite/pkg-plist b/editors/codelite/pkg-plist
index 8b8f1381711f..0579790ff06f 100644
--- a/editors/codelite/pkg-plist
+++ b/editors/codelite/pkg-plist
@@ -1,4 +1,6 @@
bin/codelite
+bin/codelite-make
+bin/codelite-terminal
%%CLANG%%bin/codelite-clang
bin/clg++
bin/clgcc
@@ -9,6 +11,7 @@ bin/codelite_indexer
bin/codelite_kill_children
bin/codelite_xterm
bin/codelitegcc
+lib/codelite/CMakePlugin.so
lib/codelite/CallGraph.so
lib/codelite/CodeFormatter.so
lib/codelite/ContinuousBuild.so
@@ -19,6 +22,7 @@ lib/codelite/Outline.so
lib/codelite/QMakePlugin.so
lib/codelite/SnipWiz.so
lib/codelite/Subversion.so
+lib/codelite/Tweaks.so
lib/codelite/UnitTestsPP.so
lib/codelite/Wizards.so
lib/codelite/ZoomNavigator.so
@@ -125,10 +129,10 @@ lib/codelite/wxFormBuilder.so
%%DATADIR%%/templates/gizmos/wxmain.project.wizard
%%DATADIR%%/templates/gizmos/wxproject-fb.project.wizard
%%DATADIR%%/templates/gizmos/wxproject.project.wizard
-%%DATADIR%%/templates/projects/ConsoleClang/ConsoleClang.project
-%%DATADIR%%/templates/projects/ConsoleClang/main.c
%%DATADIR%%/templates/projects/ConsoleClang++/ConsoleClang++.project
%%DATADIR%%/templates/projects/ConsoleClang++/main.cpp
+%%DATADIR%%/templates/projects/ConsoleClang/ConsoleClang.project
+%%DATADIR%%/templates/projects/ConsoleClang/main.c
%%DATADIR%%/templates/projects/UnitTest++/UnitTest++.project
%%DATADIR%%/templates/projects/UnitTest++/icon.png
%%DATADIR%%/templates/projects/UnitTest++/main.cpp
@@ -157,8 +161,10 @@ lib/codelite/wxFormBuilder.so
%%DATADIR%%/templates/projects/custom-makefile/custom-makefile.project
%%DATADIR%%/templates/projects/custom-makefile/icon.png
%%DATADIR%%/templates/projects/dynamic-library-wx-enabled/dynamic-library-wx-enabled.project
+%%DATADIR%%/templates/projects/dynamic-library-wx-enabled/dynamic-library-wx-enabled.project.windows
%%DATADIR%%/templates/projects/dynamic-library-wx-enabled/icon.png
%%DATADIR%%/templates/projects/dynamic-library/dynamic-library.project
+%%DATADIR%%/templates/projects/dynamic-library/dynamic-library.project.windows
%%DATADIR%%/templates/projects/dynamic-library/icon.png
%%DATADIR%%/templates/projects/executable-cobra/executable-cobra.project
%%DATADIR%%/templates/projects/executable-cobra/main.cobra
@@ -181,6 +187,7 @@ lib/codelite/wxFormBuilder.so
%%DATADIR%%/templates/projects/executable-wx-dialog/icon.png
%%DATADIR%%/templates/projects/executable-wx-dialog/main.cpp
%%DATADIR%%/templates/projects/executable-wx-dialog/main.h
+%%DATADIR%%/templates/projects/executable-wx-dialog/win_resources.rc
%%DATADIR%%/templates/projects/executable-wx-enabled/executable-wx-enabled.project
%%DATADIR%%/templates/projects/executable-wx-enabled/icon.png
%%DATADIR%%/templates/projects/executable-wx-enabled/main.cpp
@@ -191,6 +198,7 @@ lib/codelite/wxFormBuilder.so
%%DATADIR%%/templates/projects/executable-wx-frame/icon.png
%%DATADIR%%/templates/projects/executable-wx-frame/main.cpp
%%DATADIR%%/templates/projects/executable-wx-frame/main.h
+%%DATADIR%%/templates/projects/executable-wx-frame/win_resources.rc
%%DATADIR%%/templates/projects/executable-wxcrafter-dialog/MainDialog.cpp
%%DATADIR%%/templates/projects/executable-wxcrafter-dialog/MainDialog.h
%%DATADIR%%/templates/projects/executable-wxcrafter-dialog/icon.png
@@ -227,14 +235,20 @@ lib/codelite/wxFormBuilder.so
%%DATADIR%%/templates/projects/vc-executable/vc-executable.project
%%DATADIR%%/templates/projects/vc-static-lib/icon.png
%%DATADIR%%/templates/projects/vc-static-lib/vc-static-lib.project
+%%DATADIR%%/templates/projects/wxWidgets_ConsoleApp/icon.png
+%%DATADIR%%/templates/projects/wxWidgets_ConsoleApp/main_app.cpp
+%%DATADIR%%/templates/projects/wxWidgets_ConsoleApp/main_app.h
+%%DATADIR%%/templates/projects/wxWidgets_ConsoleApp/wxWidgets_ConsoleApp.project
%%DATADIR%%/templates/qmake/qmake.project
%%DATADIR%%/unittest++1.3.tar.gz
-share/locale/cs/LC_MESSAGES/codelite.mo
+%%NLS%%share/locale/cs/LC_MESSAGES/codelite.mo
+%%NLS%%share/locale/cz/LC_MESSAGES/codelite.mo
share/applications/codelite.desktop
@dirrm lib/codelite/resources
@dirrm lib/codelite/debuggers
@dirrm lib/codelite
@dirrm %%DATADIR%%/templates/qmake
+@dirrm %%DATADIR%%/templates/projects/wxWidgets_ConsoleApp
@dirrm %%DATADIR%%/templates/projects/vc-static-lib
@dirrm %%DATADIR%%/templates/projects/vc-executable
@dirrm %%DATADIR%%/templates/projects/vc-dynamic-library
@@ -279,3 +293,5 @@ share/applications/codelite.desktop
@dirrm %%DATADIR%%/gdb_printers
@dirrm %%DATADIR%%/config
@dirrm %%DATADIR%%
+@dirrmtry share/locale/cz/LC_MESSAGES
+@dirrmtry share/locale/cz