aboutsummaryrefslogtreecommitdiff
path: root/editors/codelite
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2009-04-11 07:43:26 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2009-04-11 07:43:26 +0000
commit179511cd07635c7420cab6e6e47f38c92a745ac7 (patch)
treea26c04fad312450fc808eedc75719e727eea7a1c /editors/codelite
parent2bfb9985f094f516d8896aa54c56b705aa5bf282 (diff)
downloadports-179511cd07635c7420cab6e6e47f38c92a745ac7.tar.gz
ports-179511cd07635c7420cab6e6e47f38c92a745ac7.zip
Notes
Diffstat (limited to 'editors/codelite')
-rw-r--r--editors/codelite/Makefile30
-rw-r--r--editors/codelite/pkg-plist150
2 files changed, 88 insertions, 92 deletions
diff --git a/editors/codelite/Makefile b/editors/codelite/Makefile
index b1fe4aaed8f2..fef36a8e30c7 100644
--- a/editors/codelite/Makefile
+++ b/editors/codelite/Makefile
@@ -39,6 +39,10 @@ post-patch:
.endif
${REINPLACE_CMD} -e 's|wx-config|${WX_CONFIG}|g' \
${WRKSRC}/configure
+# Configure script does not respect --prefix
+ ${REINPLACE_CMD} -e '/^prefix/s|/usr|${PREFIX}|; \
+ /^plugins_dir/s|/usr/lib/codelite|${DATADIR}/plugins|' \
+ ${WRKSRC}/configure
${REINPLACE_CMD} -e 's|$${cur_rev}|${SVN_REVISION}|' \
${WRKSRC}/le_makerevision.sh
# CTags already installed
@@ -47,30 +51,4 @@ post-patch:
fi; \
)
-do-install:
- ${MKDIR} ${DATADIR}
- ${MKDIR} ${DATADIR}/config
- ${MKDIR} ${DATADIR}/rc
- ${MKDIR} ${DATADIR}/templates
- ${MKDIR} ${DATADIR}/lexers
- ${MKDIR} ${DATADIR}/debuggers
- ${MKDIR} ${DATADIR}/plugins
- ${MKDIR} ${DATADIR}/images
- ${INSTALL_PROGRAM} ${WRKSRC}/Runtime/codelite ${PREFIX}/bin/CodeLite
- ${INSTALL_PROGRAM} ${WRKSRC}/Runtime/codelite_indexer ${PREFIX}/bin/
- (cd ${WRKSRC}/Runtime/config/ && ${COPYTREE_SHARE} \* ${DATADIR}/config)
- (cd ${WRKSRC}/Runtime/rc/ && ${COPYTREE_SHARE} \*.xrc ${DATADIR}/rc)
- (cd ${WRKSRC}/Runtime/templates && ${COPYTREE_SHARE} \* ${DATADIR}/templates)
- (cd ${WRKSRC}/Runtime/lexers && ${COPYTREE_SHARE} \* ${DATADIR}/lexers)
- ${INSTALL_DATA} ${WRKSRC}/lib/Debugger.so ${DATADIR}/debuggers
-.for lib in CodeFormatter Subversion cscope Gizmos
- ${INSTALL_DATA} ${WRKSRC}/lib/${lib}.so ${DATADIR}/plugins
-.endfor
- ${INSTALL_DATA} ${WRKSRC}/Runtime/index.html ${DATADIR}
- ${INSTALL_DATA} ${WRKSRC}/Runtime/astyle.sample ${DATADIR}
- ${INSTALL_DATA} ${WRKSRC}/Runtime/svnreport.html ${DATADIR}
- (cd ${WRKSRC}/Runtime/images && ${COPYTREE_SHARE} \*.png ${DATADIR}/images)
- ${INSTALL} -d ${PREFIX}/share/applications
- ${INSTALL} ${WRKSRC}/Runtime/codelite.desktop ${PREFIX}/share/applications/
-
.include <bsd.port.post.mk>
diff --git a/editors/codelite/pkg-plist b/editors/codelite/pkg-plist
index e7f9e26d038a..4238a53631d2 100644
--- a/editors/codelite/pkg-plist
+++ b/editors/codelite/pkg-plist
@@ -1,81 +1,97 @@
-bin/CodeLite
+bin/codelite
+bin/codelite_exec
+bin/codelite_fix_files
bin/codelite_indexer
+bin/codelite_kill_children
+%%DATADIR%%/src/unittest++1.3.tar.gz
+%%DATADIR%%/astyle.sample
%%DATADIR%%/config/accelerators.conf.default
%%DATADIR%%/config/build_settings.xml.default
-%%DATADIR%%/config/build_settings.xml.default.win
-%%DATADIR%%/config/build_settings.xml.default.mac
-%%DATADIR%%/config/codelite.layout.default
%%DATADIR%%/config/codelite.xml.default
-%%DATADIR%%/config/codelite.xml.default.gtk
%%DATADIR%%/config/debuggers.xml.default
-%%DATADIR%%/config/debuggers.xml.gtk
-%%DATADIR%%/config/liteeditor.xml.mac
%%DATADIR%%/config/plugins.xml.default
-%%DATADIR%%/debuggers/Debugger.so
-%%DATADIR%%/templates/projects/vc-executable/vc-executable.project
-%%DATADIR%%/templates/projects/executable/main.cpp
-%%DATADIR%%/templates/projects/executable/executable.project
-%%DATADIR%%/templates/projects/vc-static-lib/vc-static-lib.project
-%%DATADIR%%/templates/projects/dynamic-library/dynamic-library.project
-%%DATADIR%%/templates/projects/static-library/static-library.project
-%%DATADIR%%/templates/projects/dynamic-library-wx-enabled/dynamic-library-wx-enabled.project
-%%DATADIR%%/templates/projects/vc-dynamic-library/vc-dynamic-library.project
-%%DATADIR%%/templates/projects/static-library-wx-enabled/static-library-wx-enabled.project
-%%DATADIR%%/templates/projects/UnitTest++/UnitTest++.project
-%%DATADIR%%/templates/projects/UnitTest++/main.cpp
-%%DATADIR%%/templates/projects/non-code-project/non-code.project
-%%DATADIR%%/templates/projects/custom-makefile/custom-makefile.project
-%%DATADIR%%/templates/gizmos/wxmain.project.wizard
-%%DATADIR%%/templates/gizmos/mainframe.cpp.wizard
-%%DATADIR%%/templates/gizmos/app.cpp.wizard
-%%DATADIR%%/templates/gizmos/plugin.h.wizard
-%%DATADIR%%/templates/gizmos/main.cpp.wizard
-%%DATADIR%%/templates/gizmos/app.h.wizard
-%%DATADIR%%/templates/gizmos/liteeditor-plugin.project.wizard
-%%DATADIR%%/templates/gizmos/mainframe.h.wizard
-%%DATADIR%%/templates/gizmos/wxproject.project.wizard
-%%DATADIR%%/templates/gizmos/plugin.cpp.wizard
-%%DATADIR%%/templates/formbuilder/DialogTemplate.fbp
-%%DATADIR%%/templates/formbuilder/DialogTemplateWithButtons.fbp
-%%DATADIR%%/templates/formbuilder/FrameTemplate.fbp
-%%DATADIR%%/templates/formbuilder/PanelTemplate.fbp
-%%DATADIR%%/plugins/CodeFormatter.so
-%%DATADIR%%/plugins/Subversion.so
-%%DATADIR%%/plugins/cscope.so
-%%DATADIR%%/plugins/Gizmos.so
-%%DATADIR%%/rc/menu.xrc
-%%DATADIR%%/lexers/Default/lexer_cpp.xml
-%%DATADIR%%/lexers/Default/lexer_script.xml
-%%DATADIR%%/lexers/Default/lexer_properties.xml
-%%DATADIR%%/lexers/Default/lexer_perl.xml
-%%DATADIR%%/lexers/Default/lexer_makefile.xml
-%%DATADIR%%/lexers/Default/lexer_lua.xml
-%%DATADIR%%/lexers/Default/lexer_java.xml
-%%DATADIR%%/lexers/Default/lexer_inno.xml
-%%DATADIR%%/lexers/Default/lexer_html.xml
-%%DATADIR%%/lexers/Default/lexer_diff.xml
-%%DATADIR%%/lexers/Default/lexer_default.xml
-%%DATADIR%%/lexers/Default/lexer_xml.xml
-%%DATADIR%%/lexers/BlackTheme/lexer_cpp.xml
-%%DATADIR%%/lexers/BlackTheme/lexer_script.xml
-%%DATADIR%%/lexers/BlackTheme/lexer_properties.xml
-%%DATADIR%%/lexers/BlackTheme/lexer_perl.xml
-%%DATADIR%%/lexers/BlackTheme/lexer_makefile.xml
-%%DATADIR%%/lexers/BlackTheme/lexer_lua.xml
-%%DATADIR%%/lexers/BlackTheme/lexer_java.xml
-%%DATADIR%%/lexers/BlackTheme/lexer_inno.xml
-%%DATADIR%%/lexers/BlackTheme/lexer_html.xml
-%%DATADIR%%/lexers/BlackTheme/lexer_diff.xml
-%%DATADIR%%/lexers/BlackTheme/lexer_default.xml
-%%DATADIR%%/lexers/BlackTheme/lexer_xml.xml
%%DATADIR%%/images/cubes.png
%%DATADIR%%/images/help_earth.png
%%DATADIR%%/images/plugin_not_ok.png
%%DATADIR%%/images/plugin_ok.png
%%DATADIR%%/images/splashscreen.png
%%DATADIR%%/index.html
-%%DATADIR%%/astyle.sample
+%%DATADIR%%/lexers/BlackTheme/lexer_cpp.xml
+%%DATADIR%%/lexers/BlackTheme/lexer_default.xml
+%%DATADIR%%/lexers/BlackTheme/lexer_diff.xml
+%%DATADIR%%/lexers/BlackTheme/lexer_html.xml
+%%DATADIR%%/lexers/BlackTheme/lexer_inno.xml
+%%DATADIR%%/lexers/BlackTheme/lexer_java.xml
+%%DATADIR%%/lexers/BlackTheme/lexer_lua.xml
+%%DATADIR%%/lexers/BlackTheme/lexer_makefile.xml
+%%DATADIR%%/lexers/BlackTheme/lexer_perl.xml
+%%DATADIR%%/lexers/BlackTheme/lexer_properties.xml
+%%DATADIR%%/lexers/BlackTheme/lexer_script.xml
+%%DATADIR%%/lexers/BlackTheme/lexer_xml.xml
+%%DATADIR%%/lexers/Default/lexer_cpp.xml
+%%DATADIR%%/lexers/Default/lexer_default.xml
+%%DATADIR%%/lexers/Default/lexer_diff.xml
+%%DATADIR%%/lexers/Default/lexer_html.xml
+%%DATADIR%%/lexers/Default/lexer_inno.xml
+%%DATADIR%%/lexers/Default/lexer_java.xml
+%%DATADIR%%/lexers/Default/lexer_lua.xml
+%%DATADIR%%/lexers/Default/lexer_makefile.xml
+%%DATADIR%%/lexers/Default/lexer_perl.xml
+%%DATADIR%%/lexers/Default/lexer_properties.xml
+%%DATADIR%%/lexers/Default/lexer_script.xml
+%%DATADIR%%/lexers/Default/lexer_xml.xml
+%%DATADIR%%/plugins/CodeFormatter.so
+%%DATADIR%%/plugins/ContinuousBuild.so
+%%DATADIR%%/plugins/Copyright.so
+%%DATADIR%%/plugins/ExternalTools.so
+%%DATADIR%%/plugins/Gizmos.so
+%%DATADIR%%/plugins/SnipWiz.so
+%%DATADIR%%/plugins/Subversion.so
+%%DATADIR%%/plugins/SymbolView.so
+%%DATADIR%%/plugins/UnitTestCPP.so
+%%DATADIR%%/plugins/abbreviation.so
+%%DATADIR%%/plugins/cscope.so
+%%DATADIR%%/plugins/debuggers/Debugger.so
+%%DATADIR%%/plugins/resources/abbrev.png
+%%DATADIR%%/plugins/resources/abbreviation.accelerators
+%%DATADIR%%/plugins/resources/compfile.png
+%%DATADIR%%/plugins/resources/external_tools.accelerators
+%%DATADIR%%/plugins/resources/svn_diff.png
+%%DATADIR%%/plugins/resources/svn_settings.png
+%%DATADIR%%/plugins/resources/svn_ssh.png
+%%DATADIR%%/plugins/resources/wxfb_conflict.png
+%%DATADIR%%/plugins/resources/wxfb_modified.png
+%%DATADIR%%/plugins/resources/wxfb_ok.png
+%%DATADIR%%/plugins/wxformbuilder.so
+%%DATADIR%%/rc/menu.xrc
%%DATADIR%%/svnreport.html
+%%DATADIR%%/templates/formbuilder/DialogTemplate.fbp
+%%DATADIR%%/templates/formbuilder/DialogTemplateWithButtons.fbp
+%%DATADIR%%/templates/formbuilder/FrameTemplate.fbp
+%%DATADIR%%/templates/formbuilder/PanelTemplate.fbp
+%%DATADIR%%/templates/gizmos/app.cpp.wizard
+%%DATADIR%%/templates/gizmos/app.h.wizard
+%%DATADIR%%/templates/gizmos/liteeditor-plugin.project.wizard
+%%DATADIR%%/templates/gizmos/main.cpp.wizard
+%%DATADIR%%/templates/gizmos/mainframe.cpp.wizard
+%%DATADIR%%/templates/gizmos/mainframe.h.wizard
+%%DATADIR%%/templates/gizmos/plugin.cpp.wizard
+%%DATADIR%%/templates/gizmos/plugin.h.wizard
+%%DATADIR%%/templates/gizmos/wxmain.project.wizard
+%%DATADIR%%/templates/gizmos/wxproject.project.wizard
+%%DATADIR%%/templates/projects/UnitTest++/UnitTest++.project
+%%DATADIR%%/templates/projects/UnitTest++/main.cpp
+%%DATADIR%%/templates/projects/custom-makefile/custom-makefile.project
+%%DATADIR%%/templates/projects/dynamic-library-wx-enabled/dynamic-library-wx-enabled.project
+%%DATADIR%%/templates/projects/dynamic-library/dynamic-library.project
+%%DATADIR%%/templates/projects/executable/executable.project
+%%DATADIR%%/templates/projects/executable/main.cpp
+%%DATADIR%%/templates/projects/non-code-project/non-code.project
+%%DATADIR%%/templates/projects/static-library-wx-enabled/static-library-wx-enabled.project
+%%DATADIR%%/templates/projects/static-library/static-library.project
+%%DATADIR%%/templates/projects/vc-dynamic-library/vc-dynamic-library.project
+%%DATADIR%%/templates/projects/vc-executable/vc-executable.project
+%%DATADIR%%/templates/projects/vc-static-lib/vc-static-lib.project
share/applications/codelite.desktop
@dirrm %%DATADIR%%/templates/projects/non-code-project
@dirrm %%DATADIR%%/templates/projects/custom-makefile
@@ -93,12 +109,14 @@ share/applications/codelite.desktop
@dirrm %%DATADIR%%/templates/formbuilder
@dirrm %%DATADIR%%/templates
@dirrm %%DATADIR%%/rc
+@dirrm %%DATADIR%%/plugins/resources
+@dirrm %%DATADIR%%/plugins/debuggers
@dirrm %%DATADIR%%/plugins
@dirrm %%DATADIR%%/lexers/Default
@dirrm %%DATADIR%%/lexers/BlackTheme
@dirrm %%DATADIR%%/lexers
-@dirrm %%DATADIR%%/debuggers
@dirrm %%DATADIR%%/config
@dirrm %%DATADIR%%/images
+@dirrm %%DATADIR%%/src
@dirrm %%DATADIR%%
@dirrmtry share/applications