aboutsummaryrefslogtreecommitdiff
path: root/editors/codelite
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2009-08-31 09:12:24 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2009-08-31 09:12:24 +0000
commit3d7440c189cd594819f22156fa1a84dd863ee9bc (patch)
tree97c47534ec22f7a22d59dbafe4177d7ed33fb203 /editors/codelite
parent0e0fee2c119fa238a32d4fb1bf85725e310bca9b (diff)
downloadports-3d7440c189cd594819f22156fa1a84dd863ee9bc.tar.gz
ports-3d7440c189cd594819f22156fa1a84dd863ee9bc.zip
Notes
Diffstat (limited to 'editors/codelite')
-rw-r--r--editors/codelite/Makefile4
-rw-r--r--editors/codelite/distinfo6
-rw-r--r--editors/codelite/files/patch-CodeLite_procutils.cpp101
-rw-r--r--editors/codelite/pkg-plist16
4 files changed, 21 insertions, 106 deletions
diff --git a/editors/codelite/Makefile b/editors/codelite/Makefile
index e940c91e36d1..b8f12cef4d45 100644
--- a/editors/codelite/Makefile
+++ b/editors/codelite/Makefile
@@ -9,7 +9,7 @@ PORTNAME= codelite
DISTVERSION= 1.0.${SVN_REVISION}
PORTREVISION= 1
CATEGORIES= editors
-MASTER_SITES= SF/${PORTNAME}/Releases/PreviousReleases/${PORTNAME}%20${PORTVERSION}
+MASTER_SITES= SF/${PORTNAME}/Releases/${PORTNAME}-${PORTVERSION}
MAINTAINER= gahr@FreeBSD.org
COMMENT= An Open Source IDE for C/C++
@@ -28,7 +28,7 @@ HAS_CONFIGURE= yes
ONLY_FOR_ARCHS= i386 amd64 sparc64
-SVN_REVISION= 2841
+SVN_REVISION= 2893
.if defined(WITH_CSCOPE)
RUN_DEPENDS+= cscope:${PORTSDIR}/devel/cscope
diff --git a/editors/codelite/distinfo b/editors/codelite/distinfo
index 31f75ee0aa7e..d74fb8a453b8 100644
--- a/editors/codelite/distinfo
+++ b/editors/codelite/distinfo
@@ -1,3 +1,3 @@
-MD5 (codelite-1.0.2841.tar.gz) = 0e1ad0ff13ae593a2a4c625f0da32102
-SHA256 (codelite-1.0.2841.tar.gz) = 727f7b7bfa944a717f37e146c10e26d4b20c5361cb6152ef55a419e1dfd99c66
-SIZE (codelite-1.0.2841.tar.gz) = 5864114
+MD5 (codelite-1.0.2893.tar.gz) = 79a878c37639af09e054cd8c9ebee528
+SHA256 (codelite-1.0.2893.tar.gz) = 894bf9e7c926e426543dc0c56dfba94efc4735ef1d842fb238994bfe67bd884a
+SIZE (codelite-1.0.2893.tar.gz) = 5913609
diff --git a/editors/codelite/files/patch-CodeLite_procutils.cpp b/editors/codelite/files/patch-CodeLite_procutils.cpp
deleted file mode 100644
index f18f8fbdf2b2..000000000000
--- a/editors/codelite/files/patch-CodeLite_procutils.cpp
+++ /dev/null
@@ -1,101 +0,0 @@
---- CodeLite/procutils.cpp.orig 2009-01-09 17:34:59.000000000 +0100
-+++ CodeLite/procutils.cpp 2009-05-23 13:45:05.000000000 +0200
-@@ -40,6 +40,15 @@
-
- #endif
-
-+#ifdef __FreeBSD__
-+#include <kvm.h>
-+#include <fcntl.h>
-+#include <sys/param.h>
-+#include <sys/sysctl.h>
-+#include <sys/user.h>
-+#include <paths.h>
-+#endif
-+
- ProcUtils::ProcUtils()
- {
- }
-@@ -135,6 +144,24 @@
- CloseHandle( hModuleSnap );
- return me32.szExePath;
-
-+#elif defined(__FreeBSD__)
-+ kvm_t *kvd;
-+ struct kinfo_proc *ki;
-+ int nof_procs;
-+ wxString cmd;
-+
-+ if (!(kvd = kvm_openfiles(_PATH_DEVNULL, _PATH_DEVNULL, NULL, O_RDONLY, NULL)))
-+ return wxEmptyString;
-+
-+ if (!(ki = kvm_getprocs(kvd, KERN_PROC_PID, pid, &nof_procs))) {
-+ kvm_close(kvd);
-+ return wxEmptyString;
-+ }
-+
-+ cmd = wxString(ki->ki_ocomm, wxConvUTF8);
-+ kvm_close(kvd);
-+
-+ return (cmd);
- #else
- wxArrayString output;
- ExecuteCommand(wxT("ps -A -o pid,command --no-heading"), output);
-@@ -223,6 +250,28 @@
- proclist.push_back(entry);
- } while (Process32Next (hProcessSnap, &pe));
- CloseHandle (hProcessSnap);
-+
-+#elif defined(__FreeBSD__)
-+ kvm_t *kvd;
-+ struct kinfo_proc *ki;
-+ int nof_procs, i;
-+
-+ if (!(kvd = kvm_openfiles(_PATH_DEVNULL, _PATH_DEVNULL, NULL, O_RDONLY, NULL)))
-+ return;
-+
-+ if (!(ki = kvm_getprocs(kvd, KERN_PROC_PROC, 0, &nof_procs))) {
-+ kvm_close(kvd);
-+ return;
-+ }
-+
-+ for (i=0; i<nof_procs; i++) {
-+ ProcessEntry entry;
-+ entry.pid = ki[i].ki_pid;
-+ entry.name = wxString(ki[i].ki_ocomm, wxConvUTF8);
-+ proclist.push_back(entry);
-+ }
-+ kvm_close(kvd);
-+
- #else
- //GTK and other
- wxArrayString output;
-@@ -299,6 +348,28 @@
- }
- } while (Process32Next (hProcessSnap, &pe));
- CloseHandle (hProcessSnap);
-+
-+#elif defined(__FreeBSD__)
-+ kvm_t *kvd;
-+ struct kinfo_proc *ki;
-+ int nof_procs, i;
-+
-+ if (!(kvd = kvm_openfiles(_PATH_DEVNULL, _PATH_DEVNULL, NULL, O_RDONLY, NULL)))
-+ return;
-+
-+ if (!(ki = kvm_getprocs(kvd, KERN_PROC_PROC, pid, &nof_procs))) {
-+ kvm_close(kvd);
-+ return;
-+ }
-+
-+ for (i=0; i<nof_procs; i++) {
-+ ProcessEntry entry;
-+ if (ki[i].ki_ppid == pid)
-+ proclist.push_back(ki[i].ki_pid);
-+ }
-+
-+ kvm_close(kvd);
-+
- #else
- //GTK and other
- wxArrayString output;
diff --git a/editors/codelite/pkg-plist b/editors/codelite/pkg-plist
index fa6a8eb921e1..bc6c8cabf8ad 100644
--- a/editors/codelite/pkg-plist
+++ b/editors/codelite/pkg-plist
@@ -15,6 +15,7 @@ bin/codelite_kill_children
%%DATADIR%%/images/plugin_ok.png
%%DATADIR%%/images/splashscreen.png
%%DATADIR%%/index.html
+%%DATADIR%%/lexers/BlackTheme/lexer_asm.xml
%%DATADIR%%/lexers/BlackTheme/lexer_cpp.xml
%%DATADIR%%/lexers/BlackTheme/lexer_default.xml
%%DATADIR%%/lexers/BlackTheme/lexer_diff.xml
@@ -25,8 +26,10 @@ bin/codelite_kill_children
%%DATADIR%%/lexers/BlackTheme/lexer_makefile.xml
%%DATADIR%%/lexers/BlackTheme/lexer_perl.xml
%%DATADIR%%/lexers/BlackTheme/lexer_properties.xml
+%%DATADIR%%/lexers/BlackTheme/lexer_python.xml
%%DATADIR%%/lexers/BlackTheme/lexer_script.xml
%%DATADIR%%/lexers/BlackTheme/lexer_xml.xml
+%%DATADIR%%/lexers/Default/lexer_asm.xml
%%DATADIR%%/lexers/Default/lexer_cpp.xml
%%DATADIR%%/lexers/Default/lexer_default.xml
%%DATADIR%%/lexers/Default/lexer_diff.xml
@@ -37,6 +40,7 @@ bin/codelite_kill_children
%%DATADIR%%/lexers/Default/lexer_makefile.xml
%%DATADIR%%/lexers/Default/lexer_perl.xml
%%DATADIR%%/lexers/Default/lexer_properties.xml
+%%DATADIR%%/lexers/Default/lexer_python.xml
%%DATADIR%%/lexers/Default/lexer_script.xml
%%DATADIR%%/lexers/Default/lexer_xml.xml
%%DATADIR%%/plugins/CodeFormatter.so
@@ -55,12 +59,22 @@ bin/codelite_kill_children
%%DATADIR%%/plugins/resources/abbreviation.accelerators
%%DATADIR%%/plugins/resources/compfile.png
%%DATADIR%%/plugins/resources/external_tools.accelerators
+%%DATADIR%%/plugins/resources/qt24_preferences.png
+%%DATADIR%%/plugins/resources/qt24_new.png
+%%DATADIR%%/plugins/resources/qt16_preferences.png
+%%DATADIR%%/plugins/resources/qt16_new.png
%%DATADIR%%/plugins/resources/svn_diff.png
%%DATADIR%%/plugins/resources/svn_settings.png
%%DATADIR%%/plugins/resources/svn_ssh.png
%%DATADIR%%/plugins/resources/wxfb_conflict.png
%%DATADIR%%/plugins/resources/wxfb_modified.png
%%DATADIR%%/plugins/resources/wxfb_ok.png
+%%DATADIR%%/plugins/libwxsqlite3u.so
+%%DATADIR%%/plugins/libwxscintillau.so
+%%DATADIR%%/plugins/libwxpropgridu.so
+%%DATADIR%%/plugins/libpluginu.so
+%%DATADIR%%/plugins/libcodeliteu.so
+%%DATADIR%%/plugins/QmakePlugin.so
%%DATADIR%%/plugins/wxformbuilder.so
%%DATADIR%%/rc/menu.xrc
%%DATADIR%%/src/unittest++1.3.tar.gz
@@ -132,6 +146,7 @@ bin/codelite_kill_children
%%DATADIR%%/templates/projects/vc-executable/vc-executable.project
%%DATADIR%%/templates/projects/vc-static-lib/icon.png
%%DATADIR%%/templates/projects/vc-static-lib/vc-static-lib.project
+%%DATADIR%%/templates/qmake/qmake.project
share/applications/codelite.desktop
@dirrm %%DATADIR%%/templates/projects/vc-static-lib
@dirrm %%DATADIR%%/templates/projects/vc-executable
@@ -152,6 +167,7 @@ share/applications/codelite.desktop
@dirrm %%DATADIR%%/templates/projects/custom-makefile
@dirrm %%DATADIR%%/templates/projects/UnitTest++
@dirrm %%DATADIR%%/templates/projects
+@dirrm %%DATADIR%%/templates/qmake
@dirrm %%DATADIR%%/templates/gizmos
@dirrm %%DATADIR%%/templates/formbuilder
@dirrm %%DATADIR%%/templates