aboutsummaryrefslogtreecommitdiff
path: root/editors/codelite
diff options
context:
space:
mode:
authorThomas Zander <riggs@FreeBSD.org>2016-08-14 07:39:36 +0000
committerThomas Zander <riggs@FreeBSD.org>2016-08-14 07:39:36 +0000
commit6a416adf42f40bb3582a85efb48d80258bdcbccb (patch)
treee5b48e69a2f3643c8545206f7336f5bb8357d869 /editors/codelite
parentc665df1f3415c94f46b629a3faf5f5131373bbf5 (diff)
downloadports-6a416adf42f40bb3582a85efb48d80258bdcbccb.tar.gz
ports-6a416adf42f40bb3582a85efb48d80258bdcbccb.zip
Notes
Diffstat (limited to 'editors/codelite')
-rw-r--r--editors/codelite/Makefile3
-rw-r--r--editors/codelite/pkg-plist10
2 files changed, 13 insertions, 0 deletions
diff --git a/editors/codelite/Makefile b/editors/codelite/Makefile
index be9eec40dfdc..2bd403b7e5f9 100644
--- a/editors/codelite/Makefile
+++ b/editors/codelite/Makefile
@@ -3,6 +3,7 @@
PORTNAME= codelite
PORTVERSION= 9.2
+PORTREVISION= 1
CATEGORIES= editors devel
MAINTAINER= mokhi64@gmail.com
@@ -11,12 +12,14 @@ COMMENT= Open Source IDE for C/C++
LICENSE= GPLv2+
RUN_DEPENDS= xterm:x11/xterm
+LIB_DEPENDS+= libhunspell-1.3.so:textproc/hunspell
USE_GITHUB= yes
GH_ACCOUNT= eranif
USES= cmake:outsource compiler:c++11-lib dos2unix execinfo gettext \
pathfix shebangfix sqlite
+USE_GNOME+= cairo gtk20
DOS2UNIX_GLOB= *.cpp *.txt
SHEBANG_FILES= Runtime/codelite_xterm
bash_CMD= /bin/sh
diff --git a/editors/codelite/pkg-plist b/editors/codelite/pkg-plist
index db85d8a443cd..bf93b246c110 100644
--- a/editors/codelite/pkg-plist
+++ b/editors/codelite/pkg-plist
@@ -9,6 +9,16 @@ bin/codelite_fix_files
bin/codelite_indexer
bin/codelite_kill_children
bin/codelite_xterm
+%%CLANG34%%bin/codelite-lldb
+%%CLANG34%%lib/codelite/LLDBDebugger.so
+%%CLANG35%%bin/codelite-lldb
+%%CLANG35%%lib/codelite/LLDBDebugger.so
+%%CLANG36%%bin/codelite-lldb
+%%CLANG36%%lib/codelite/LLDBDebugger.so
+%%CLANG37%%bin/codelite-lldb
+%%CLANG37%%lib/codelite/LLDBDebugger.so
+%%CLANG38%%bin/codelite-lldb
+%%CLANG38%%lib/codelite/LLDBDebugger.so
lib/codelite/CMakePlugin.so
lib/codelite/CallGraph.so
lib/codelite/CodeFormatter.so