aboutsummaryrefslogtreecommitdiff
path: root/editors/codelite
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2014-01-21 16:18:52 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2014-01-21 16:18:52 +0000
commit17d64225a4d41f8c7b6f01db09c7a32fa0bdaa81 (patch)
tree5183c8c7110ad22e51af2678b66cec7a709658f4 /editors/codelite
parent2567b372517cd6c29cc845e12d602e260f431f86 (diff)
downloadports-17d64225a4d41f8c7b6f01db09c7a32fa0bdaa81.tar.gz
ports-17d64225a4d41f8c7b6f01db09c7a32fa0bdaa81.zip
Notes
Diffstat (limited to 'editors/codelite')
-rw-r--r--editors/codelite/Makefile12
-rw-r--r--editors/codelite/files/patch-CMakeLists.txt6
-rw-r--r--editors/codelite/files/patch-CodeLite_cpptoken.h11
3 files changed, 19 insertions, 10 deletions
diff --git a/editors/codelite/Makefile b/editors/codelite/Makefile
index 92a9e9cb9ce3..bb5b27c29e45 100644
--- a/editors/codelite/Makefile
+++ b/editors/codelite/Makefile
@@ -12,7 +12,7 @@ COMMENT= An Open Source IDE for C/C++
LICENSE= GPLv2
-LIB_DEPENDS= curl:${PORTSDIR}/ftp/curl
+LIB_DEPENDS= libcurl.so:${PORTSDIR}/ftp/curl
RUN_DEPENDS= xterm:${PORTSDIR}/x11/xterm
OPTIONS_DEFINE= CSCOPE CLANG
@@ -22,9 +22,8 @@ CLANG_DESC= Clang code-completion
USE_WX= 2.9
WX_UNICODE= yes
-USE_DOS2UNIX= *.cpp
-USES= gettext cmake:outsource
-USE_LDCONFIG= lib/codelite
+USES= gettext cmake:outsource dos2unix
+USE_LDCONFIG= ${PREFIX}/lib/codelite
CMAKE_ARGS+= -DIS_FREEBSD=1 \
-DPREFIX=${PREFIX}
@@ -32,7 +31,6 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
SVN_REVISION= 6213
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MCSCOPE}
@@ -40,8 +38,8 @@ RUN_DEPENDS+= cscope:${PORTSDIR}/devel/cscope
.endif
.if ${PORT_OPTIONS:MCLANG}
-BUILD_DEPENDS+= ${LOCALBASE}/lib/libclang.so:${PORTSDIR}/lang/clang-devel
-RUN_DEPENDS+= ${LOCALBASE}/lib/libclang.so:${PORTSDIR}/lang/clang-devel
+BUILD_DEPENDS+= ${LOCALBASE}/llvm-devel/lib/libclang.so:${PORTSDIR}/lang/clang-devel
+RUN_DEPENDS+= ${LOCALBASE}/llvm-devel/lib/libclang.so:${PORTSDIR}/lang/clang-devel
PLIST_SUB+= CLANG=""
CMAKE_ARGS+= -DENABLE_CLANG=1
.else
diff --git a/editors/codelite/files/patch-CMakeLists.txt b/editors/codelite/files/patch-CMakeLists.txt
index 94ee53871bd0..1989460ead69 100644
--- a/editors/codelite/files/patch-CMakeLists.txt
+++ b/editors/codelite/files/patch-CMakeLists.txt
@@ -7,9 +7,9 @@
- set( CLANG_INCLUDE "${CL_SRC_ROOT}/sdk/clang/Linux/${ARCH_NAME}/include" )
- set( CLANG_LIBRARY "-L${CL_SRC_ROOT}/sdk/clang/Linux/${ARCH_NAME}/lib -lclang" )
- set( CLANG_BINARY "${CL_SRC_ROOT}/sdk/clang/Linux/${ARCH_NAME}/lib/libclang.so")
-+ set( CLANG_INCLUDE "%%LOCALBASE%%/include" )
-+ set( CLANG_LIBRARY "-L%%LOCALBASE%%/lib/ -lclang" )
-+ set( CLANG_BINARY "%%LOCALBASE%%/lib/libclang.so")
++ set( CLANG_INCLUDE "%%LOCALBASE%%/llvm-devel/include" )
++ set( CLANG_LIBRARY "-L%%LOCALBASE%%/llvm-devel/lib/ -lclang" )
++ set( CLANG_BINARY "%%LOCALBASE%%/llvm-devel/lib/libclang.so")
endif()
message( "-- clang link line ${CLANG_LIBRARY} ")
diff --git a/editors/codelite/files/patch-CodeLite_cpptoken.h b/editors/codelite/files/patch-CodeLite_cpptoken.h
new file mode 100644
index 000000000000..085de87482e1
--- /dev/null
+++ b/editors/codelite/files/patch-CodeLite_cpptoken.h
@@ -0,0 +1,11 @@
+--- CodeLite/cpptoken.h.orig 2014-01-21 10:05:01.000000000 +0100
++++ CodeLite/cpptoken.h 2014-01-21 10:05:10.000000000 +0100
+@@ -87,7 +87,7 @@
+ void print();
+
+ // Provide lower-than operator so we can use std::list::sort method
+- bool operator < (const CppToken& rhs) {
++ bool operator < (const CppToken& rhs) const {
+ return filename < rhs.filename;
+ }
+ };