aboutsummaryrefslogtreecommitdiff
path: root/editors/cooledit
diff options
context:
space:
mode:
authorChris Piazza <cpiazza@FreeBSD.org>2000-01-29 06:56:35 +0000
committerChris Piazza <cpiazza@FreeBSD.org>2000-01-29 06:56:35 +0000
commitfe11e34f92f2134a8ddfe7261633708d67576eac (patch)
tree0bae30a8b3ffc5eeb60a52b6afeb6f5a89e7a4b9 /editors/cooledit
parent62a15d733469b31c873f26d25c715a62a775d871 (diff)
downloadports-fe11e34f92f2134a8ddfe7261633708d67576eac.tar.gz
ports-fe11e34f92f2134a8ddfe7261633708d67576eac.zip
Notes
Diffstat (limited to 'editors/cooledit')
-rw-r--r--editors/cooledit/Makefile2
-rw-r--r--editors/cooledit/distinfo2
-rw-r--r--editors/cooledit/files/patch-ae6
-rw-r--r--editors/cooledit/files/patch-af8
-rw-r--r--editors/cooledit/files/patch-ah14
-rw-r--r--editors/cooledit/files/patch-al11
-rw-r--r--editors/cooledit/pkg-plist2
7 files changed, 29 insertions, 16 deletions
diff --git a/editors/cooledit/Makefile b/editors/cooledit/Makefile
index 6d6363897264..6419c38f8243 100644
--- a/editors/cooledit/Makefile
+++ b/editors/cooledit/Makefile
@@ -6,7 +6,7 @@
# $FreeBSD$
#
-DISTNAME= cooledit-3.11.3
+DISTNAME= cooledit-3.12.0
CATEGORIES= editors
MASTER_SITES= ${MASTER_SITE_SUNSITE} \
http://www.netins.net/showcase/Comput-IT/cooledit/src/
diff --git a/editors/cooledit/distinfo b/editors/cooledit/distinfo
index 9439ffabfbdb..83ea3f084b6c 100644
--- a/editors/cooledit/distinfo
+++ b/editors/cooledit/distinfo
@@ -1 +1 @@
-MD5 (cooledit-3.11.3.tar.gz) = ea0f8aa393d1a77c76c0d7f2ffd358b7
+MD5 (cooledit-3.12.0.tar.gz) = 6071b98029c366e7d42e08ccafc71949
diff --git a/editors/cooledit/files/patch-ae b/editors/cooledit/files/patch-ae
index 0bcbab8d53a9..309103896a48 100644
--- a/editors/cooledit/files/patch-ae
+++ b/editors/cooledit/files/patch-ae
@@ -1,5 +1,5 @@
---- syntax/Makefile.in.orig Mon Jun 7 15:12:47 1999
-+++ syntax/Makefile.in Mon Jun 7 15:15:31 1999
+--- syntax/Makefile.in.orig Tue Nov 30 02:34:36 1999
++++ syntax/Makefile.in Wed Jan 26 18:35:05 2000
@@ -99,7 +99,7 @@
VERSION = @VERSION@
l = @l@
@@ -7,5 +7,5 @@
-syntaxdir = $(libdir)/cooledit/syntax
+syntaxdir = $(datadir)/cooledit/syntax
- syntax_DATA = c.syntax changelog.syntax diff.syntax diffc.syntax html.syntax java.syntax latex.syntax lsm.syntax makefile.syntax ml.syntax nroff.syntax pascal.syntax perl.syntax python.syntax sh.syntax smalltalk.syntax texinfo.syntax unknown.syntax swig.syntax
+ syntax_DATA = c.syntax changelog.syntax diff.syntax diffc.syntax html.syntax java.syntax latex.syntax lsm.syntax makefile.syntax ml.syntax nroff.syntax pascal.syntax perl.syntax python.syntax sh.syntax smalltalk.syntax texinfo.syntax unknown.syntax swig.syntax mail.syntax ada95.syntax
diff --git a/editors/cooledit/files/patch-af b/editors/cooledit/files/patch-af
index 856494ee0910..8a15854d8a49 100644
--- a/editors/cooledit/files/patch-af
+++ b/editors/cooledit/files/patch-af
@@ -1,6 +1,6 @@
---- widget/syntax.c.orig Fri Jun 11 16:24:41 1999
-+++ widget/syntax.c Sat Jun 12 08:30:33 1999
-@@ -729,7 +729,7 @@
+--- widget/syntax.c.orig Tue Nov 30 02:34:27 1999
++++ widget/syntax.c Wed Jan 26 18:36:26 2000
+@@ -590,7 +590,7 @@
f = fopen (p, "r");
if (f)
return f;
@@ -8,4 +8,4 @@
+ strcpy (p, DATADIR "/cooledit/syntax/");
strcat (p, filename);
syntax_free (error_file_name);
- error_file_name = strdup (p);
+ error_file_name = (char *) strdup (p);
diff --git a/editors/cooledit/files/patch-ah b/editors/cooledit/files/patch-ah
index ef786f4bc732..14504b9fd61f 100644
--- a/editors/cooledit/files/patch-ah
+++ b/editors/cooledit/files/patch-ah
@@ -1,15 +1,15 @@
---- editor/coolpython.c.orig Fri Jun 11 16:24:42 1999
-+++ editor/coolpython.c Sat Jun 12 08:30:33 1999
-@@ -1485,7 +1485,7 @@
+--- editor/coolpython.c.orig Thu Jan 27 22:59:34 2000
++++ editor/coolpython.c Thu Jan 27 23:00:34 2000
+@@ -1487,7 +1487,7 @@
PyDict_SetItemString (d, "Mod3Mask", PyInt_FromLong ((long) Mod3Mask));
PyDict_SetItemString (d, "Mod4Mask", PyInt_FromLong ((long) Mod4Mask));
PyDict_SetItemString (d, "Mod5Mask", PyInt_FromLong ((long) Mod5Mask));
- PyDict_SetItemString (d, "LIBDIR", PyString_FromString (LIBDIR));
+ PyDict_SetItemString (d, "DATADIR", PyString_FromString (DATADIR));
- }
- void coolpython_run_file (char *filename)
-@@ -1544,7 +1544,7 @@
+ PyDict_SetItemString (d, "Mod5Mask", PyInt_FromLong ((long) Mod5Mask));
+
+@@ -1569,7 +1569,7 @@
import sys\n\
sys.path.append('%s')\n\
sys.path.append('%s%s')\n\
@@ -18,7 +18,7 @@
e = PyRun_String (s, Py_file_input, name_space, name_space);
if (!e) {
PyErr_Print ();
-@@ -1553,7 +1553,7 @@
+@@ -1578,7 +1578,7 @@
}
Py_DECREF (e);
coolpython_constants (name_space);
diff --git a/editors/cooledit/files/patch-al b/editors/cooledit/files/patch-al
new file mode 100644
index 000000000000..73ee55c9b3f4
--- /dev/null
+++ b/editors/cooledit/files/patch-al
@@ -0,0 +1,11 @@
+--- editor/Makefile.in.orig Fri Jan 28 22:41:04 2000
++++ editor/Makefile.in Fri Jan 28 22:41:32 2000
+@@ -116,7 +116,7 @@
+ datadir = $(prefix)/@DATADIRNAME@
+ localedir = $(datadir)/locale
+
+-DEFS = -DLOCALEDIR=\"$(localedir)\" -DLIBDIR=\"${exec_prefix}/lib/cooledit\" @DEFS@
++DEFS = -DLOCALEDIR=\"$(localedir)\" -DLIBDIR=\"${exec_prefix}/lib/cooledit\" -DSYSCONFDIR=\"$(sysconfdir)\" -DDATADIR=\"$(datadir)/coolicon\" @DEFS@
+ mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
+ CONFIG_HEADER = ../config.h
+ CONFIG_CLEAN_FILES =
diff --git a/editors/cooledit/pkg-plist b/editors/cooledit/pkg-plist
index 59a2070f689b..7b785ed32b33 100644
--- a/editors/cooledit/pkg-plist
+++ b/editors/cooledit/pkg-plist
@@ -16,6 +16,7 @@ lib/libCw.so.1
@exec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -m %B
@unexec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -R
share/cooledit/global.py
+share/cooledit/syntax/ada95.syntax
share/cooledit/syntax/c.syntax
share/cooledit/syntax/changelog.syntax
share/cooledit/syntax/diff.syntax
@@ -24,6 +25,7 @@ share/cooledit/syntax/html.syntax
share/cooledit/syntax/java.syntax
share/cooledit/syntax/latex.syntax
share/cooledit/syntax/lsm.syntax
+share/cooledit/syntax/mail.syntax
share/cooledit/syntax/makefile.syntax
share/cooledit/syntax/ml.syntax
share/cooledit/syntax/nroff.syntax