aboutsummaryrefslogtreecommitdiff
path: root/editors/cream/Makefile
diff options
context:
space:
mode:
authorWilliam Grzybowski <wg@FreeBSD.org>2014-07-29 16:41:50 +0000
committerWilliam Grzybowski <wg@FreeBSD.org>2014-07-29 16:41:50 +0000
commit1ec32f8947d9e0bd3681573779a64c72afc2614f (patch)
tree45d867abdeb20b1742969bfefb5b6031d1a24f9f /editors/cream/Makefile
parent0ce9c970cf1f04781b118a59f97f3eb1664b66e8 (diff)
downloadports-1ec32f8947d9e0bd3681573779a64c72afc2614f.tar.gz
ports-1ec32f8947d9e0bd3681573779a64c72afc2614f.zip
Notes
Diffstat (limited to 'editors/cream/Makefile')
-rw-r--r--editors/cream/Makefile45
1 files changed, 26 insertions, 19 deletions
diff --git a/editors/cream/Makefile b/editors/cream/Makefile
index 8229551baed0..be3276a8f9bc 100644
--- a/editors/cream/Makefile
+++ b/editors/cream/Makefile
@@ -2,40 +2,47 @@
# $FreeBSD$
PORTNAME= cream
-PORTVERSION= 0.42
-PORTREVISION= 1
+PORTVERSION= 0.43
CATEGORIES= editors
MASTER_SITES= SF/${PORTNAME}/Cream/${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Gvim extension with many features
+LICENSE= GPLv3
+
RUN_DEPENDS= ${LOCALBASE}/bin/gvim:${PORTSDIR}/editors/vim
+NO_ARCH= yes
NO_BUILD= yes
-PLIST_SUB= VIMRUNTIME="${VIMRUNTIME:S/${PREFIX}\///}"
-NO_STAGE= yes
-.include <bsd.port.pre.mk>
+USES= desktop-file-utils
+
+PLIST_SUB= VIM_VER="${VIM_VER}"
+
+OPTIONS_DEFINE= DOCS
-VIMRUNTIME!= cd ${PORTSDIR}/editors/vim && ${MAKE} -V DATADIR
+VIMRUNTIME!= cd ../vim && ${MAKE} -V PORTVERSION:R:S,\.,,g
+VIM_VER?= vim${VIMRUNTIME}
do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/cream ${PREFIX}/bin
- ${MKDIR} ${VIMRUNTIME}/cream
- ${INSTALL_DATA} ${WRKSRC}/creamrc ${WRKSRC}/*.vim ${VIMRUNTIME}/cream
+ (cd ${WRKSRC} && ${INSTALL_SCRIPT} cream \
+ ${STAGEDIR}${PREFIX}/bin)
+ @${MKDIR} ${STAGEDIR}${PREFIX}/share/vim/${VIM_VER}/cream
+ (cd ${WRKSRC} && ${INSTALL_DATA} creamrc *.vim \
+ ${STAGEDIR}${PREFIX}/share/vim/${VIM_VER}/cream)
.for f in addons bitmaps help lang
- ${MKDIR} ${VIMRUNTIME}/cream/${f}
- ${INSTALL_DATA} ${WRKSRC}/${f}/* ${VIMRUNTIME}/cream/${f}
+ @(cd ${WRKSRC} && ${COPYTREE_SHARE} ${f} \
+ ${STAGEDIR}${PREFIX}/share/vim/${VIM_VER}/cream)
.endfor
- ${INSTALL_DATA} ${WRKSRC}/cream.png ${WRKSRC}/cream.svg \
- ${PREFIX}/share/pixmaps
- ${INSTALL_DATA} ${WRKSRC}/cream.desktop ${PREFIX}/share/applications
-.if !defined(NOPORTDOCS)
+ (cd ${WRKSRC} && ${INSTALL_DATA} cream.desktop \
+ ${STAGEDIR}${PREFIX}/share/applications)
+ (cd ${WRKSRC} && ${INSTALL_DATA} cream.png cream.svg \
+ ${STAGEDIR}${PREFIX}/share/pixmaps)
.for f in docs docs-html
- ${MKDIR} ${DOCSDIR}/${f}
- ${INSTALL_DATA} ${WRKSRC}/${f}/* ${DOCSDIR}/${f}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ @(cd ${WRKSRC} && ${COPYTREE_SHARE} ${f} \
+ ${STAGEDIR}${DOCSDIR})
.endfor
-.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>