aboutsummaryrefslogtreecommitdiff
path: root/editors/doxymacs/Makefile
diff options
context:
space:
mode:
authorSam Lawrance <lawrance@FreeBSD.org>2005-11-10 22:20:58 +0000
committerSam Lawrance <lawrance@FreeBSD.org>2005-11-10 22:20:58 +0000
commit9607a1c585d4b17b8ae600482982d50c70f31c4b (patch)
tree175754fe53bfaea67547a69554f980086d3d1675 /editors/doxymacs/Makefile
parentcd1f87030a26d02307b452a264f7041f2445c124 (diff)
Add doxymacs 1.5.0. Doxymacs is Doxygen + {X}Emacs.
The purpose of the doxymacs project is to create a LISP package that will make using Doxygen from within {X}Emacs easier. It has the following features: * ability to look up documentation for symbols from {X}Emacs in the browser of your choice. * easily insert Doxygen style comments into source. * optionally use an "external" (i.e. written in C) XML parser to speed up building the completion list. * fontify Doxygen keywords. WWW: http://doxymacs.sourceforge.net/ PR: ports/60472 Submitted by: Dryice Liu <dryice@liu.com.cn>
Notes
Notes: svn path=/head/; revision=147855
Diffstat (limited to 'editors/doxymacs/Makefile')
-rw-r--r--editors/doxymacs/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/editors/doxymacs/Makefile b/editors/doxymacs/Makefile
new file mode 100644
index 000000000000..086071848f20
--- /dev/null
+++ b/editors/doxymacs/Makefile
@@ -0,0 +1,24 @@
+# Ports collection makefile for: w3 on Emacs21
+# Date created: 21 December 2003
+# Whom: Dryice Liu <dryice@liu.com.cn>
+#
+# $FreeBSD$
+#
+
+PORTNAME= doxymacs
+PORTVERSION= 1.5.0
+CATEGORIES= editors elisp
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= dryice@liu.com.cn
+COMMENT= Doxymacs is Doxygen + {X}Emacs
+
+EMACS_PORT_NAME?= emacs21
+BUILD_DEPENDS= ${LOCALBASE}/${EMACS_VERSION_SITE_LISPDIR}/w3/w3.el:${PORTSDIR}/www/w3-4 \
+ xmllint:${PORTSDIR}/textproc/libxml2
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+GNU_CONFIGURE= yes
+
+.include <bsd.port.mk>