aboutsummaryrefslogtreecommitdiff
path: root/editors/e93
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2006-12-21 05:39:28 +0000
committerAlejandro Pulver <alepulver@FreeBSD.org>2006-12-21 05:39:28 +0000
commit00459322025c73607d4bcc4613028b4a4612e13f (patch)
tree01b34adafb5148f8611da040e14f1fad9b866510 /editors/e93
parenta5363d092568ccc76af1737338bcb86ab2977ee6 (diff)
downloadports-00459322025c73607d4bcc4613028b4a4612e13f.tar.gz
ports-00459322025c73607d4bcc4613028b4a4612e13f.zip
Notes
Diffstat (limited to 'editors/e93')
-rw-r--r--editors/e93/Makefile50
-rw-r--r--editors/e93/distinfo6
-rw-r--r--editors/e93/files/patch-channels.c20
-rw-r--r--editors/e93/files/patch-shell.c11
-rw-r--r--editors/e93/files/patch-shellcmd.c111
-rw-r--r--editors/e93/pkg-plist44
6 files changed, 189 insertions, 53 deletions
diff --git a/editors/e93/Makefile b/editors/e93/Makefile
index 325e173824d8..f0bf4d297343 100644
--- a/editors/e93/Makefile
+++ b/editors/e93/Makefile
@@ -6,11 +6,10 @@
#
PORTNAME= e93
-PORTVERSION= 1.3.2
+PORTVERSION= 1.3.4
CATEGORIES= editors tcl82 tk82
-MASTER_SITES= ${MASTER_SITE_XCONTRIB}
-MASTER_SITE_SUBDIR= editors
-DISTNAME= ${PORTNAME}-1.3r2X
+MASTER_SITES= ftp://ftp.e93.org/pub/
+DISTNAME= ${PORTNAME}-1.3r4X
EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
@@ -20,40 +19,15 @@ LIB_DEPENDS= tcl82.1:${PORTSDIR}/lang/tcl82 \
tk82.1:${PORTSDIR}/x11-toolkits/tk82
WRKSRC= ${WRKDIR}/${PORTNAME}
-USE_X_PREFIX= yes
-
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 500113
-BROKEN= "Does not compile"
-.endif
do-install:
- ${MKDIR} ${PREFIX}/share/doc/e93 ${PREFIX}/lib/e93lib/images \
- ${PREFIX}/lib/e93lib/highlightschemes \
- ${PREFIX}/lib/e93lib/modules \
- ${PREFIX}/lib/e93lib/syntaxmaps
- (cd ${WRKSRC}; \
- ${INSTALL_PROGRAM} e93 ${PREFIX}/bin; \
- ${INSTALL_SCRIPT} e93r ${PREFIX}/bin; \
- ${INSTALL_DATA} LICENSE.TXT ${PREFIX}/share/doc/e93; \
- ${INSTALL_DATA} README.e93 ${PREFIX}/share/doc/e93; \
- ${INSTALL_DATA} README.regex ${PREFIX}/share/doc/e93; \
- ${INSTALL_DATA} README.syntaxmaps ${PREFIX}/share/doc/e93; \
- )
- (cd ${WRKSRC}/e93lib; \
- ${INSTALL_DATA} e93rc.tcl ${PREFIX}/lib/e93lib; \
- ${INSTALL_DATA} images/about.ppm ${PREFIX}/lib/e93lib/images; \
- ${INSTALL_DATA} highlightschemes/schemes.tcl ${PREFIX}/lib/e93lib/highlightschemes; \
- ${INSTALL_DATA} modules/c.tcl ${PREFIX}/lib/e93lib/modules; \
- ${INSTALL_DATA} syntaxmaps/unknown.tcl ${PREFIX}/lib/e93lib/syntaxmaps; \
- ${INSTALL_DATA} syntaxmaps/asm.tcl ${PREFIX}/lib/e93lib/syntaxmaps; \
- ${INSTALL_DATA} syntaxmaps/html.tcl ${PREFIX}/lib/e93lib/syntaxmaps; \
- ${INSTALL_DATA} syntaxmaps/java.tcl ${PREFIX}/lib/e93lib/syntaxmaps; \
- ${INSTALL_DATA} syntaxmaps/tcl.tcl ${PREFIX}/lib/e93lib/syntaxmaps; \
- ${INSTALL_DATA} syntaxmaps/vhdl.tcl ${PREFIX}/lib/e93lib/syntaxmaps; \
- ${INSTALL_DATA} syntaxmaps/text.tcl ${PREFIX}/lib/e93lib/syntaxmaps; \
- ${INSTALL_DATA} syntaxmaps/c.tcl ${PREFIX}/lib/e93lib/syntaxmaps; \
- )
+ ${INSTALL_PROGRAM} ${WRKSRC}/e93 ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/e93r ${PREFIX}/bin
+ ${MKDIR} ${PREFIX}/lib/e93lib
+ ${CP} -R ${WRKSRC}/e93lib/* ${PREFIX}/lib/e93lib
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README* ${DOCSDIR}
+.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/editors/e93/distinfo b/editors/e93/distinfo
index 78253429b943..72b1748659b4 100644
--- a/editors/e93/distinfo
+++ b/editors/e93/distinfo
@@ -1,3 +1,3 @@
-MD5 (e93-1.3r2X.tgz) = 21e07a5745cf7fb48fbaf0046cdd1bb9
-SHA256 (e93-1.3r2X.tgz) = ad561c91379e94e8a4ef53a055c47daa083c7b2f9c4b1133fd24c856decca199
-SIZE (e93-1.3r2X.tgz) = 323524
+MD5 (e93-1.3r4X.tgz) = afc4fde7d4a76bb4652ba66e03766a18
+SHA256 (e93-1.3r4X.tgz) = 479f584d8d35ebbb5ceb8ee957ffa2b1dc84fdfa6d38e384756db6667d5c1329
+SIZE (e93-1.3r4X.tgz) = 431179
diff --git a/editors/e93/files/patch-channels.c b/editors/e93/files/patch-channels.c
new file mode 100644
index 000000000000..9684436394de
--- /dev/null
+++ b/editors/e93/files/patch-channels.c
@@ -0,0 +1,20 @@
+--- ./channels.c.orig Sat May 29 12:01:41 2004
++++ ./channels.c Wed Dec 20 14:35:21 2006
+@@ -54,7 +54,7 @@
+ return(TCL_OK); // nothing for us to do, but this proc must exist
+ }
+
+-static int StdoutOutputProc(ClientData clientData,const char *buf,int charsToWrite,int *errorCode)
++static int StdoutOutputProc(ClientData clientData,char *buf,int charsToWrite,int *errorCode)
+ // Writes the given output on the IO channel. Returns count of how
+ // many characters were actually written, and an error indication.
+ {
+@@ -76,7 +76,7 @@
+ return(charsWritten);
+ }
+
+-static int StderrOutputProc(ClientData clientData,const char *buf,int charsToWrite,int *errorCode)
++static int StderrOutputProc(ClientData clientData,char *buf,int charsToWrite,int *errorCode)
+ // Writes the given output on the IO channel. Returns count of how
+ // many characters were actually written, and an error indication.
+ {
diff --git a/editors/e93/files/patch-shell.c b/editors/e93/files/patch-shell.c
new file mode 100644
index 000000000000..17ac9c84bde3
--- /dev/null
+++ b/editors/e93/files/patch-shell.c
@@ -0,0 +1,11 @@
+--- ./shell.c.orig Mon May 31 19:37:29 2004
++++ ./shell.c Wed Dec 20 14:24:36 2006
+@@ -935,7 +935,7 @@
+ return(TCL_ERROR);
+ }
+
+-static void TraceCheckAbortProc(ClientData theClientData,Tcl_Interp *theInterpreter,int theLevel,char *theCommand,Tcl_CmdProc *theProc,ClientData cmdClientData,int argc,const char *argv[])
++static void TraceCheckAbortProc(ClientData theClientData,Tcl_Interp *theInterpreter,int theLevel,char *theCommand,Tcl_CmdProc *theProc,ClientData cmdClientData,int argc,char *argv[])
+ // This is a small trick on Tcl. We tell it we want to trace, but really, we want
+ // to check to see if the user is trying to abort the execution of a script.
+ // So, every time we are called, we check to see if the user is aborting, and
diff --git a/editors/e93/files/patch-shellcmd.c b/editors/e93/files/patch-shellcmd.c
new file mode 100644
index 000000000000..1d92b1a5aade
--- /dev/null
+++ b/editors/e93/files/patch-shellcmd.c
@@ -0,0 +1,111 @@
+--- ./shellcmd.c.orig Thu Dec 1 16:16:19 2005
++++ ./shellcmd.c Wed Dec 20 14:34:05 2006
+@@ -199,7 +199,7 @@
+ return(false);
+ }
+
+-static bool GetUINT32String(Tcl_Interp *localInterpreter,const char *theString,UINT32 *theNumber)
++static bool GetUINT32String(Tcl_Interp *localInterpreter,char *theString,UINT32 *theNumber)
+ // convert theString to a UINT32
+ // return false if the conversion failed, and fill the Tcl result
+ {
+@@ -668,7 +668,7 @@
+ {
+ for(theIndex=1;!fail&&(int)theIndex<objc;theIndex++)
+ {
+- if(Tcl_SplitList(localInterpreter,Tcl_GetStringFromObj(objv[theIndex],NULL),&pathArgc,&pathArgv)==TCL_OK)
++ if(Tcl_SplitList(localInterpreter,Tcl_GetStringFromObj(objv[theIndex],NULL),&pathArgc,(char ***)&pathArgv)==TCL_OK)
+ {
+ theMenu=NULL; // start at the root
+ if(GetEditorMenu(pathArgc,pathArgv,&theMenu))
+@@ -720,7 +720,7 @@
+ {
+ if(GetBoolean(localInterpreter,objv[3],&active))
+ {
+- if(Tcl_SplitList(localInterpreter,Tcl_GetStringFromObj(objv[1],NULL),&pathArgc,&pathArgv)==TCL_OK)
++ if(Tcl_SplitList(localInterpreter,Tcl_GetStringFromObj(objv[1],NULL),&pathArgc,(char ***)&pathArgv)==TCL_OK)
+ {
+ if(CreateEditorMenu(pathArgc,pathArgv,theRelationship,Tcl_GetStringFromObj(objv[4],NULL),Tcl_GetStringFromObj(objv[5],NULL),Tcl_GetStringFromObj(objv[6],NULL),active))
+ {
+@@ -1223,7 +1223,7 @@
+ fail=false;
+ if(objc==3)
+ {
+- if(Tcl_SplitList(localInterpreter,Tcl_GetStringFromObj(objv[2],NULL),&listArgc,&listArgv)==TCL_OK)
++ if(Tcl_SplitList(localInterpreter,Tcl_GetStringFromObj(objv[2],NULL),&listArgc,(char ***)&listArgv)==TCL_OK)
+ {
+ if((selectedElements=(bool *)MNewPtrClr(sizeof(bool)*listArgc))) // get array of "falses"
+ {
+@@ -3696,19 +3696,19 @@
+ {
+ if(ShellBufferNotBusy(localInterpreter,theBuffer))
+ {
+- if(Tcl_SplitList(localInterpreter,Tcl_GetStringFromObj(objv[2],NULL),&listArgc,&listArgv)==TCL_OK)
++ if(Tcl_SplitList(localInterpreter,Tcl_GetStringFromObj(objv[2],NULL),&listArgc,(char ***)&listArgv)==TCL_OK)
+ {
+ EditorStartSelectionChange(theBuffer);
+ fail=false;
+ for(i=0;!fail&&i<listArgc;i++)
+ {
+- if(Tcl_SplitList(localInterpreter,listArgv[i],&elementArgc,&elementArgv)==TCL_OK)
++ if(Tcl_SplitList(localInterpreter,listArgv[i],&elementArgc,(char ***)&elementArgv)==TCL_OK)
+ {
+ if(elementArgc==2)
+ {
+- if(GetUINT32String(localInterpreter,elementArgv[0],&startPosition))
++ if(GetUINT32String(localInterpreter,(char *)elementArgv[0],&startPosition))
+ {
+- if(GetUINT32String(localInterpreter,elementArgv[1],&endPosition))
++ if(GetUINT32String(localInterpreter,(char *)elementArgv[1],&endPosition))
+ {
+ startPosition=ForcePositionIntoRange(theBuffer,startPosition);
+ endPosition=ForcePositionIntoRange(theBuffer,endPosition);
+@@ -4604,7 +4604,7 @@
+ fail;
+
+ fail=false;
+- if(Tcl_SplitList(localInterpreter,endExpressionList,&argc,&argv)==TCL_OK) // get list of end expressions
++ if(Tcl_SplitList(localInterpreter,endExpressionList,&argc,(char ***)&argv)==TCL_OK) // get list of end expressions
+ {
+ for(i=0;!fail&&i<argc;i++)
+ {
+@@ -4654,11 +4654,11 @@
+ SetMappingStartExpressionPiece(theMapping,expressionPiece);
+ if(ParseEndExpressions(localInterpreter,theMap,theMapping,argv[2]))
+ {
+- if(GetUINT32String(localInterpreter,argv[3],&startStyle))
++ if(GetUINT32String(localInterpreter,(char *)argv[3],&startStyle))
+ {
+- if(GetUINT32String(localInterpreter,argv[4],&betweenStyle))
++ if(GetUINT32String(localInterpreter,(char *)argv[4],&betweenStyle))
+ {
+- if(GetUINT32String(localInterpreter,argv[5],&endStyle))
++ if(GetUINT32String(localInterpreter,(char *)argv[5],&endStyle))
+ {
+ SetMappingStyles(theMapping,startStyle,betweenStyle,endStyle);
+ return(true);
+@@ -4704,13 +4704,13 @@
+ i,j;
+
+ fail=false;
+- if(Tcl_SplitList(localInterpreter,mapContents,&listArgc,&listArgv)==TCL_OK) // make list of command/parameter
++ if(Tcl_SplitList(localInterpreter,mapContents,&listArgc,(char ***)&listArgv)==TCL_OK) // make list of command/parameter
+ {
+ for(i=0;(i<listArgc)&&!fail;i+=2) // step over each command, parameter list pair
+ {
+ if(MatchToken(listArgv[i],syntaxMapCommands,&syntaxMapToken))
+ {
+- if(Tcl_SplitList(localInterpreter,listArgv[i+1],&argc,&argv)==TCL_OK) // make parameters into arguments
++ if(Tcl_SplitList(localInterpreter,listArgv[i+1],&argc,(char ***)&argv)==TCL_OK) // make parameters into arguments
+ {
+ switch(syntaxMapToken)
+ {
+@@ -4749,7 +4749,7 @@
+ {
+ if((theMapping=LocateSyntaxStyleMapping(theMap,argv[0])))
+ {
+- if(Tcl_SplitList(localInterpreter,argv[1],&mappinglistArgc,&mappinglistArgv)==TCL_OK) // make parameters into arguments
++ if(Tcl_SplitList(localInterpreter,argv[1],&mappinglistArgc,(char ***)&mappinglistArgv)==TCL_OK) // make parameters into arguments
+ {
+ for(j=0;j<mappinglistArgc&&!fail;j++)
+ {
diff --git a/editors/e93/pkg-plist b/editors/e93/pkg-plist
index 455200599ff2..c6a656da5626 100644
--- a/editors/e93/pkg-plist
+++ b/editors/e93/pkg-plist
@@ -1,24 +1,44 @@
bin/e93
bin/e93r
+lib/e93lib/e93rc.tcl
+lib/e93lib/examples/README
+lib/e93lib/examples/sethighlightscheme.tcl
lib/e93lib/highlightschemes/schemes.tcl
+lib/e93lib/images/about.ppm
+lib/e93lib/images/e93icon-16.png
+lib/e93lib/images/e93icon-24.png
+lib/e93lib/images/e93icon-48.png
lib/e93lib/modules/c.tcl
-lib/e93lib/syntaxmaps/unknown.tcl
+lib/e93lib/modules/colorme.tcl
+lib/e93lib/newstuff/NEW_WAY
+lib/e93lib/newstuff/README
+lib/e93lib/newstuff/htmlTEST.tcl
+lib/e93lib/newstuff/test.tcl
lib/e93lib/syntaxmaps/asm.tcl
+lib/e93lib/syntaxmaps/c.tcl
+lib/e93lib/syntaxmaps/css.tcl
+lib/e93lib/syntaxmaps/eiffel.tcl
lib/e93lib/syntaxmaps/html.tcl
lib/e93lib/syntaxmaps/java.tcl
+lib/e93lib/syntaxmaps/javaScript.tcl
+lib/e93lib/syntaxmaps/php.tcl
lib/e93lib/syntaxmaps/tcl.tcl
-lib/e93lib/syntaxmaps/vhdl.tcl
lib/e93lib/syntaxmaps/text.tcl
-lib/e93lib/syntaxmaps/c.tcl
-lib/e93lib/images/about.ppm
-lib/e93lib/e93rc.tcl
-share/doc/e93/README.e93
-share/doc/e93/README.regex
-share/doc/e93/README.syntaxmaps
-share/doc/e93/LICENSE.TXT
-@dirrm lib/e93lib/highlightschemes
-@dirrm lib/e93lib/modules
+lib/e93lib/syntaxmaps/unknown.tcl
+lib/e93lib/syntaxmaps/verilog.tcl
+lib/e93lib/syntaxmaps/vhdl.tcl
+lib/e93lib/syntaxmaps/xml.tcl
+lib/e93lib/syntaxmaps/xsl.tcl
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/README.e93
+%%PORTDOCS%%%%DOCSDIR%%/README.rants
+%%PORTDOCS%%%%DOCSDIR%%/README.regex
+%%PORTDOCS%%%%DOCSDIR%%/README.syntaxmaps
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrm lib/e93lib/syntaxmaps
+@dirrm lib/e93lib/newstuff
+@dirrm lib/e93lib/modules
@dirrm lib/e93lib/images
+@dirrm lib/e93lib/highlightschemes
+@dirrm lib/e93lib/examples
@dirrm lib/e93lib
-@dirrm share/doc/e93