aboutsummaryrefslogtreecommitdiff
path: root/editors/emacs20-dl
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>1998-12-13 14:27:06 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>1998-12-13 14:27:06 +0000
commit10a16f13357fa914b377bb2d8a8a14e87b986e19 (patch)
tree2449b61a12bb7270a675e524e16683fbd728925e /editors/emacs20-dl
parent1d6f29e1d576ae80337013866a5199905b0d1889 (diff)
downloadports-10a16f13357fa914b377bb2d8a8a14e87b986e19.tar.gz
ports-10a16f13357fa914b377bb2d8a8a14e87b986e19.zip
Notes
Diffstat (limited to 'editors/emacs20-dl')
-rw-r--r--editors/emacs20-dl/Makefile41
-rw-r--r--editors/emacs20-dl/distinfo2
-rw-r--r--editors/emacs20-dl/files/patch-ca34
-rw-r--r--editors/emacs20-dl/files/patch-cb16
-rw-r--r--editors/emacs20-dl/files/patch-cc12
-rw-r--r--editors/emacs20-dl/files/patch-cd12
-rw-r--r--editors/emacs20-dl/pkg-comment1
-rw-r--r--editors/emacs20-dl/pkg-descr12
-rw-r--r--editors/emacs20-dl/pkg-plist1
-rw-r--r--editors/emacs20-dl/scripts/configure9
10 files changed, 140 insertions, 0 deletions
diff --git a/editors/emacs20-dl/Makefile b/editors/emacs20-dl/Makefile
new file mode 100644
index 000000000000..d3c36df943c0
--- /dev/null
+++ b/editors/emacs20-dl/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: GNU emacs with dl
+# Version required: 20.3
+# Date created: 10 October 1998
+# Whom: shige
+#
+# $Id$
+#
+
+DISTNAME= emacs-20.3
+PKGNAME= emacs-dl-20.3
+CATEGORIES= editors
+MASTER_SITES= ${MASTER_SITE_GNU}
+
+PATCH_SITES= ftp://ftp.jaist.ac.jp/pub/GNU/elisp/emacs-20-dl/
+PATCHFILES= emacs-20.3-dl.diff
+PATCH_DIST_STRIP= -p1
+
+MAINTAINER= shige@kuis.kyoto-u.ac.jp
+
+RUN_DEPENDS= emacs-20.3:${.CURDIR}/../../editors/emacs20
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+CONFIGURE_ARGS= i386--freebsd --with-x-toolkit --with-pop
+MAKE_ENV= INSTALL_SCRIPT="${INSTALL_SCRIPT}"
+EMACS_VER= 20.3
+PLIST_SUB= EMACS_VER=${EMACS_VER}
+
+.if defined(USE_XPGLIB)
+.if (${USE_XPGLIB} == "YES")
+CONFIGURE_ARGS+= --with-xpg4
+.endif
+.endif
+
+pre-build:
+ @${RM} -rf ${WRKSRC}/info/*
+
+do-install:
+ @${INSTALL} -c -s -m 555 -o root -g wheel ${WRKSRC}/src/emacs ${PREFIX}/bin/emacs-dl-${EMACS_VER}
+
+.include <bsd.port.mk>
diff --git a/editors/emacs20-dl/distinfo b/editors/emacs20-dl/distinfo
new file mode 100644
index 000000000000..87ba86165ea8
--- /dev/null
+++ b/editors/emacs20-dl/distinfo
@@ -0,0 +1,2 @@
+MD5 (emacs-20.3.tar.gz) = 5aee43bb7c7267cc24b78011d280ecdc
+MD5 (emacs-20.3-dl.diff) = 45e06de63c8bd8b272a7a3c517ad387f
diff --git a/editors/emacs20-dl/files/patch-ca b/editors/emacs20-dl/files/patch-ca
new file mode 100644
index 000000000000..7b2ecd2e97d3
--- /dev/null
+++ b/editors/emacs20-dl/files/patch-ca
@@ -0,0 +1,34 @@
+--- src/Makefile.in.orig Thu Nov 19 00:28:38 1998
++++ src/Makefile.in Thu Nov 19 00:30:14 1998
+@@ -126,6 +126,10 @@
+ #define LIBS_MACHINE
+ #endif
+
++#ifndef LIBS_XPG
++#define LIBS_XPG
++#endif
++
+ #ifndef LIB_MATH
+ # ifdef LISP_FLOAT_TYPE
+ # define LIB_MATH -lm
+@@ -418,7 +422,11 @@
+ libexecdir=${exec_prefix}/libexec
+ archlibdir=${libexecdir}/emacs/${version}/${configuration}
+ #ifdef __FreeBSD__
++#ifdef __ELF__
++#define LINKER $(CC) -nostdlib -Wl,-export-dynamic -Wl,-R${archlibdir}
++#else /* not __ELF__ */
+ #define LINKER $(CC) -nostdlib -Wl,-R${archlibdir}
++#endif /* __ELF__ */
+ #else
+ #define LINKER $(CC) -nostdlib -rdynamic -Wl,-rpath,${archlibdir}
+ #endif
+@@ -814,7 +822,7 @@
+ duplicated symbols. If the standard libraries were compiled
+ with GCC, we might need gnulib again after them. */
+ LIBES = $(LOADLIBES) $(LDLIBS) $(LIBX) $(LIBDL) LIBS_SYSTEM LIBS_MACHINE LIBS_TERMCAP \
+- LIBS_DEBUG $(GNULIB_VAR) LIB_MATH LIB_STANDARD $(GNULIB_VAR)
++ LIBS_XPG LIBS_DEBUG $(GNULIB_VAR) LIB_MATH LIB_STANDARD $(GNULIB_VAR)
+
+ /* Enable recompilation of certain other files depending on system type. */
+
diff --git a/editors/emacs20-dl/files/patch-cb b/editors/emacs20-dl/files/patch-cb
new file mode 100644
index 000000000000..fe5f9671b66a
--- /dev/null
+++ b/editors/emacs20-dl/files/patch-cb
@@ -0,0 +1,16 @@
+--- src/s/freebsd.h.orig Wed Nov 11 21:22:03 1998
++++ src/s/freebsd.h Wed Nov 11 21:52:19 1998
+@@ -45,6 +45,13 @@
+ #define LIBS_SYSTEM -lutil
+ #define LIBS_TERMCAP -ltermcap
+
++/* Use XPG4 Library for FreeBSD */
++#if __FreeBSD_version >= 220000
++#ifdef USE_XPG
++#define LIBS_XPG -lxpg4
++#endif
++#endif
++
+ #define SYSV_SYSTEM_DIR
+
+ /* freebsd has POSIX-style pgrp behavior. */
diff --git a/editors/emacs20-dl/files/patch-cc b/editors/emacs20-dl/files/patch-cc
new file mode 100644
index 000000000000..ec35177dedca
--- /dev/null
+++ b/editors/emacs20-dl/files/patch-cc
@@ -0,0 +1,12 @@
+--- configure.in.orig Sat Nov 21 08:59:52 1998
++++ configure.in Sat Nov 21 08:58:16 1998
+@@ -57,6 +57,9 @@
+ AC_ARG_WITH(gssapi,
+ [ --with-gssapi support GSSAPI-authenticated POP],
+ [AC_DEFINE(GSSAPI)])
++AC_ARG_WITH(xpg4,
++[ --with-xpg4 support XPG4 library on FreeBSD system],
++[AC_DEFINE(USE_XPG)])
+ dnl This should be the last --with option, because --with-x is
+ dnl added later on when we find the path of X, and it's best to
+ dnl keep them together visually.
diff --git a/editors/emacs20-dl/files/patch-cd b/editors/emacs20-dl/files/patch-cd
new file mode 100644
index 000000000000..9792250f67b9
--- /dev/null
+++ b/editors/emacs20-dl/files/patch-cd
@@ -0,0 +1,12 @@
+--- src/config.in.orig Sat Nov 21 09:00:30 1998
++++ src/config.in Sat Nov 21 09:00:58 1998
+@@ -118,6 +118,9 @@
+ /* Define to support using a Hesiod database to find the POP server. */
+ #undef HESIOD
+
++/* Define to support using a XPG4 library on FreeBSD system. */
++#undef USE_XPG
++
+ /* Some things figured out by the configure script, grouped as they are in
+ configure.in. */
+ #ifndef _ALL_SOURCE /* suppress warning if this is pre-defined */
diff --git a/editors/emacs20-dl/pkg-comment b/editors/emacs20-dl/pkg-comment
new file mode 100644
index 000000000000..a84a4980d746
--- /dev/null
+++ b/editors/emacs20-dl/pkg-comment
@@ -0,0 +1 @@
+GNU editing macros with dynamic loading module function (binary only).
diff --git a/editors/emacs20-dl/pkg-descr b/editors/emacs20-dl/pkg-descr
new file mode 100644
index 000000000000..a3773f46af2c
--- /dev/null
+++ b/editors/emacs20-dl/pkg-descr
@@ -0,0 +1,12 @@
+GNU Emacs is a self-documenting, customizable, extensible real-time
+display editor (emacs binary only).
+
+This package's emacs has a dynamic loading function.
+
+Emacs binary is:
+ ${PREFIX}/bin/emacs-dl-${EMACS_VER}
+
+Dynamic loading patch:
+ ftp://ftp.jaist.ac.jp/pub/GNU/elisp/emacs-20-dl/emacs-${EMACS_VER}-dl.diff
+
+--- Port by shige@kuis.kyoto-u.ac.jp
diff --git a/editors/emacs20-dl/pkg-plist b/editors/emacs20-dl/pkg-plist
new file mode 100644
index 000000000000..7b66f3158b16
--- /dev/null
+++ b/editors/emacs20-dl/pkg-plist
@@ -0,0 +1 @@
+bin/emacs-dl-%%EMACS_VER%%
diff --git a/editors/emacs20-dl/scripts/configure b/editors/emacs20-dl/scripts/configure
new file mode 100644
index 000000000000..545b6cd52a83
--- /dev/null
+++ b/editors/emacs20-dl/scripts/configure
@@ -0,0 +1,9 @@
+#! /bin/sh
+
+cd ${WRKSRC}
+
+if [ -f /usr/lib/aout/crt0.o -a ! -f /usr/lib/crt0.o ]; then
+ sed -e "s|/usr/lib/crt0\.o|/usr/lib/aout/crt0.o|g" \
+ src/s/freebsd.h > src/s/freebsd.h.new || exit
+ mv -f src/s/freebsd.h.new src/s/freebsd.h
+fi