aboutsummaryrefslogtreecommitdiff
path: root/editors/emacs
diff options
context:
space:
mode:
authorAshish SHUKLA <ashish@FreeBSD.org>2015-08-23 21:19:17 +0000
committerAshish SHUKLA <ashish@FreeBSD.org>2015-08-23 21:19:17 +0000
commitb6fdca2c339007f36413d888ff41f54a55b8c5ef (patch)
tree516173cfba54ad83c473cf6d0bbeae6b8800ed95 /editors/emacs
parent4151091105eddd3573c552c489f197ec9bf4818c (diff)
- Add patches to fix misused umask parameter, caught with FORTIFY_SOURCE
PR: 202574 Submitted by: op
Notes
Notes: svn path=/head/; revision=395132
Diffstat (limited to 'editors/emacs')
-rw-r--r--editors/emacs/Makefile1
-rw-r--r--editors/emacs/files/patch-src_unexaix.c11
-rw-r--r--editors/emacs/files/patch-src_unexcoff.c11
-rw-r--r--editors/emacs/files/patch-src_unexelf.c11
4 files changed, 34 insertions, 0 deletions
diff --git a/editors/emacs/Makefile b/editors/emacs/Makefile
index 12484de7495f..d876451e4402 100644
--- a/editors/emacs/Makefile
+++ b/editors/emacs/Makefile
@@ -4,6 +4,7 @@
PORTNAME= emacs
PORTVERSION= ${EMACS_VER}
PORTEPOCH= 3
+PORTREVISION= 1
CATEGORIES= editors ipv6
MASTER_SITES= GNU
PKGNAMESUFFIX?= 24
diff --git a/editors/emacs/files/patch-src_unexaix.c b/editors/emacs/files/patch-src_unexaix.c
new file mode 100644
index 000000000000..4c13317e8e43
--- /dev/null
+++ b/editors/emacs/files/patch-src_unexaix.c
@@ -0,0 +1,11 @@
+--- src/unexaix.c.orig 2015-08-22 16:04:45 UTC
++++ src/unexaix.c
+@@ -478,7 +478,7 @@ mark_x (const char *name)
+ int um;
+ int new = 0; /* for PERROR */
+
+- um = umask (777);
++ um = umask (0777);
+ umask (um);
+ if (stat (name, &sbuf) == -1)
+ {
diff --git a/editors/emacs/files/patch-src_unexcoff.c b/editors/emacs/files/patch-src_unexcoff.c
new file mode 100644
index 000000000000..777f6696e4e3
--- /dev/null
+++ b/editors/emacs/files/patch-src_unexcoff.c
@@ -0,0 +1,11 @@
+--- src/unexcoff.c.orig 2015-08-22 16:05:00 UTC
++++ src/unexcoff.c
+@@ -451,7 +451,7 @@ mark_x (const char *name)
+ int um;
+ int new = 0; /* for PERROR */
+
+- um = umask (777);
++ um = umask (0777);
+ umask (um);
+ if (stat (name, &sbuf) == -1)
+ {
diff --git a/editors/emacs/files/patch-src_unexelf.c b/editors/emacs/files/patch-src_unexelf.c
new file mode 100644
index 000000000000..4aa3869e4e38
--- /dev/null
+++ b/editors/emacs/files/patch-src_unexelf.c
@@ -0,0 +1,11 @@
+--- src/unexelf.c.orig 2015-08-22 16:05:06 UTC
++++ src/unexelf.c
+@@ -1323,7 +1323,7 @@ temacs:
+ if (stat (new_name, &stat_buf) != 0)
+ fatal ("Can't stat (%s): %s", new_name, strerror (errno));
+
+- mask = umask (777);
++ mask = umask (0777);
+ umask (mask);
+ stat_buf.st_mode |= 0111 & ~mask;
+ if (chmod (new_name, stat_buf.st_mode) != 0)