aboutsummaryrefslogtreecommitdiff
path: root/editors/encryptpad
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-02-10 18:58:59 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-02-10 18:58:59 +0000
commit1b0a8493be93b2b07b0736c9a2a81324d91a8b4b (patch)
tree141fd643139ffea6832328131144468f19f600a0 /editors/encryptpad
parent9bc86f155ca23b5ae105fc79c89ed740f2dcffde (diff)
downloadports-1b0a8493be93b2b07b0736c9a2a81324d91a8b4b.tar.gz
ports-1b0a8493be93b2b07b0736c9a2a81324d91a8b4b.zip
Notes
Diffstat (limited to 'editors/encryptpad')
-rw-r--r--editors/encryptpad/Makefile25
-rw-r--r--editors/encryptpad/distinfo8
-rw-r--r--editors/encryptpad/pkg-plist4
3 files changed, 21 insertions, 16 deletions
diff --git a/editors/encryptpad/Makefile b/editors/encryptpad/Makefile
index 3e02fab0d07c..03def2b56beb 100644
--- a/editors/encryptpad/Makefile
+++ b/editors/encryptpad/Makefile
@@ -2,11 +2,13 @@
# $FreeBSD$
PORTNAME= encryptpad
-PORTVERSION= 0.3.2.5
DISTVERSIONPREFIX= v
-PORTREVISION= 1
+DISTVERSION= 0.4.0.2
CATEGORIES= editors security
+PATCH_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/commit/
+PATCHFILES= 55fd37480d.patch:-p1
+
MAINTAINER= dg@syrec.org
COMMENT= Minimalist secure text editor and binary encryptor
@@ -14,23 +16,22 @@ LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/license.txt
BUILD_DEPENDS= bash:shells/bash
-LIB_DEPENDS= libbotan-1.10.so:security/botan110
+LIB_DEPENDS= libbotan-2.so:security/botan2
+USES= desktop-file-utils gmake pkgconfig shared-mime-info
USE_GITHUB= yes
GH_ACCOUNT= evpo
GH_PROJECT= EncryptPad
-
-USES= desktop-file-utils gmake pkgconfig shared-mime-info
-USE_QT5= core gui widgets qmake_build buildtools_build
+USE_QT5= core gui widgets buildtools_build qmake_build
USE_GL= gl
-PORTDOCS= CHANGES.* README.* docs
-
OPTIONS_DEFINE= DOCS
+PORTDOCS= *
+
do-build:
- (cd ${WRKSRC} && ${SETENV} MAKE=${MAKE_CMD} PATH=${QT_BINDIR}:${PATH} \
- ./configure.sh --all --use-system-libs)
+ @cd ${WRKSRC} && ${SETENV} MAKE=${MAKE_CMD} PATH=${QT_BINDIR}:${PATH} \
+ ./configure.sh --all --use-system-libs
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/bin/release/* ${STAGEDIR}${PREFIX}/bin
@@ -40,7 +41,7 @@ do-install:
@${MKDIR} ${STAGEDIR}${PREFIX}/share/mime/packages
${INSTALL_DATA} ${WRKSRC}/encryptpad.xml \
${STAGEDIR}${PREFIX}/share/mime/packages
-.for sz in 16 32 128
+.for sz in 16 32 128 256 512
@${MKDIR} ${STAGEDIR}${PREFIX}/share/icons/hicolor/${sz}x${sz}/apps
${INSTALL_DATA} ${WRKSRC}/images/icns.iconset/icon_${sz}x${sz}.png \
${STAGEDIR}${PREFIX}/share/icons/hicolor/${sz}x${sz}/apps/encryptpad.png
@@ -48,6 +49,6 @@ do-install:
post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
- ${CP} -a ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
+ cd ${WRKSRC}/docs && ${COPYTREE_SHARE} . ${STAGEDIR}/${DOCSDIR}
.include <bsd.port.mk>
diff --git a/editors/encryptpad/distinfo b/editors/encryptpad/distinfo
index d9b798798b46..17eee9c3e0f8 100644
--- a/editors/encryptpad/distinfo
+++ b/editors/encryptpad/distinfo
@@ -1,3 +1,5 @@
-TIMESTAMP = 1484432907
-SHA256 (evpo-EncryptPad-v0.3.2.5_GH0.tar.gz) = f9870c4aad45dd8171f92e97632e748b9504a52a1436c232cb387246672666e5
-SIZE (evpo-EncryptPad-v0.3.2.5_GH0.tar.gz) = 7988782
+TIMESTAMP = 1518271775
+SHA256 (evpo-EncryptPad-v0.4.0.2_GH0.tar.gz) = ac3f2787d9ed0b41fa88c49bc088ab8cef2d85ef86f39204738669911ed41379
+SIZE (evpo-EncryptPad-v0.4.0.2_GH0.tar.gz) = 11579309
+SHA256 (55fd37480d.patch) = 9e06f1e93df35ebf935bfabe1df2275747ab06161acd7165230757290253c43f
+SIZE (55fd37480d.patch) = 1095
diff --git a/editors/encryptpad/pkg-plist b/editors/encryptpad/pkg-plist
index 12f2baf09c68..a34c3d8a3bed 100644
--- a/editors/encryptpad/pkg-plist
+++ b/editors/encryptpad/pkg-plist
@@ -1,7 +1,9 @@
bin/encryptpad
bin/encryptcli
share/applications/encryptpad.desktop
-share/icons/hicolor/128x128/apps/encryptpad.png
share/icons/hicolor/16x16/apps/encryptpad.png
share/icons/hicolor/32x32/apps/encryptpad.png
+share/icons/hicolor/128x128/apps/encryptpad.png
+share/icons/hicolor/256x256/apps/encryptpad.png
+share/icons/hicolor/512x512/apps/encryptpad.png
share/mime/packages/encryptpad.xml