aboutsummaryrefslogtreecommitdiff
path: root/editors/flim-emacs
diff options
context:
space:
mode:
authorShigeyuki Fukushima <shige@FreeBSD.org>2000-01-11 14:42:30 +0000
committerShigeyuki Fukushima <shige@FreeBSD.org>2000-01-11 14:42:30 +0000
commit30ec893159f120b9049178b535cc7a68688d8f10 (patch)
tree28dac85e51c35de2b973b904d69414582459733f /editors/flim-emacs
parent11db3427a12e1fdf5ddff8237954dcaf64b8cc18 (diff)
downloadports-30ec893159f120b9049178b535cc7a68688d8f10.tar.gz
ports-30ec893159f120b9049178b535cc7a68688d8f10.zip
Notes
Diffstat (limited to 'editors/flim-emacs')
-rw-r--r--editors/flim-emacs/Makefile21
-rw-r--r--editors/flim-emacs/files/_pkg.el4
2 files changed, 24 insertions, 1 deletions
diff --git a/editors/flim-emacs/Makefile b/editors/flim-emacs/Makefile
index 6ebf3d98b499..fda4a099c159 100644
--- a/editors/flim-emacs/Makefile
+++ b/editors/flim-emacs/Makefile
@@ -40,7 +40,7 @@ ALL_TARGET?= elc
.if defined(EMACS_PORT)
PKGNAME= flim-${EMACS_PORT}-${FLIM_VER}
-EMACS_CMD= ${PREFIX}/bin/${EMACS_NAME}-${EMACS_VER}
+EMACS_CMD?= ${PREFIX}/bin/${EMACS_NAME}-${EMACS_VER}
BUILD_DEPENDS+= ${EMACS_CMD}:${PORTSDIR}/editors/${EMACS_PORT}
.if defined(HAS_COMMON_PORT) && (${HAS_COMMON_PORT} == "YES")
RUN_DEPENDS+= ${EMACS_CMD}:${PORTSDIR}/editors/${EMACS_PORT}-common
@@ -95,6 +95,10 @@ MAKEINFO= makeinfo --no-split --no-validate
MAKEINFO_EMACS= ${EMACS_CMD} -no-site-file -no-init-file -batch
MAKEINFO_EMACS_FLAGS= -e texinfo-format-buffer -f save-buffer
+pre-build:
+.if defined(EMACS_PACKAGESDIR) && defined(XEMACS_PKGNAME)
+ @${MAKE} pkg-el-copy
+.endif
post-build:
.if defined(BUILD_INFO_BY_EMACS) && (${BUILD_INFO_BY_EMACS} == "YES")
@@ -107,6 +111,9 @@ pre-install:
.if defined(EMACS_PACKAGESDIR) && defined(EMACS_PACKAGES_SUBDIRS)
@${MAKE} mkdir-site-packages
.endif
+.if defined(EMACS_PACKAGESDIR) && defined(XEMACS_PKGNAME)
+ @${MAKE} pkg-el-install
+.endif
post-install:
# install package-cookie
@@ -163,6 +170,18 @@ mkdir-site-packages:
${MKDIR} ${PREFIX}/${EMACS_PACKAGESDIR}/$${i} ; \
done)
+pkg-el-copy:
+ @(if [ -f ${FILESDIR}/_pkg.el ] ; then \
+ ${CP} ${FILESDIR}/_pkg.el ${WRKSRC}/_pkg.el ;\
+ fi)
+
+pkg-el-install:
+ @(if [ -f ${FILESDIR}/_pkg.el ] ; then \
+ ${MKDIR} ${PREFIX}/${EMACS_PACKAGESDIR}/lisp/${XEMACS_PKGNAME} ;\
+ ${INSTALL_DATA} ${FILESDIR}/_pkg.el \
+ ${PREFIX}/${EMACS_PACKAGESDIR}/lisp/${XEMACS_PKGNAME}/_pkg.el ;\
+ fi)
+
doc-install:
@${MKDIR} ${PREFIX}/${FLIMDOCDIR}
@(cd ${WRKSRC} ; \
diff --git a/editors/flim-emacs/files/_pkg.el b/editors/flim-emacs/files/_pkg.el
new file mode 100644
index 000000000000..76e2a44b2bd2
--- /dev/null
+++ b/editors/flim-emacs/files/_pkg.el
@@ -0,0 +1,4 @@
+;;;###autoload
+(package-provide 'flim
+ :version 1.12
+ :type 'regular)