aboutsummaryrefslogtreecommitdiff
path: root/editors/flim-xemacs21-mule/Makefile
diff options
context:
space:
mode:
authorShigeyuki Fukushima <shige@FreeBSD.org>2000-01-11 14:47:47 +0000
committerShigeyuki Fukushima <shige@FreeBSD.org>2000-01-11 14:47:47 +0000
commit9298e091940946b5112925d43b5b9cc39008cd94 (patch)
treea0acc5947c40034d1e6d673dfe139442ca52fee8 /editors/flim-xemacs21-mule/Makefile
parent30ec893159f120b9049178b535cc7a68688d8f10 (diff)
Notes
Diffstat (limited to 'editors/flim-xemacs21-mule/Makefile')
-rw-r--r--editors/flim-xemacs21-mule/Makefile23
1 files changed, 20 insertions, 3 deletions
diff --git a/editors/flim-xemacs21-mule/Makefile b/editors/flim-xemacs21-mule/Makefile
index 7a2a4be8bbfe..4c3b780a5e0a 100644
--- a/editors/flim-xemacs21-mule/Makefile
+++ b/editors/flim-xemacs21-mule/Makefile
@@ -1,4 +1,4 @@
-# New ports collection makefile for: flim for xemacs-mule
+# New ports collection makefile for: flim for xemacs21-mule
# Version required: 1.12.7
# Date created: 25 July 1999
# Whom: Shigeyuki FUKUSHIMA <shige@FreeBSD.org>
@@ -7,7 +7,6 @@
#
MAINTAINER= shige@FreeBSD.org
-BROKEN= editors/xemacs-mule is removed.
# This is a slave port.
PORTCLASS= slave
@@ -16,8 +15,9 @@ MASTERDIR= ${.CURDIR}/../../editors/flim-emacs
# emacs port setup
EMACS_NAME= xemacs
-EMACS_PORT= xemacs-mule
+EMACS_PORT= xemacs21-mule
EMACS_VER= 21.1.8
+EMACS_CMD= ${PREFIX}/bin/${EMACS_PORT}
EMACS_PACKAGESDIR= lib/${EMACS_NAME}/site-packages
# packages-subdirectories which this port requires
EMACS_PACKAGES_SUBDIRS= info lisp man pkginfo
@@ -42,7 +42,24 @@ PKGDIR= ${.CURDIR}/pkg
# package info manifest
MANIFEST= MANIFEST.flim
+
+# xemacs package
+XEMACS_PKGNAME= flim
+XEMACS_PKGVER= 1.12
+#XEMACS_PKGVER!= grep version ${.CURDIR}/../flim-emacs/files/_pkg.el | \
+# sed 's/.*:version \([0-9.]*\).*/\1/'
+XEMACS_PKG_TARBALL= ${XEMACS_PKGNAME}-${XEMACS_PKGVER}-pkg.tar.gz
+XEMACS_PKG_CONTENTS= pkginfo/${MANIFEST} lisp/${XEMACS_PKGNAME} \
+ info/mime-en.info info/mime-ja.info \
+ man/${XEMACS_PKGNAME}
+
# package documents
FLIMDOCDIR= ${EMACS_PACKAGESDIR}/lisp/flim
+xemacs-package: install
+ @${RM} -f ${.CURDIR}/${XEMACS_PKG_TARBALL}
+ @(cd ${PREFIX}/${EMACS_PACKAGESDIR} ;\
+ ${TAR} -zcf ${.CURDIR}/${XEMACS_PKG_TARBALL} ${XEMACS_PKG_CONTENTS} ;\
+ )
+
.include <${MASTERDIR}/Makefile>