aboutsummaryrefslogtreecommitdiff
path: root/editors/flim113-xemacs21-mule/Makefile
diff options
context:
space:
mode:
authorShigeyuki Fukushima <shige@FreeBSD.org>1999-08-06 19:08:53 +0000
committerShigeyuki Fukushima <shige@FreeBSD.org>1999-08-06 19:08:53 +0000
commit4be29ea34b2fc709e0dde74be7029965528ed139 (patch)
tree2d828e6475db7668f0627a48ad68885fc2476750 /editors/flim113-xemacs21-mule/Makefile
parentf3354572f2207b3195aa52021924d4d0add0a55a (diff)
Notes
Diffstat (limited to 'editors/flim113-xemacs21-mule/Makefile')
-rw-r--r--editors/flim113-xemacs21-mule/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/editors/flim113-xemacs21-mule/Makefile b/editors/flim113-xemacs21-mule/Makefile
new file mode 100644
index 000000000000..8fe3eda284da
--- /dev/null
+++ b/editors/flim113-xemacs21-mule/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: flim for xemacs-mule
+# Version required: 1.12.5
+# Date created: 25 July 1999
+# Whom: Shigeyuki FUKUSHIMA <shige@FreeBSD.ORG>
+#
+# $Id$
+#
+
+MAINTAINER= shige@FreeBSD.ORG
+
+# This is a slave port.
+PORTCLASS= slave
+
+MASTERDIR= ${.CURDIR}/../../editors/flim-emacs-current
+
+# emacs port setup
+EMACS_NAME= xemacs
+EMACS_PORT= xemacs-mule
+EMACS_VER= 20.4
+EMACS_LIBDIR= lib/${EMACS_NAME}-${EMACS_VER}
+# xemacs-mule-20.4 has no version specific site-lisp directories.
+EMACS_LIBDIR_WITH_VER= ${EMACS_LIBDIR}
+
+# RUN_DEPENDS port name's suffix is '-common'.
+HAVE_COMMON_PORT= YES
+# emacs requires *-setupel.el
+REQUIRE_SETUPEL= YES
+
+# use pkg/* files in ${.CURDIR}
+PKGDIR= ${.CURDIR}/pkg
+
+.include <${MASTERDIR}/Makefile>