aboutsummaryrefslogtreecommitdiff
path: root/editors/flim
diff options
context:
space:
mode:
authorMANTANI Nobutaka <nobutaka@FreeBSD.org>2009-05-17 16:26:23 +0000
committerMANTANI Nobutaka <nobutaka@FreeBSD.org>2009-05-17 16:26:23 +0000
commite9b7f1c2f346c48efb0ca64cd6a9ec482f546cfa (patch)
tree4cef06c2c1fbfc871314ca655dcadad543653895 /editors/flim
parent328dd42c5ffe1d9237d616c5ce306e0c66fea468 (diff)
downloadports-e9b7f1c2f346c48efb0ca64cd6a9ec482f546cfa.tar.gz
ports-e9b7f1c2f346c48efb0ca64cd6a9ec482f546cfa.zip
Notes
Diffstat (limited to 'editors/flim')
-rw-r--r--editors/flim/Makefile32
1 files changed, 16 insertions, 16 deletions
diff --git a/editors/flim/Makefile b/editors/flim/Makefile
index acaca213e8ad..345b5f4dfc7c 100644
--- a/editors/flim/Makefile
+++ b/editors/flim/Makefile
@@ -79,40 +79,35 @@ MAKEINFO= makeinfo --no-split --no-validate
MAKEINFO_EMACS= ${EMACS_CMD} -no-site-file -no-init-file -batch
MAKEINFO_EMACS_FLAGS= -e texinfo-format-buffer -f save-buffer
-pre-build:
.if defined(EMACS_PACKAGESDIR) && defined(XEMACS_PKGNAME)
- @${MAKE} pkg-el-copy
+pre-build: pkg-el-copy
.endif
-post-build:
.if defined(BUILD_INFO_BY_EMACS) && (${BUILD_INFO_BY_EMACS} == "YES")
- @${MAKE} info-build-by-emacs
+post-build: info-build-by-emacs
.else
- @${MAKE} info-build
+post-build: info-build
.endif
-pre-install:
.if defined(EMACS_PACKAGESDIR) && defined(EMACS_PACKAGES_SUBDIRS)
- @${MAKE} mkdir-site-packages
+pre-install: mkdir-site-packages
.endif
.if defined(EMACS_PACKAGESDIR) && defined(XEMACS_PKGNAME)
- @${MAKE} pkg-el-install
+pre-install: pkg-el-install
.endif
-post-install:
-# install package-cookie
- @${MKDIR} ${LOCALBASE}/share/flim
- @${TOUCH} ${LOCALBASE}/share/flim/${FLIM_COOKIE}
+POST_INSTALL_TARGET= pkgcookie-install
.if defined(EMACS_PACKAGESDIR) && defined(MANIFEST)
- @${MAKE} info-package-install
- @${MAKE} manifest-install
+POST_INSTALL_TARGET+= info-package-install manifest-install
.else
- @${MAKE} info-install
+POST_INSTALL_TARGET+= info-install
.endif
.if !defined(NOPORTDOCS)
- @${MAKE} doc-install
+POST_INSTALL_TARGET+= doc-install
.endif
+post-install: ${POST_INSTALL_TARGET}
+
###############################################################################
#
# miscellaneous local functions
@@ -202,4 +197,9 @@ manifest-install:
@${INSTALL_DATA} ${WRKDIR}/${MANIFEST} \
${LOCALBASE}/${EMACS_PACKAGESDIR}/pkginfo/
+pkgcookie-install:
+# install package-cookie
+ @${MKDIR} ${LOCALBASE}/share/flim
+ @${TOUCH} ${LOCALBASE}/share/flim/${FLIM_COOKIE}
+
.include <bsd.port.post.mk>