aboutsummaryrefslogtreecommitdiff
path: root/editors/focuswriter
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2016-07-14 16:34:41 +0000
committerPawel Pekala <pawel@FreeBSD.org>2016-07-14 16:34:41 +0000
commitb810f948e045df4922e45015a71c6aa42a1ce598 (patch)
tree4c8a9ee885d8db71a7d49ff3ec0d43a65d4badb7 /editors/focuswriter
parenta1a26185a7f10e2fffca56b160756d27b6b4c5e7 (diff)
downloadports-b810f948e045df4922e45015a71c6aa42a1ce598.tar.gz
ports-b810f948e045df4922e45015a71c6aa42a1ce598.zip
Notes
Diffstat (limited to 'editors/focuswriter')
-rw-r--r--editors/focuswriter/Makefile53
-rw-r--r--editors/focuswriter/distinfo3
-rw-r--r--editors/focuswriter/pkg-descr20
-rw-r--r--editors/focuswriter/pkg-plist14
4 files changed, 90 insertions, 0 deletions
diff --git a/editors/focuswriter/Makefile b/editors/focuswriter/Makefile
new file mode 100644
index 000000000000..e7355d017663
--- /dev/null
+++ b/editors/focuswriter/Makefile
@@ -0,0 +1,53 @@
+# Created by: lightside <lightside@gmx.com>
+# $FreeBSD$
+
+PORTNAME= focuswriter
+PORTVERSION= 1.5.6
+DISTVERSIONPREFIX= v
+CATEGORIES= editors
+
+MAINTAINER= lightside@gmx.com
+COMMENT= Simple, distraction-free writing environment
+
+LICENSE= GPLv3 LGPL3
+LICENSE_COMB= multi
+LICENSE_FILE_GPLv3= ${WRKSRC}/COPYING
+LICENSE_FILE_LGPL3= ${WRKSRC}/resources/images/icons/oxygen/COPYING
+
+LIB_DEPENDS= libhunspell-1.3.so:textproc/hunspell
+
+USE_GITHUB= yes
+GH_ACCOUNT= gottcode
+
+USES= desktop-file-utils pkgconfig qmake
+INSTALLS_ICONS= yes
+
+LIBS+= -lz
+
+PORTDATA= *
+PORTDOCS= CREDITS NEWS README
+
+OPTIONS_DEFINE= DOCS
+OPTIONS_DEFAULT= QT5
+OPTIONS_SINGLE= QT
+OPTIONS_SINGLE_QT= QT4 QT5
+QT_DESC= Qt toolkit
+
+QT4_RUN_DEPENDS= ${LOCALBASE}/lib/libSDL2_mixer.so:audio/sdl2_mixer
+QT4_USE= QT4=corelib,gui,network,moc_build,rcc_build
+QT5_USE= QT5=concurrent,core,gui,multimedia,network,printsupport,widgets,buildtools_build
+QT5_USE+= GL=gl
+
+post-patch:
+ @${REINPLACE_CMD} -e '/PKGCONFIG/s/ zlib// ; \
+ /INSTALLS/s/man //' \
+ ${WRKSRC}/focuswriter.pro
+
+do-install-DOCS-on:
+ (cd ${WRKSRC} && ${COPYTREE_SHARE} "${PORTDOCS}" ${STAGEDIR}${DOCSDIR})
+
+post-install:
+ ${INSTALL_MAN} ${WRKSRC}/resources/unix/focuswriter.1 \
+ ${STAGEDIR}${PREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/editors/focuswriter/distinfo b/editors/focuswriter/distinfo
new file mode 100644
index 000000000000..64a1bf7661c0
--- /dev/null
+++ b/editors/focuswriter/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1466634254
+SHA256 (gottcode-focuswriter-v1.5.6_GH0.tar.gz) = a133c70427d7896b724c9fe6859453459e354cacd21f6ca7e332486a231a474f
+SIZE (gottcode-focuswriter-v1.5.6_GH0.tar.gz) = 5621251
diff --git a/editors/focuswriter/pkg-descr b/editors/focuswriter/pkg-descr
new file mode 100644
index 000000000000..93985cb97e02
--- /dev/null
+++ b/editors/focuswriter/pkg-descr
@@ -0,0 +1,20 @@
+FocusWriter is a simple, distraction-free writing environment. It utilizes a
+hide-away interface, that you access by moving your mouse to the edges of the
+screen, allowing the program to have a familiar look and feel to it, while still
+getting out of the way, so that you can immerse yourself in your work.
+
+Features:
+- TXT, basic RTF, and basic ODT file support
+- Timers and alarms
+- Daily goals
+- Fully customizable themes
+- Typewriter sound effects (optional)
+- Auto-save (optional)
+- Live statistics (optional)
+- Spell-checking (optional)
+- Multi-document support
+- Sessions
+- Portable mode (optional)
+- Translated into over 20 languages
+
+WWW: http://gottcode.org/focuswriter/
diff --git a/editors/focuswriter/pkg-plist b/editors/focuswriter/pkg-plist
new file mode 100644
index 000000000000..30d12c176abf
--- /dev/null
+++ b/editors/focuswriter/pkg-plist
@@ -0,0 +1,14 @@
+bin/focuswriter
+man/man1/focuswriter.1.gz
+share/appdata/focuswriter.appdata.xml
+share/applications/focuswriter.desktop
+share/icons/hicolor/128x128/apps/focuswriter.png
+share/icons/hicolor/16x16/apps/focuswriter.png
+share/icons/hicolor/22x22/apps/focuswriter.png
+share/icons/hicolor/24x24/apps/focuswriter.png
+share/icons/hicolor/256x256/apps/focuswriter.png
+share/icons/hicolor/32x32/apps/focuswriter.png
+share/icons/hicolor/48x48/apps/focuswriter.png
+share/icons/hicolor/64x64/apps/focuswriter.png
+share/icons/hicolor/scalable/apps/focuswriter.svg
+share/pixmaps/focuswriter.xpm