aboutsummaryrefslogtreecommitdiff
path: root/editors/fxite
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2010-08-24 07:53:40 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2010-08-24 07:53:40 +0000
commit9568031d2b2ec49cfdf4f86f6df4c42e1eee13bf (patch)
tree327287f2289b8e3ac95d0bb5e256f3608d0b1089 /editors/fxite
parent59b7cdb57f08882a638feb0c789e7d3a8fb608de (diff)
downloadports-9568031d2b2ec49cfdf4f86f6df4c42e1eee13bf.tar.gz
ports-9568031d2b2ec49cfdf4f86f6df4c42e1eee13bf.zip
Notes
Diffstat (limited to 'editors/fxite')
-rw-r--r--editors/fxite/Makefile24
-rw-r--r--editors/fxite/distinfo3
-rw-r--r--editors/fxite/pkg-descr8
3 files changed, 35 insertions, 0 deletions
diff --git a/editors/fxite/Makefile b/editors/fxite/Makefile
new file mode 100644
index 000000000000..eb771bf5a189
--- /dev/null
+++ b/editors/fxite/Makefile
@@ -0,0 +1,24 @@
+# New ports collection Makefile for: fxite
+# Date created: 23 August 2010
+# Whom: gahr
+#
+# $FreeBSD$
+#
+
+PORTNAME= fxite
+PORTVERSION= 0.6
+CATEGORIES= editors
+MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
+
+MAINTAINER= gahr@FreeBSD.org
+COMMENT= An advanced cross-platform text editor
+
+LIB_DEPENDS= fxscintilla.21:${PORTSDIR}/x11-toolkits/fxscintilla
+
+USE_GETTEXT= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib -lintl"
+
+PLIST_FILES= bin/fxite
+
+.include <bsd.port.mk>
diff --git a/editors/fxite/distinfo b/editors/fxite/distinfo
new file mode 100644
index 000000000000..58b138e62ffa
--- /dev/null
+++ b/editors/fxite/distinfo
@@ -0,0 +1,3 @@
+MD5 (fxite-0.6.tar.gz) = a1964a2f3882036598e18f0d7f1e5f38
+SHA256 (fxite-0.6.tar.gz) = 9dfdc8b0ad91f918a3d1520e8bf0b4ca8ead2699f5c22a4d8edcd9832a895051
+SIZE (fxite-0.6.tar.gz) = 1031471
diff --git a/editors/fxite/pkg-descr b/editors/fxite/pkg-descr
new file mode 100644
index 000000000000..ef1b8f0b04bc
--- /dev/null
+++ b/editors/fxite/pkg-descr
@@ -0,0 +1,8 @@
+FXiTe is an advanced cross-platform text editor built with the Fox GUI toolkit
+and the FXScintilla text widget. It features built-in syntax highlighting for
+40+ languages, an embedded Lua scripting engine, macro recording and playback,
+multi-line regular expression search and replace, rudimentary ctags and calltip
+support, a flexible interface to external tools, and a built-in "message window"
+to capture the output of external commands such as compiler error messages, etc.
+
+WWW: http://code.google.com/p/fxite/