aboutsummaryrefslogtreecommitdiff
path: root/editors/gate/Makefile
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2003-08-26 20:26:22 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2003-08-26 20:26:22 +0000
commit9f29eaeb024488cf53a3c27abc6aa8ff501177af (patch)
treecb2aec2e56e4e92bf4db08fddeb92a7d7db29703 /editors/gate/Makefile
parenta3108b1e51e6a746a151a607c5aba8d1f6b35033 (diff)
downloadports-9f29eaeb024488cf53a3c27abc6aa8ff501177af.tar.gz
ports-9f29eaeb024488cf53a3c27abc6aa8ff501177af.zip
Notes
Diffstat (limited to 'editors/gate/Makefile')
-rw-r--r--editors/gate/Makefile25
1 files changed, 16 insertions, 9 deletions
diff --git a/editors/gate/Makefile b/editors/gate/Makefile
index bcd7515334e5..d8fcb384fde1 100644
--- a/editors/gate/Makefile
+++ b/editors/gate/Makefile
@@ -6,26 +6,33 @@
#
PORTNAME= gate
-PORTVERSION= 2.04c
+PORTVERSION= 2.05
CATEGORIES= editors
-MASTER_SITES= http://www.wwnet.net/~janc/software/
-DISTNAME= ${PORTNAME}
+MASTER_SITES= http://www.unixpapa.com/software/
MAINTAINER= ports@FreeBSD.org
COMMENT= A simple and unobtrusive line-oriented text editor
-RUN_DEPENDS= ispell:${PORTSDIR}/textproc/ispell
-
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+BUILD_DEPENDS= aspell:${PORTSDIR}/textproc/aspell
+RUN_DEPENDS= aspell:${PORTSDIR}/textproc/aspell
+USE_REINPLACE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-aspell=${LOCALBASE}/bin/aspell
ALL_TARGET= gate gate.1
MAN1= gate.1
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|$${res_datadir}|${DATADIR}|g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e \
+ 's|^char \*malloc();||g' ${WRKSRC}/term.c
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/gate ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/gate.1 ${PREFIX}/man/man1
- ${MKDIR} ${PREFIX}/share/gate
- ${INSTALL_DATA} ${WRKSRC}/gate.help ${PREFIX}/share/gate
+ ${INSTALL_MAN} ${WRKSRC}/gate.1 ${MANPREFIX}/man/man1
+ @${MKDIR} ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/gate.help ${DATADIR}
.include <bsd.port.mk>