aboutsummaryrefslogtreecommitdiff
path: root/editors/gate
diff options
context:
space:
mode:
authorWilliam Grzybowski <wg@FreeBSD.org>2013-06-13 23:06:34 +0000
committerWilliam Grzybowski <wg@FreeBSD.org>2013-06-13 23:06:34 +0000
commit9bcd36c3f80692164dd68e89f84f806720a3daaf (patch)
tree60f8e283fcb30d757c21be633a1542e904e4a60a /editors/gate
parent5d331978eadfbdc705b2217a98775e13a5111cc3 (diff)
downloadports-9bcd36c3f80692164dd68e89f84f806720a3daaf.tar.gz
ports-9bcd36c3f80692164dd68e89f84f806720a3daaf.zip
Notes
Diffstat (limited to 'editors/gate')
-rw-r--r--editors/gate/Makefile6
-rw-r--r--editors/gate/files/patch-spel.c13
-rw-r--r--editors/gate/files/patch-subs.c13
3 files changed, 27 insertions, 5 deletions
diff --git a/editors/gate/Makefile b/editors/gate/Makefile
index 58fb90eddbf5..5d95ecc62ca7 100644
--- a/editors/gate/Makefile
+++ b/editors/gate/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: gate
-# Date created: 15 June 2000
-# Whom: James Howard
-#
+# Created by: James Howard
# $FreeBSD$
-#
PORTNAME= gate
PORTVERSION= 2.06
diff --git a/editors/gate/files/patch-spel.c b/editors/gate/files/patch-spel.c
new file mode 100644
index 000000000000..dfde6de5f20a
--- /dev/null
+++ b/editors/gate/files/patch-spel.c
@@ -0,0 +1,13 @@
+diff --git spel.c spel.c
+index 5c53256..1e9ad04 100644
+--- spel.c
++++ spel.c
+@@ -151,7 +151,7 @@ empty_repl()
+ /* ADD_REPL - Add the given replacement to the list of replacements.
+ * "replace" may be NULL to indicate that the word is to be ignored.
+ */
+-
++void
+ add_repl(char *word, int word_len, char *replace)
+ {
+ struct repl *r;
diff --git a/editors/gate/files/patch-subs.c b/editors/gate/files/patch-subs.c
new file mode 100644
index 000000000000..b5e61269fa9d
--- /dev/null
+++ b/editors/gate/files/patch-subs.c
@@ -0,0 +1,13 @@
+diff --git subs.c subs.c
+index 287d9d3..a6caea9 100644
+--- subs.c
++++ subs.c
+@@ -429,7 +429,7 @@ int cliplast(char *lastbuf, int bufsize)
+ #endif
+
+ /* Make a copy of the file */
+- if ((cfp= make_copy()) == NULL) return;
++ if ((cfp= make_copy()) == NULL) return 0;
+ fflush(cfp);
+ fseek(cfp,0L,0);
+