aboutsummaryrefslogtreecommitdiff
path: root/editors/gedit-autocomplete-plugin
diff options
context:
space:
mode:
authorJean-Yves Lefort <jylefort@FreeBSD.org>2005-10-17 06:40:55 +0000
committerJean-Yves Lefort <jylefort@FreeBSD.org>2005-10-17 06:40:55 +0000
commita53c34fba952f1a8f452054be8a9d71599f43d33 (patch)
tree6425a5af56861c4175772135819e333fc6a0dcba /editors/gedit-autocomplete-plugin
parent76b761f1820cdb18f09244102d535d2f0344e7f8 (diff)
downloadports-a53c34fba952f1a8f452054be8a9d71599f43d33.tar.gz
ports-a53c34fba952f1a8f452054be8a9d71599f43d33.zip
Notes
Diffstat (limited to 'editors/gedit-autocomplete-plugin')
-rw-r--r--editors/gedit-autocomplete-plugin/Makefile29
-rw-r--r--editors/gedit-autocomplete-plugin/distinfo2
-rw-r--r--editors/gedit-autocomplete-plugin/files/patch-makefile14
-rw-r--r--editors/gedit-autocomplete-plugin/pkg-descr6
4 files changed, 51 insertions, 0 deletions
diff --git a/editors/gedit-autocomplete-plugin/Makefile b/editors/gedit-autocomplete-plugin/Makefile
new file mode 100644
index 000000000000..44b6435c37af
--- /dev/null
+++ b/editors/gedit-autocomplete-plugin/Makefile
@@ -0,0 +1,29 @@
+# Ports collection makefile for: gedit-autocomplete-plugin
+# Date created: 2005-10-10
+# Whom: Andreas Kohn <andreas@syndrom23.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= autocomplete-plugin
+PORTVERSION= 3.0
+CATEGORIES= editors
+MASTER_SITES= http://usuarios.lycos.es/acisif/gedit/autocomplete/
+PKGNAMEPREFIX= gedit-
+
+MAINTAINER= andreas@syndrom23.de
+COMMENT= A simple autocompletion plugin for gedit
+
+BUILD_DEPENDS= gedit:${PORTSDIR}/editors/gedit
+RUN_DEPENDS= gedit:${PORTSDIR}/editors/gedit
+
+GEDIT_VERSION= 2.10
+
+USE_X_PREFIX= yes
+MAKEFILE= makefile
+MAKE_ARGS= GEDIT_VERSION=gedit-${GEDIT_VERSION}
+
+PLIST_FILES= lib/gedit-2/plugins/autocomplete.gedit-plugin \
+ lib/gedit-2/plugins/libautocomplete.so
+
+.include <bsd.port.mk>
diff --git a/editors/gedit-autocomplete-plugin/distinfo b/editors/gedit-autocomplete-plugin/distinfo
new file mode 100644
index 000000000000..1e68b54d7438
--- /dev/null
+++ b/editors/gedit-autocomplete-plugin/distinfo
@@ -0,0 +1,2 @@
+MD5 (autocomplete-plugin-3.0.tar.gz) = 34e71a3caad1fa29fcaa0a4442406c9a
+SIZE (autocomplete-plugin-3.0.tar.gz) = 6187
diff --git a/editors/gedit-autocomplete-plugin/files/patch-makefile b/editors/gedit-autocomplete-plugin/files/patch-makefile
new file mode 100644
index 000000000000..dd8312c404c1
--- /dev/null
+++ b/editors/gedit-autocomplete-plugin/files/patch-makefile
@@ -0,0 +1,14 @@
+--- makefile.orig Sun Sep 12 16:11:44 2004
++++ makefile Mon Oct 17 08:06:34 2005
+@@ -2,8 +2,8 @@
+ GEDIT_VERSION=gedit-2.4
+
+ all:
+- gcc -march=i686 -O3 -s -Wall -fPIC -shared `pkg-config $(GEDIT_VERSION) --libs --cflags` *.c -o libautocomplete.so
++ $(CC) $(CFLAGS) -Wall -fPIC -shared `pkg-config $(GEDIT_VERSION) --libs --cflags` *.c -o libautocomplete.so
+
+ install:
+- cp libautocomplete.so /usr/lib/gedit-2/plugins/
+- cp autocomplete.gedit-plugin /usr/lib/gedit-2/plugins/
++ $(BSD_INSTALL_PROGRAM) libautocomplete.so $(PREFIX)/lib/gedit-2/plugins/
++ $(BSD_INSTALL_DATA) autocomplete.gedit-plugin $(PREFIX)/lib/gedit-2/plugins/
diff --git a/editors/gedit-autocomplete-plugin/pkg-descr b/editors/gedit-autocomplete-plugin/pkg-descr
new file mode 100644
index 000000000000..9658c2c0a0d7
--- /dev/null
+++ b/editors/gedit-autocomplete-plugin/pkg-descr
@@ -0,0 +1,6 @@
+A simple autocomplete plugin for gedit.
+
+This plugin autocompletes words when you write words twice or more times
+in a document.
+
+WWW: http://usuarios.lycos.es/acisif/gedit/autocomplete/autocomplete.html