aboutsummaryrefslogtreecommitdiff
path: root/editors/gedit-plugins/Makefile
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2010-05-10 21:19:08 +0000
committerKoop Mast <kwm@FreeBSD.org>2010-05-10 21:19:08 +0000
commit48e62d9a379cd45a15f6ae89d564f81b3c13d16e (patch)
treeb627baa77f19bb1eab2fa4dee08aab1908131cd0 /editors/gedit-plugins/Makefile
parentfbdf96410f8e803568c33397323dd9d8d3af995f (diff)
downloadports-48e62d9a379cd45a15f6ae89d564f81b3c13d16e.tar.gz
ports-48e62d9a379cd45a15f6ae89d564f81b3c13d16e.zip
Notes
Diffstat (limited to 'editors/gedit-plugins/Makefile')
-rw-r--r--editors/gedit-plugins/Makefile14
1 files changed, 8 insertions, 6 deletions
diff --git a/editors/gedit-plugins/Makefile b/editors/gedit-plugins/Makefile
index 9325ca543256..79c8bacc0b34 100644
--- a/editors/gedit-plugins/Makefile
+++ b/editors/gedit-plugins/Makefile
@@ -3,12 +3,11 @@
# Whom: Adam Weinberger <adamw@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/editors/gedit-plugins/Makefile,v 1.39 2009/09/26 08:15:15 avl Exp $
+# $MCom: ports/editors/gedit-plugins/Makefile,v 1.43 2010/04/03 09:38:28 kwm Exp $
#
PORTNAME= gedit-plugins
-PORTVERSION= 2.28.0
-PORTREVISION= 2
+PORTVERSION= 2.30.0
CATEGORIES= editors gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
@@ -31,7 +30,8 @@ WANT_GNOME= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
-GCONF_SCHEMAS= gedit-show-tabbar-plugin.schemas
+GCONF_SCHEMAS= gedit-show-tabbar-plugin.schemas \
+ gedit-drawspaces.schemas
OPTIONS= PYTHON "Build plugins that depend on python" off
@@ -46,8 +46,10 @@ WITH_GNOME= yes
USE_PYTHON= yes
.include "${PORTSDIR}/Mk/bsd.python.mk"
USE_GNOME+= pygtksourceview
-BUILD_DEPENDS+= ${PYTHON_SITELIBDIR}/gtk-2.0/vtemodule.so:${PORTSDIR}/x11-toolkits/py-vte
-RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/gtk-2.0/vtemodule.so:${PORTSDIR}/x11-toolkits/py-vte
+BUILD_DEPENDS+= ${PYTHON_SITELIBDIR}/gtk-2.0/vtemodule.so:${PORTSDIR}/x11-toolkits/py-vte \
+ ${PYTHON_SITELIBDIR}/gtksourceview2.so:${PORTSDIR}/x11-toolkits/py-gtksourceview
+RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/gtk-2.0/vtemodule.so:${PORTSDIR}/x11-toolkits/py-vte \
+ ${PYTHON_SITELIBDIR}/gtksourceview2.so:${PORTSDIR}/x11-toolkits/py-gtksourceview
CONFIGURE_ARGS+=--enable-python
PLIST_SUB+= PYTHON=""
.else