aboutsummaryrefslogtreecommitdiff
path: root/editors/gedit-plugins
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2005-11-05 05:06:30 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2005-11-05 05:06:30 +0000
commitdc707de1229d76a2c554366ec680992ebaa07b05 (patch)
treeab4d4e3a9a509bbf7069168075dd51408576213e /editors/gedit-plugins
parent4157b014c8d164dcfa69379a70be1f0e169cb359 (diff)
downloadports-dc707de1229d76a2c554366ec680992ebaa07b05.tar.gz
ports-dc707de1229d76a2c554366ec680992ebaa07b05.zip
Notes
Diffstat (limited to 'editors/gedit-plugins')
-rw-r--r--editors/gedit-plugins/Makefile37
-rw-r--r--editors/gedit-plugins/distinfo2
-rw-r--r--editors/gedit-plugins/files/patch-plugins::diff::diff.c30
-rw-r--r--editors/gedit-plugins/files/patch-plugins_cvschangelog_cvschangelog.c37
-rw-r--r--editors/gedit-plugins/pkg-descr3
-rw-r--r--editors/gedit-plugins/pkg-plist59
6 files changed, 0 insertions, 168 deletions
diff --git a/editors/gedit-plugins/Makefile b/editors/gedit-plugins/Makefile
deleted file mode 100644
index 4149aa115f29..000000000000
--- a/editors/gedit-plugins/Makefile
+++ /dev/null
@@ -1,37 +0,0 @@
-# New ports collection makefile for: gedit-plugins
-# Date created: 19 September 2003
-# Whom: Adam Weinberger <adamw@FreeBSD.org>
-#
-# $FreeBSD$
-#
-
-PORTNAME= gedit-plugins
-PORTVERSION= 2.3.5
-PORTREVISION= 7
-CATEGORIES= editors gnome
-MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/${PORTNAME}/2.3
-
-MAINTAINER= gnome@FreeBSD.org
-COMMENT= Plugins for gedit
-
-BUILD_DEPENDS= gedit:${PORTSDIR}/editors/gedit
-RUN_DEPENDS= ${BUILD_DEPENDS}
-
-USE_BZIP2= yes
-USE_PERL5= yes
-USE_X_PREFIX= yes
-USE_LIBTOOL_VER=15
-INSTALLS_SHLIB= yes
-USE_REINPLACE= yes
-USE_GNOME= gnomehack gnomeprefix gnometarget
-CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
-
-post-patch:
- @${REINPLACE_CMD} -e "s|gedit-2.4|gedit-2.10|g" \
- ${WRKSRC}/configure
- @${FIND} ${WRKSRC} -name Makefile.in -exec \
- ${REINPLACE_CMD} -e 's|-D.*_DISABLE_DEPRECATED||' '{}' \;
-
-.include <bsd.port.mk>
diff --git a/editors/gedit-plugins/distinfo b/editors/gedit-plugins/distinfo
deleted file mode 100644
index 9e99e3e7839b..000000000000
--- a/editors/gedit-plugins/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 (gedit-plugins-2.3.5.tar.bz2) = 6925b3f5150a0e265abeb6d4657728d1
-SIZE (gedit-plugins-2.3.5.tar.bz2) = 707746
diff --git a/editors/gedit-plugins/files/patch-plugins::diff::diff.c b/editors/gedit-plugins/files/patch-plugins::diff::diff.c
deleted file mode 100644
index 6a2c8f1146c6..000000000000
--- a/editors/gedit-plugins/files/patch-plugins::diff::diff.c
+++ /dev/null
@@ -1,30 +0,0 @@
---- plugins/diff/diff.c.orig Sat Oct 18 16:02:21 2003
-+++ plugins/diff/diff.c Sat Oct 18 16:05:51 2003
-@@ -56,7 +56,6 @@
- #include <gedit/gedit-mdi.h>
- #include <gedit/gedit-output-window.h>
-
--
- #define DIFF_BASE_KEY "/apps/gedit-2/plugins/diff"
- #define DIFF_LOCATION_KEY "/diff-program-location"
- #define UNIFIED_FORMAT_KEY "/use-unified-format"
-@@ -438,7 +437,7 @@
-
- case GTK_RESPONSE_HELP:
- /* FIXME: choose a better link id */
-- gnome_help_display ("gedit.xml", "gedit-use-plugins", &error);
-+ gnome_help_display ("gedit.xml", "gedit-compare-files-plugin", &error);
-
- if (error != NULL)
- {
-@@ -959,7 +958,9 @@
-
- temp = gedit_plugin_locate_program (DIFF_PROGRAM_NAME,
- plugin_name,
-- parent);
-+ parent,
-+ DIFF_BASE_KEY DIFF_LOCATION_KEY,
-+ "gedit-compare-files-configure");
-
- if (temp != NULL)
- {
diff --git a/editors/gedit-plugins/files/patch-plugins_cvschangelog_cvschangelog.c b/editors/gedit-plugins/files/patch-plugins_cvschangelog_cvschangelog.c
deleted file mode 100644
index 028139561504..000000000000
--- a/editors/gedit-plugins/files/patch-plugins_cvschangelog_cvschangelog.c
+++ /dev/null
@@ -1,37 +0,0 @@
---- plugins/cvschangelog/cvschangelog.c.orig Sat Aug 23 19:31:01 2003
-+++ plugins/cvschangelog/cvschangelog.c Fri Oct 21 14:20:50 2005
-@@ -163,6 +163,16 @@
- return FALSE;
- }
-
-+static char *
-+document_get_chars (GeditDocument *doc)
-+{
-+ GtkTextIter start_iter;
-+ GtkTextIter end_iter;
-+
-+ gtk_text_buffer_get_bounds (GTK_TEXT_BUFFER (doc), &start_iter, &end_iter);
-+ return gtk_text_buffer_get_text (GTK_TEXT_BUFFER (doc), &start_iter, &end_iter, TRUE);
-+}
-+
- static void
- cvs_changelogs_cb (BonoboUIComponent *uic, gpointer user_data, const gchar *verbname)
- {
-@@ -178,7 +188,7 @@
-
- doc = gedit_view_get_document (view);
-
-- buf = gedit_document_get_chars (doc, 0, -1);
-+ buf = document_get_chars (doc);
-
- list = get_changelogs (buf);
-
-@@ -209,7 +219,7 @@
- doc = gedit_get_active_document ();
-
- if (doc != NULL) {
-- buf = gedit_document_get_chars (doc, 0, -1);
-+ buf = document_get_chars (doc);
-
- if (is_commit_message (buf))
- gedit_menus_set_verb_sensitive (uic,
diff --git a/editors/gedit-plugins/pkg-descr b/editors/gedit-plugins/pkg-descr
deleted file mode 100644
index 114e40da4044..000000000000
--- a/editors/gedit-plugins/pkg-descr
+++ /dev/null
@@ -1,3 +0,0 @@
-Various plugins for gedit.
-
-WWW: http://www.gnome.org/projects/gedit/plugins.html
diff --git a/editors/gedit-plugins/pkg-plist b/editors/gedit-plugins/pkg-plist
deleted file mode 100644
index 071ea2043501..000000000000
--- a/editors/gedit-plugins/pkg-plist
+++ /dev/null
@@ -1,59 +0,0 @@
-lib/gedit-2/plugins/ascii.gedit-plugin
-lib/gedit-2/plugins/cvschangelog.gedit-plugin
-lib/gedit-2/plugins/diff.gedit-plugin
-lib/gedit-2/plugins/libasciitable.so
-lib/gedit-2/plugins/libcvschangelog.so
-lib/gedit-2/plugins/libdiff.so
-share/gnome/gedit-2/glade/asciitable.glade2
-share/gnome/gedit-2/glade/diff.glade2
-share/locale/am/LC_MESSAGES/gedit-plugins-2.4.mo
-share/locale/ar/LC_MESSAGES/gedit-plugins-2.4.mo
-share/locale/az/LC_MESSAGES/gedit-plugins-2.4.mo
-share/locale/be/LC_MESSAGES/gedit-plugins-2.4.mo
-share/locale/bg/LC_MESSAGES/gedit-plugins-2.4.mo
-share/locale/ca/LC_MESSAGES/gedit-plugins-2.4.mo
-share/locale/cs/LC_MESSAGES/gedit-plugins-2.4.mo
-share/locale/da/LC_MESSAGES/gedit-plugins-2.4.mo
-share/locale/de/LC_MESSAGES/gedit-plugins-2.4.mo
-share/locale/el/LC_MESSAGES/gedit-plugins-2.4.mo
-share/locale/es/LC_MESSAGES/gedit-plugins-2.4.mo
-share/locale/et/LC_MESSAGES/gedit-plugins-2.4.mo
-share/locale/eu/LC_MESSAGES/gedit-plugins-2.4.mo
-share/locale/fi/LC_MESSAGES/gedit-plugins-2.4.mo
-share/locale/fr/LC_MESSAGES/gedit-plugins-2.4.mo
-share/locale/ga/LC_MESSAGES/gedit-plugins-2.4.mo
-share/locale/gl/LC_MESSAGES/gedit-plugins-2.4.mo
-share/locale/he/LC_MESSAGES/gedit-plugins-2.4.mo
-share/locale/hi/LC_MESSAGES/gedit-plugins-2.4.mo
-share/locale/hu/LC_MESSAGES/gedit-plugins-2.4.mo
-share/locale/it/LC_MESSAGES/gedit-plugins-2.4.mo
-share/locale/ja/LC_MESSAGES/gedit-plugins-2.4.mo
-share/locale/kn/LC_MESSAGES/gedit-plugins-2.4.mo
-share/locale/ko/LC_MESSAGES/gedit-plugins-2.4.mo
-share/locale/lt/LC_MESSAGES/gedit-plugins-2.4.mo
-share/locale/lv/LC_MESSAGES/gedit-plugins-2.4.mo
-share/locale/mk/LC_MESSAGES/gedit-plugins-2.4.mo
-share/locale/ml/LC_MESSAGES/gedit-plugins-2.4.mo
-share/locale/mn/LC_MESSAGES/gedit-plugins-2.4.mo
-share/locale/ms/LC_MESSAGES/gedit-plugins-2.4.mo
-share/locale/nl/LC_MESSAGES/gedit-plugins-2.4.mo
-share/locale/nn/LC_MESSAGES/gedit-plugins-2.4.mo
-share/locale/no/LC_MESSAGES/gedit-plugins-2.4.mo
-share/locale/pl/LC_MESSAGES/gedit-plugins-2.4.mo
-share/locale/pt/LC_MESSAGES/gedit-plugins-2.4.mo
-share/locale/pt_BR/LC_MESSAGES/gedit-plugins-2.4.mo
-share/locale/ro/LC_MESSAGES/gedit-plugins-2.4.mo
-share/locale/ru/LC_MESSAGES/gedit-plugins-2.4.mo
-share/locale/sk/LC_MESSAGES/gedit-plugins-2.4.mo
-share/locale/sl/LC_MESSAGES/gedit-plugins-2.4.mo
-share/locale/sr/LC_MESSAGES/gedit-plugins-2.4.mo
-share/locale/sr@Latn/LC_MESSAGES/gedit-plugins-2.4.mo
-share/locale/sv/LC_MESSAGES/gedit-plugins-2.4.mo
-share/locale/ta/LC_MESSAGES/gedit-plugins-2.4.mo
-share/locale/th/LC_MESSAGES/gedit-plugins-2.4.mo
-share/locale/tr/LC_MESSAGES/gedit-plugins-2.4.mo
-share/locale/uk/LC_MESSAGES/gedit-plugins-2.4.mo
-share/locale/vi/LC_MESSAGES/gedit-plugins-2.4.mo
-share/locale/wa/LC_MESSAGES/gedit-plugins-2.4.mo
-share/locale/zh_CN/LC_MESSAGES/gedit-plugins-2.4.mo
-share/locale/zh_TW/LC_MESSAGES/gedit-plugins-2.4.mo