aboutsummaryrefslogtreecommitdiff
path: root/editors/gedit/Makefile
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2006-04-30 00:47:21 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2006-04-30 00:47:21 +0000
commit798e9bed2a389dce8a970e15b68176fd49f442db (patch)
tree9dc5597aab073298ec381964f72cd853b3dd366c /editors/gedit/Makefile
parent48b92584b0722f7f6ca412e6cfe16f1381e043cc (diff)
Notes
Diffstat (limited to 'editors/gedit/Makefile')
-rw-r--r--editors/gedit/Makefile31
1 files changed, 25 insertions, 6 deletions
diff --git a/editors/gedit/Makefile b/editors/gedit/Makefile
index 0de92d763045..a63d9b369929 100644
--- a/editors/gedit/Makefile
+++ b/editors/gedit/Makefile
@@ -3,15 +3,14 @@
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/editors/gedit/Makefile,v 1.12 2005/10/03 15:49:09 ahze Exp $
+# $MCom: ports/editors/gedit/Makefile,v 1.33 2006/04/13 07:52:34 bland Exp $
#
PORTNAME= gedit
-PORTVERSION= 2.12.1
-PORTREVISION= 1
+PORTVERSION= 2.14.2
CATEGORIES= editors gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/${PORTNAME}/2.12
+MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
@@ -20,6 +19,7 @@ COMMENT= A small but powerful text editor for Gnome 2 Desktop Environment
LIB_DEPENDS= pspell.16:${PORTSDIR}/textproc/aspell
USE_BZIP2= yes
+USE_GETTEXT= yes
USE_X_PREFIX= yes
INSTALLS_OMF= yes
INSTALLS_SHLIB= yes
@@ -27,14 +27,33 @@ USE_GMAKE= yes
GNU_CONFIGURE= yes
USE_GNOME= gnomeprefix gnomehack intlhack \
libgnomeprintui libgnomeui eel2 gtksourceview desktopfileutils
+WANT_GNOME= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
-PLIST_SUB= VERSION="2.12"
+PLIST_SUB= VERSION="2.14"
MAN1= gedit.1
GCONF_SCHEMAS= gedit.schemas
+.if defined(PACKAGE_BUILDING)
+.undef WITHOUT_GNOME
+WITH_GNOME= yes
+.endif
+
+.include <bsd.port.pre.mk>
+
+.if ${HAVE_GNOME:Mpygnomedesktop}!=""
+USE_PYTHON= yes
+.include "${PORTSDIR}/Mk/bsd.python.mk"
+USE_GNOME+= pygnomedesktop
+CONFIGURE_ARGS+=--enable-python
+PLIST_SUB+= PYTHON=""
+.else
+CONFIGURE_ARGS+=--disable-python
+PLIST_SUB+= PYTHON="@comment "
+.endif
+
post-install:
@-update-desktop-database
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>