aboutsummaryrefslogtreecommitdiff
path: root/editors/gedit
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2006-10-14 08:35:50 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2006-10-14 08:35:50 +0000
commitf1bb12de8e50bf76ae21f37debda60994ec7fd99 (patch)
tree1671d4beef381f12d939e34b344eb385a3af4f19 /editors/gedit
parent29adee7bb42244f34736c5c24ed18a9b269d0925 (diff)
downloadports-f1bb12de8e50bf76ae21f37debda60994ec7fd99.tar.gz
ports-f1bb12de8e50bf76ae21f37debda60994ec7fd99.zip
Notes
Diffstat (limited to 'editors/gedit')
-rw-r--r--editors/gedit/Makefile25
-rw-r--r--editors/gedit/distinfo6
-rw-r--r--editors/gedit/pkg-plist144
3 files changed, 143 insertions, 32 deletions
diff --git a/editors/gedit/Makefile b/editors/gedit/Makefile
index d64bc8a82269..5686a4f9b6bb 100644
--- a/editors/gedit/Makefile
+++ b/editors/gedit/Makefile
@@ -3,37 +3,38 @@
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/editors/gedit/Makefile,v 1.33 2006/04/13 07:52:34 bland Exp $
+# $MCom: ports/editors/gedit/Makefile,v 1.48 2006/10/01 16:28:46 ahze Exp $
#
PORTNAME= gedit
-PORTVERSION= 2.14.4
+PORTVERSION= 2.16.1
CATEGORIES= editors gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
-COMMENT= A small but powerful text editor for Gnome 2 Desktop Environment
+COMMENT= A small but powerful text editor for GNOME 2 Desktop Environment
LIB_DEPENDS= pspell.16:${PORTSDIR}/textproc/aspell
USE_BZIP2= yes
USE_GETTEXT= yes
-USE_X_PREFIX= yes
+USE_XLIB= yes
INSTALLS_OMF= yes
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
USE_GNOME= gnomeprefix gnomehack intlhack \
libgnomeprintui libgnomeui eel2 gtksourceview desktopfileutils
WANT_GNOME= yes
+CONFIGURE_ARGS= --mandir=${PREFIX}/man
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
-PLIST_SUB= VERSION="2.14"
+PLIST_SUB= VERSION="2.16"
MAN1= gedit.1
-GCONF_SCHEMAS= gedit.schemas
+GCONF_SCHEMAS= gedit.schemas gedit-file-browser.schemas
.if defined(PACKAGE_BUILDING)
.undef WITHOUT_GNOME
@@ -53,6 +54,16 @@ CONFIGURE_ARGS+=--disable-python
PLIST_SUB+= PYTHON="@comment "
.endif
+post-patch:
+ @${REINPLACE_CMD} -e 's|make|${GMAKE}|g' \
+ ${WRKSRC}/bindings/python/Makefile.in
+
+pre-build:
+ ${MKDIR} ${WRKSRC}/bindings/python/.deps
+.for ff in gedit_la-gedit.Plo gedit_la-geditcommands.Plo gedit_la-geditutils.Plo
+ ${TOUCH} ${WRKSRC}/bindings/python/.deps/${ff}
+.endfor
+
post-install:
@-update-desktop-database
diff --git a/editors/gedit/distinfo b/editors/gedit/distinfo
index 5af58e7094a2..4f934666c1f0 100644
--- a/editors/gedit/distinfo
+++ b/editors/gedit/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnome2/gedit-2.14.4.tar.bz2) = 189d4d9128eca1162a782744cb324aea
-SHA256 (gnome2/gedit-2.14.4.tar.bz2) = 93b2e6002e12dbf039c438a4c4bc9dcc990cb013391febe928439c3e805f4a04
-SIZE (gnome2/gedit-2.14.4.tar.bz2) = 2364187
+MD5 (gnome2/gedit-2.16.1.tar.bz2) = 989bf8c2726d12fb825014f3b2d7e587
+SHA256 (gnome2/gedit-2.16.1.tar.bz2) = 9250b65d3eac1ac27c27fcb0c2007ec9ee4907549720a8f771930b845899c503
+SIZE (gnome2/gedit-2.16.1.tar.bz2) = 2819511
diff --git a/editors/gedit/pkg-plist b/editors/gedit/pkg-plist
index 51e9253c68e4..d061efe858b6 100644
--- a/editors/gedit/pkg-plist
+++ b/editors/gedit/pkg-plist
@@ -18,18 +18,11 @@ include/gedit-%%VERSION%%/gedit/gedit-prefs-manager.h
include/gedit-%%VERSION%%/gedit/gedit-print-job-preview.h
include/gedit-%%VERSION%%/gedit/gedit-print.h
include/gedit-%%VERSION%%/gedit/gedit-progress-message-area.h
-include/gedit-%%VERSION%%/gedit/gedit-recent.h
include/gedit-%%VERSION%%/gedit/gedit-statusbar.h
include/gedit-%%VERSION%%/gedit/gedit-tab.h
include/gedit-%%VERSION%%/gedit/gedit-utils.h
include/gedit-%%VERSION%%/gedit/gedit-view.h
include/gedit-%%VERSION%%/gedit/gedit-window.h
-include/gedit-%%VERSION%%/gedit/recent-files/egg-recent-item.h
-include/gedit-%%VERSION%%/gedit/recent-files/egg-recent-model.h
-include/gedit-%%VERSION%%/gedit/recent-files/egg-recent-util.h
-include/gedit-%%VERSION%%/gedit/recent-files/egg-recent-view-gtk.h
-include/gedit-%%VERSION%%/gedit/recent-files/egg-recent-view-uimanager.h
-include/gedit-%%VERSION%%/gedit/recent-files/egg-recent-view.h
lib/gedit-2/plugins/changecase.gedit-plugin
lib/gedit-2/plugins/docinfo.gedit-plugin
%%PYTHON%%lib/gedit-2/plugins/externaltools.gedit-plugin
@@ -52,11 +45,14 @@ lib/gedit-2/plugins/docinfo.gedit-plugin
%%PYTHON%%lib/gedit-2/plugins/externaltools/outputpanel.pyc
%%PYTHON%%lib/gedit-2/plugins/externaltools/outputpanel.pyo
%%PYTHON%%lib/gedit-2/plugins/externaltools/tools.glade
+lib/gedit-2/plugins/filebrowser.gedit-plugin
lib/gedit-2/plugins/indent.gedit-plugin
lib/gedit-2/plugins/libchangecase.la
lib/gedit-2/plugins/libchangecase.so
lib/gedit-2/plugins/libdocinfo.la
lib/gedit-2/plugins/libdocinfo.so
+lib/gedit-2/plugins/libfilebrowser.la
+lib/gedit-2/plugins/libfilebrowser.so
lib/gedit-2/plugins/libindent.la
lib/gedit-2/plugins/libindent.so
lib/gedit-2/plugins/libsample.la
@@ -74,9 +70,6 @@ lib/gedit-2/plugins/libtime.so
%%PYTHON%%lib/gedit-2/plugins/modelines.pyc
%%PYTHON%%lib/gedit-2/plugins/modelines.pyo
%%PYTHON%%lib/gedit-2/plugins/pythonconsole.gedit-plugin
-%%PYTHON%%lib/gedit-2/plugins/pythonconsole.py
-%%PYTHON%%lib/gedit-2/plugins/pythonconsole.pyc
-%%PYTHON%%lib/gedit-2/plugins/pythonconsole.pyo
lib/gedit-2/plugins/sample.gedit-plugin
%%PYTHON%%lib/gedit-2/plugins/snippets.gedit-plugin
%%PYTHON%%lib/gedit-2/plugins/snippets/ElementTree.py
@@ -112,9 +105,48 @@ lib/gedit-2/plugins/sample.gedit-plugin
%%PYTHON%%lib/gedit-2/plugins/snippets/snippets.glade
lib/gedit-2/plugins/sort.gedit-plugin
lib/gedit-2/plugins/spell.gedit-plugin
+%%PYTHON%%lib/gedit-2/plugins/pythonconsole/__init__.py
+%%PYTHON%%lib/gedit-2/plugins/pythonconsole/__init__.pyc
+%%PYTHON%%lib/gedit-2/plugins/pythonconsole/__init__.pyo
+%%PYTHON%%lib/gedit-2/plugins/pythonconsole/console.py
+%%PYTHON%%lib/gedit-2/plugins/pythonconsole/console.pyc
+%%PYTHON%%lib/gedit-2/plugins/pythonconsole/console.pyo
lib/gedit-2/plugins/taglist.gedit-plugin
lib/gedit-2/plugins/time.gedit-plugin
libdata/pkgconfig/gedit-%%VERSION%%.pc
+%%DOCSDIR%%/GeditApp.html
+%%DOCSDIR%%/GeditDocument.html
+%%DOCSDIR%%/GeditEncodingsOptionMenu.html
+%%DOCSDIR%%/GeditFileChooserDialog.html
+%%DOCSDIR%%/GeditMessageArea.html
+%%DOCSDIR%%/GeditNotebook.html
+%%DOCSDIR%%/GeditPanel.html
+%%DOCSDIR%%/GeditPlugin.html
+%%DOCSDIR%%/GeditPrintJob.html
+%%DOCSDIR%%/GeditPrintJobPreview.html
+%%DOCSDIR%%/GeditProgressMessageArea.html
+%%DOCSDIR%%/GeditStatusbar.html
+%%DOCSDIR%%/GeditTab.html
+%%DOCSDIR%%/GeditView.html
+%%DOCSDIR%%/GeditWindow.html
+%%DOCSDIR%%/ch01.html
+%%DOCSDIR%%/gedit-gedit-convert.html
+%%DOCSDIR%%/gedit-gedit-debug.html
+%%DOCSDIR%%/gedit-gedit-encodings.html
+%%DOCSDIR%%/gedit-gedit-help.html
+%%DOCSDIR%%/gedit-gedit-metadata-manager.html
+%%DOCSDIR%%/gedit-gedit-prefs-manager-app.html
+%%DOCSDIR%%/gedit-gedit-prefs-manager.html
+%%DOCSDIR%%/gedit-gedit-utils.html
+%%DOCSDIR%%/gedit.devhelp
+%%DOCSDIR%%/gedit.devhelp2
+%%DOCSDIR%%/home.png
+%%DOCSDIR%%/index.html
+%%DOCSDIR%%/index.sgml
+%%DOCSDIR%%/left.png
+%%DOCSDIR%%/right.png
+%%DOCSDIR%%/style.css
+%%DOCSDIR%%/up.png
share/gnome/applications/gedit.desktop
share/gnome/gedit-2/glade/docinfo.glade2
share/gnome/gedit-2/glade/gedit-encodings-dialog.glade
@@ -126,7 +158,10 @@ share/gnome/gedit-2/glade/languages-dialog.glade2
share/gnome/gedit-2/glade/sort.glade2
share/gnome/gedit-2/glade/spell-checker.glade2
share/gnome/gedit-2/glade/time.glade2
+share/gnome/gedit-2/icons/gedit-plugin.png
+share/gnome/gedit-2/logo/gedit-logo.png
%%PYTHON%%share/gnome/gedit-2/plugins/externaltools/stock-tools.xml
+share/gnome/gedit-2/plugins/filebrowser/gedit-file-browser-widget-ui.xml
%%PYTHON%%share/gnome/gedit-2/plugins/snippets/c++.xml
%%PYTHON%%share/gnome/gedit-2/plugins/snippets/c.xml
%%PYTHON%%share/gnome/gedit-2/plugins/snippets/css.xml
@@ -215,6 +250,10 @@ share/gnome/help/gedit/ko/legal.xml
share/gnome/help/gedit/ro/figures/gedit_window.png
share/gnome/help/gedit/ro/gedit.xml
share/gnome/help/gedit/ro/legal.xml
+share/gnome/help/gedit/sv/figures/gedit_format_bold.png
+share/gnome/help/gedit/sv/figures/gedit_format_italic.png
+share/gnome/help/gedit/sv/figures/gedit_format_strikethrough.png
+share/gnome/help/gedit/sv/figures/gedit_format_underline.png
share/gnome/help/gedit/sv/figures/gedit_recent_files_menu_icon.png
share/gnome/help/gedit/sv/figures/gedit_window.png
share/gnome/help/gedit/sv/gedit.xml
@@ -257,9 +296,6 @@ share/gnome/omf/gedit/gedit-sv.omf
share/gnome/omf/gedit/gedit-zh_CN.omf
share/gnome/omf/gedit/gedit-zh_HK.omf
share/gnome/omf/gedit/gedit-zh_TW.omf
-share/gnome/pixmaps/gedit-icon.png
-share/gnome/pixmaps/gedit-logo.png
-share/gnome/pixmaps/gedit-plugin-manager.png
share/locale/af/LC_MESSAGES/gedit.mo
share/locale/am/LC_MESSAGES/gedit.mo
share/locale/ar/LC_MESSAGES/gedit.mo
@@ -267,6 +303,7 @@ share/locale/az/LC_MESSAGES/gedit.mo
share/locale/be/LC_MESSAGES/gedit.mo
share/locale/bg/LC_MESSAGES/gedit.mo
share/locale/bn/LC_MESSAGES/gedit.mo
+share/locale/bn_IN/LC_MESSAGES/gedit.mo
share/locale/br/LC_MESSAGES/gedit.mo
share/locale/bs/LC_MESSAGES/gedit.mo
share/locale/ca/LC_MESSAGES/gedit.mo
@@ -291,6 +328,7 @@ share/locale/he/LC_MESSAGES/gedit.mo
share/locale/hi/LC_MESSAGES/gedit.mo
share/locale/hr/LC_MESSAGES/gedit.mo
share/locale/hu/LC_MESSAGES/gedit.mo
+share/locale/hy/LC_MESSAGES/gedit.mo
share/locale/id/LC_MESSAGES/gedit.mo
share/locale/is/LC_MESSAGES/gedit.mo
share/locale/it/LC_MESSAGES/gedit.mo
@@ -298,8 +336,10 @@ share/locale/ja/LC_MESSAGES/gedit.mo
share/locale/ka/LC_MESSAGES/gedit.mo
share/locale/kn/LC_MESSAGES/gedit.mo
share/locale/ko/LC_MESSAGES/gedit.mo
+share/locale/ku/LC_MESSAGES/gedit.mo
share/locale/lt/LC_MESSAGES/gedit.mo
share/locale/lv/LC_MESSAGES/gedit.mo
+share/locale/mg/LC_MESSAGES/gedit.mo
share/locale/mi/LC_MESSAGES/gedit.mo
share/locale/mk/LC_MESSAGES/gedit.mo
share/locale/ml/LC_MESSAGES/gedit.mo
@@ -310,7 +350,6 @@ share/locale/nb/LC_MESSAGES/gedit.mo
share/locale/ne/LC_MESSAGES/gedit.mo
share/locale/nl/LC_MESSAGES/gedit.mo
share/locale/nn/LC_MESSAGES/gedit.mo
-share/locale/no/LC_MESSAGES/gedit.mo
share/locale/or/LC_MESSAGES/gedit.mo
share/locale/pa/LC_MESSAGES/gedit.mo
share/locale/pl/LC_MESSAGES/gedit.mo
@@ -318,6 +357,7 @@ share/locale/pt/LC_MESSAGES/gedit.mo
share/locale/pt_BR/LC_MESSAGES/gedit.mo
share/locale/ro/LC_MESSAGES/gedit.mo
share/locale/ru/LC_MESSAGES/gedit.mo
+share/locale/rw/LC_MESSAGES/gedit.mo
share/locale/sk/LC_MESSAGES/gedit.mo
share/locale/sl/LC_MESSAGES/gedit.mo
share/locale/sq/LC_MESSAGES/gedit.mo
@@ -325,21 +365,17 @@ share/locale/sr/LC_MESSAGES/gedit.mo
share/locale/sr@Latn/LC_MESSAGES/gedit.mo
share/locale/sv/LC_MESSAGES/gedit.mo
share/locale/ta/LC_MESSAGES/gedit.mo
+share/locale/te/LC_MESSAGES/gedit.mo
share/locale/th/LC_MESSAGES/gedit.mo
share/locale/tk/LC_MESSAGES/gedit.mo
share/locale/tr/LC_MESSAGES/gedit.mo
share/locale/uk/LC_MESSAGES/gedit.mo
share/locale/vi/LC_MESSAGES/gedit.mo
share/locale/wa/LC_MESSAGES/gedit.mo
+share/locale/xh/LC_MESSAGES/gedit.mo
share/locale/zh_CN/LC_MESSAGES/gedit.mo
share/locale/zh_HK/LC_MESSAGES/gedit.mo
share/locale/zh_TW/LC_MESSAGES/gedit.mo
-@dirrmtry share/locale/zh_HK/LC_MESSAGES
-@dirrmtry share/locale/zh_HK
-@dirrmtry share/locale/dz/LC_MESSAGES
-@dirrmtry share/locale/dz
-@dirrmtry share/locale/br/LC_MESSAGES
-@dirrmtry share/locale/br
@dirrm share/gnome/omf/gedit
@dirrm share/gnome/help/gedit/zh_TW/figures
@dirrm share/gnome/help/gedit/zh_TW
@@ -372,17 +408,81 @@ share/locale/zh_TW/LC_MESSAGES/gedit.mo
@dirrm share/gnome/help/gedit
@dirrm share/gnome/gedit-2/ui
@dirrm share/gnome/gedit-2/taglist
+@dirrm share/gnome/gedit-2/logo
+@dirrm share/gnome/gedit-2/icons
%%PYTHON%%@dirrm share/gnome/gedit-2/plugins/snippets
+@dirrm share/gnome/gedit-2/plugins/filebrowser
%%PYTHON%%@dirrm share/gnome/gedit-2/plugins/externaltools
-%%PYTHON%%@dirrm share/gnome/gedit-2/plugins
+@dirrm share/gnome/gedit-2/plugins
@dirrm share/gnome/gedit-2/glade
@dirrm share/gnome/gedit-2
+@dirrm %%DOCSDIR%%
+%%PYTHON%%@dirrm lib/gedit-2/plugins/pythonconsole
%%PYTHON%%@dirrm lib/gedit-2/plugins/snippets
%%PYTHON%%@dirrm lib/gedit-2/plugins/externaltools
@dirrm lib/gedit-2/plugins
@dirrm lib/gedit-2
-@dirrm include/gedit-%%VERSION%%/gedit/recent-files
@dirrm include/gedit-%%VERSION%%/gedit
@dirrm include/gedit-%%VERSION%%
@exec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
@unexec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
+@dirrmtry share/locale/zh_TW/LC_MESSAGES
+@dirrmtry share/locale/zh_TW
+@dirrmtry share/locale/zh_HK/LC_MESSAGES
+@dirrmtry share/locale/zh_HK
+@dirrmtry share/locale/zh_CN/LC_MESSAGES
+@dirrmtry share/locale/zh_CN
+@dirrmtry share/locale/xh/LC_MESSAGES
+@dirrmtry share/locale/xh
+@dirrmtry share/locale/uk/LC_MESSAGES
+@dirrmtry share/locale/uk
+@dirrmtry share/locale/tk/LC_MESSAGES
+@dirrmtry share/locale/tk
+@dirrmtry share/locale/te/LC_MESSAGES
+@dirrmtry share/locale/te
+@dirrmtry share/locale/sr/LC_MESSAGES
+@dirrmtry share/locale/sr
+@dirrmtry share/locale/sl/LC_MESSAGES
+@dirrmtry share/locale/sl
+@dirrmtry share/locale/sk/LC_MESSAGES
+@dirrmtry share/locale/sk
+@dirrmtry share/locale/rw/LC_MESSAGES
+@dirrmtry share/locale/rw
+@dirrmtry share/locale/ro/LC_MESSAGES
+@dirrmtry share/locale/ro
+@dirrmtry share/locale/pt/LC_MESSAGES
+@dirrmtry share/locale/pt
+@dirrmtry share/locale/pl/LC_MESSAGES
+@dirrmtry share/locale/pl
+@dirrmtry share/locale/nn/LC_MESSAGES
+@dirrmtry share/locale/nn
+@dirrmtry share/locale/ne/LC_MESSAGES
+@dirrmtry share/locale/ne
+@dirrmtry share/locale/mr/LC_MESSAGES
+@dirrmtry share/locale/mr
+@dirrmtry share/locale/mi/LC_MESSAGES
+@dirrmtry share/locale/mi
+@dirrmtry share/locale/mg/LC_MESSAGES
+@dirrmtry share/locale/mg
+@dirrmtry share/locale/ku/LC_MESSAGES
+@dirrmtry share/locale/ku
+@dirrmtry share/locale/ko/LC_MESSAGES
+@dirrmtry share/locale/ko
+@dirrmtry share/locale/hy/LC_MESSAGES
+@dirrmtry share/locale/hy
+@dirrmtry share/locale/gl/LC_MESSAGES
+@dirrmtry share/locale/gl
+@dirrmtry share/locale/fi/LC_MESSAGES
+@dirrmtry share/locale/fi
+@dirrmtry share/locale/el/LC_MESSAGES
+@dirrmtry share/locale/el
+@dirrmtry share/locale/dz/LC_MESSAGES
+@dirrmtry share/locale/dz
+@dirrmtry share/locale/cs/LC_MESSAGES
+@dirrmtry share/locale/cs
+@dirrmtry share/locale/ca/LC_MESSAGES
+@dirrmtry share/locale/ca
+@dirrmtry share/locale/bn_IN/LC_MESSAGES
+@dirrmtry share/locale/bn_IN
+@dirrmtry share/locale/be/LC_MESSAGES
+@dirrmtry share/locale/be