aboutsummaryrefslogtreecommitdiff
path: root/editors/ghex2
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2003-09-18 06:49:37 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2003-09-18 06:49:37 +0000
commit9c0caae1c20155b432bb0feb074a8fd9cc1c12bc (patch)
tree534d0190982c831de589344c3003940ec6f2d6b1 /editors/ghex2
parent27d17afba2c21f490ea8472d7aa37495e02e3ed8 (diff)
downloadports-9c0caae1c20155b432bb0feb074a8fd9cc1c12bc.tar.gz
ports-9c0caae1c20155b432bb0feb074a8fd9cc1c12bc.zip
Notes
Diffstat (limited to 'editors/ghex2')
-rw-r--r--editors/ghex2/Makefile10
-rw-r--r--editors/ghex2/distinfo2
-rw-r--r--editors/ghex2/files/patch-configure10
-rw-r--r--editors/ghex2/files/patch-src_ui.c11
-rw-r--r--editors/ghex2/pkg-plist118
5 files changed, 114 insertions, 37 deletions
diff --git a/editors/ghex2/Makefile b/editors/ghex2/Makefile
index 6f1c8d1c8a82..7e5171fb2843 100644
--- a/editors/ghex2/Makefile
+++ b/editors/ghex2/Makefile
@@ -6,11 +6,10 @@
#
PORTNAME= ghex2
-PORTVERSION= 2.2.1
-PORTREVISION= 2
+PORTVERSION= 2.4.0.1
CATEGORIES= editors gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/${PORTNAME:S/2$//}/2.2
+MASTER_SITE_SUBDIR= sources/${PORTNAME:S/2$//}/2.4
DISTNAME= ${PORTNAME:S/2$//}-${PORTVERSION}
DIST_SUBDIR= gnome2
@@ -20,10 +19,11 @@ COMMENT= GNOME 2 hex editor
USE_BZIP2= yes
USE_X_PREFIX= yes
USE_GMAKE= yes
+USE_REINPLACE= yes
USE_GNOME= gnomeprefix gnomehack gail libgnomeprintui libgnomeui
USE_LIBTOOL= yes
-USE_REINPLACE= yes
+INSTALLS_SHLIB= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib"
+ LDFLAGS="-L${LOCALBASE}/lib"
.include <bsd.port.mk>
diff --git a/editors/ghex2/distinfo b/editors/ghex2/distinfo
index 0c47977b9234..ed1ab7a182c1 100644
--- a/editors/ghex2/distinfo
+++ b/editors/ghex2/distinfo
@@ -1 +1 @@
-MD5 (gnome2/ghex-2.2.1.tar.bz2) = a10ef7db355d2c7790b5d999d0b3087a
+MD5 (gnome2/ghex-2.4.0.1.tar.bz2) = 2add675fa3d8d61e71616d49bb7d861e
diff --git a/editors/ghex2/files/patch-configure b/editors/ghex2/files/patch-configure
new file mode 100644
index 000000000000..f195f07b43c6
--- /dev/null
+++ b/editors/ghex2/files/patch-configure
@@ -0,0 +1,10 @@
+--- configure.orig Wed Dec 11 18:31:51 2002
++++ configure Thu Dec 12 12:07:17 2002
+@@ -7414,6 +7414,7 @@
+
+ # This can be used to rebuild libtool when needed
+ LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
++$ac_aux_dir/ltconfig $LIBTOOL_DEPS
+
+ # Always use our own libtool.
+ LIBTOOL='$(SHELL) $(top_builddir)/libtool'
diff --git a/editors/ghex2/files/patch-src_ui.c b/editors/ghex2/files/patch-src_ui.c
deleted file mode 100644
index b79543ead137..000000000000
--- a/editors/ghex2/files/patch-src_ui.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/ui.c.orig Fri Jul 18 20:25:58 2003
-+++ src/ui.c Fri Jul 18 20:26:34 2003
-@@ -875,7 +875,7 @@
- g_return_if_fail (msg != NULL);
- va_start(args, msg);
- real_msg = g_strdup_vprintf(msg, args);
-- va_end(msg);
-+ va_end(args);
- info_dlg = gtk_message_dialog_new (
- GTK_WINDOW (win),
- GTK_DIALOG_MODAL | GTK_DIALOG_DESTROY_WITH_PARENT,
diff --git a/editors/ghex2/pkg-plist b/editors/ghex2/pkg-plist
index 7f1081dc9d31..e0080d42706e 100644
--- a/editors/ghex2/pkg-plist
+++ b/editors/ghex2/pkg-plist
@@ -2,34 +2,84 @@ bin/ghex2
etc/gconf/gconf.xml.defaults/apps/ghex2/%gconf.xml
etc/gconf/gconf.xml.defaults/schemas/apps/ghex2/%gconf.xml
etc/gconf/schemas/ghex2.schemas
+include/gtkhex/accessiblegtkhex.h
+include/gtkhex/accessiblegtkhexfactory.h
+include/gtkhex/gtkhex.h
+include/gtkhex/hex-document.h
+lib/libgtkhex.a
+lib/libgtkhex.so
+lib/libgtkhex.so.0
+libdata/pkgconfig/gtkhex.pc
share/gnome/applications/ghex.desktop
share/gnome/gnome-2.0/ui/ghex-ui.xml
-share/gnome/help/ghex2/ja/ghex2.sgml
-share/gnome/help/ghex2/ja/ghexconverter.png
-share/gnome/help/ghex2/ja/ghexdisplaypref.png
-share/gnome/help/ghex2/ja/ghexfind.png
-share/gnome/help/ghex2/ja/ghexfindreplace.png
-share/gnome/help/ghex2/ja/ghexfullwindow.png
-share/gnome/help/ghex2/ja/ghexmdiprefs.png
-share/gnome/help/ghex2/ja/ghexmenubar.png
-share/gnome/help/ghex2/ja/ghexmenues.html
-share/gnome/help/ghex2/ja/ghexprefedit.png
-share/gnome/help/ghex2/ja/ghexprintprefs.png
-share/gnome/help/ghex2/ja/index.html
-share/gnome/help/ghex2/ja/topic.dat
-share/gnome/help/ghex2/ja/usage.html
share/gnome/help/ghex2/C/figures/ghex_window_empty.png
share/gnome/help/ghex2/C/figures/ghex_window_open.png
share/gnome/help/ghex2/C/ghex2.xml
share/gnome/help/ghex2/C/legal.xml
share/gnome/help/ghex2/C/topic.dat
+share/gnome/help/ghex2/de/figures/ghex_window_empty.png
+share/gnome/help/ghex2/de/figures/ghex_window_open.png
+share/gnome/help/ghex2/de/ghex2.xml
+share/gnome/help/ghex2/de/legal.xml
+share/gnome/help/ghex2/es/figures/ghex_window_empty.png
+share/gnome/help/ghex2/es/figures/ghex_window_open.png
+share/gnome/help/ghex2/es/ghex2.xml
+share/gnome/help/ghex2/es/legal.xml
+share/gnome/help/ghex2/es/topic.dat
+share/gnome/help/ghex2/fr/figures/ghex_window_empty.png
+share/gnome/help/ghex2/fr/figures/ghex_window_open.png
+share/gnome/help/ghex2/fr/ghex2.xml
+share/gnome/help/ghex2/fr/legal.xml
+share/gnome/help/ghex2/it/figures/ghex_window_empty.png
+share/gnome/help/ghex2/it/figures/ghex_window_open.png
+share/gnome/help/ghex2/it/ghex2.xml
+share/gnome/help/ghex2/it/legal.xml
+share/gnome/help/ghex2/ja/figures/ghex_window_empty.png
+share/gnome/help/ghex2/ja/figures/ghex_window_open.png
+share/gnome/help/ghex2/ja/ghex2.xml
+share/gnome/help/ghex2/ja/legal.xml
+share/gnome/help/ghex2/ja/topic.dat
+share/gnome/help/ghex2/ko/figures/ghex_window_empty.png
+share/gnome/help/ghex2/ko/figures/ghex_window_open.png
+share/gnome/help/ghex2/ko/ghex2.xml
+share/gnome/help/ghex2/ko/legal.xml
+share/gnome/help/ghex2/sv/figures/ghex_window_empty.png
+share/gnome/help/ghex2/sv/figures/ghex_window_open.png
+share/gnome/help/ghex2/sv/ghex2.xml
+share/gnome/help/ghex2/sv/legal.xml
+share/gnome/help/ghex2/sv/topic.dat
+share/gnome/help/ghex2/zh_CN/figures/ghex_window_empty.png
+share/gnome/help/ghex2/zh_CN/figures/ghex_window_open.png
+share/gnome/help/ghex2/zh_CN/ghex2.xml
+share/gnome/help/ghex2/zh_CN/legal.xml
+share/gnome/help/ghex2/zh_TW/figures/ghex_window_empty.png
+share/gnome/help/ghex2/zh_TW/figures/ghex_window_open.png
+share/gnome/help/ghex2/zh_TW/ghex2.xml
+share/gnome/help/ghex2/zh_TW/legal.xml
share/gnome/omf/ghex/ghex-C.omf
@exec scrollkeeper-install -q %D/share/gnome/omf/ghex/ghex-C.omf 2>/dev/null || /usr/bin/true
-share/gnome/omf/ghex/ghex-ja.omf
-@exec scrollkeeper-install -q %D/share/gnome/omf/ghex/ghex-ja.omf 2>/dev/null || /usr/bin/true
+share/gnome/omf/ghex/ghex2-de.omf
+@exec scrollkeeper-install -q %D/share/gnome/omf/ghex/ghex2-de.omf 2>/dev/null || /usr/bin/true
+share/gnome/omf/ghex/ghex2-es.omf
+@exec scrollkeeper-install -q %D/share/gnome/omf/ghex/ghex2-es.omf 2>/dev/null || /usr/bin/true
+share/gnome/omf/ghex/ghex2-fr.omf
+@exec scrollkeeper-install -q %D/share/gnome/omf/ghex/ghex2-fr.omf 2>/dev/null || /usr/bin/true
+share/gnome/omf/ghex/ghex2-it.omf
+@exec scrollkeeper-install -q %D/share/gnome/omf/ghex/ghex2-it.omf 2>/dev/null || /usr/bin/true
+share/gnome/omf/ghex/ghex2-ja.omf
+@exec scrollkeeper-install -q %D/share/gnome/omf/ghex/ghex2-ja.omf 2>/dev/null || /usr/bin/true
+share/gnome/omf/ghex/ghex2-ko.omf
+@exec scrollkeeper-install -q %D/share/gnome/omf/ghex/ghex2-ko.omf 2>/dev/null || /usr/bin/true
+share/gnome/omf/ghex/ghex2-sv.omf
+@exec scrollkeeper-install -q %D/share/gnome/omf/ghex/ghex2-sv.omf 2>/dev/null || /usr/bin/true
+share/gnome/omf/ghex/ghex2-zh_CN.omf
+@exec scrollkeeper-install -q %D/share/gnome/omf/ghex/ghex2-zh_CN.omf 2>/dev/null || /usr/bin/true
+share/gnome/omf/ghex/ghex2-zh_TW.omf
+@exec scrollkeeper-install -q %D/share/gnome/omf/ghex/ghex2-zh_TW.omf 2>/dev/null || /usr/bin/true
share/gnome/pixmaps/gnome-ghex.png
-share/locale/az/LC_MESSAGES/ghex-2.0.mo
share/locale/am/LC_MESSAGES/ghex-2.0.mo
+share/locale/az/LC_MESSAGES/ghex-2.0.mo
+share/locale/be/LC_MESSAGES/ghex-2.0.mo
share/locale/bg/LC_MESSAGES/ghex-2.0.mo
share/locale/ca/LC_MESSAGES/ghex-2.0.mo
share/locale/cs/LC_MESSAGES/ghex-2.0.mo
@@ -49,6 +99,7 @@ share/locale/hu/LC_MESSAGES/ghex-2.0.mo
share/locale/it/LC_MESSAGES/ghex-2.0.mo
share/locale/ja/LC_MESSAGES/ghex-2.0.mo
share/locale/ko/LC_MESSAGES/ghex-2.0.mo
+share/locale/ml/LC_MESSAGES/ghex-2.0.mo
share/locale/ms/LC_MESSAGES/ghex-2.0.mo
share/locale/nl/LC_MESSAGES/ghex-2.0.mo
share/locale/nn/LC_MESSAGES/ghex-2.0.mo
@@ -60,6 +111,8 @@ share/locale/ro/LC_MESSAGES/ghex-2.0.mo
share/locale/ru/LC_MESSAGES/ghex-2.0.mo
share/locale/sk/LC_MESSAGES/ghex-2.0.mo
share/locale/sl/LC_MESSAGES/ghex-2.0.mo
+share/locale/sr/LC_MESSAGES/ghex-2.0.mo
+share/locale/sr@Latn/LC_MESSAGES/ghex-2.0.mo
share/locale/sv/LC_MESSAGES/ghex-2.0.mo
share/locale/tr/LC_MESSAGES/ghex-2.0.mo
share/locale/uk/LC_MESSAGES/ghex-2.0.mo
@@ -68,12 +121,37 @@ share/locale/wa/LC_MESSAGES/ghex-2.0.mo
share/locale/zh_CN/LC_MESSAGES/ghex-2.0.mo
share/locale/zh_TW/LC_MESSAGES/ghex-2.0.mo
@dirrm share/gnome/omf/ghex
+@dirrm share/gnome/help/ghex2/zh_TW/figures
+@dirrm share/gnome/help/ghex2/zh_TW
+@dirrm share/gnome/help/ghex2/zh_CN/figures
+@dirrm share/gnome/help/ghex2/zh_CN
+@dirrm share/gnome/help/ghex2/sv/figures
+@dirrm share/gnome/help/ghex2/sv
+@dirrm share/gnome/help/ghex2/ko/figures
+@dirrm share/gnome/help/ghex2/ko
+@dirrm share/gnome/help/ghex2/ja/figures
+@dirrm share/gnome/help/ghex2/ja
+@dirrm share/gnome/help/ghex2/it/figures
+@dirrm share/gnome/help/ghex2/it
+@dirrm share/gnome/help/ghex2/fr/figures
+@dirrm share/gnome/help/ghex2/fr
+@dirrm share/gnome/help/ghex2/es/figures
+@dirrm share/gnome/help/ghex2/es
+@dirrm share/gnome/help/ghex2/de/figures
+@dirrm share/gnome/help/ghex2/de
@dirrm share/gnome/help/ghex2/C/figures
@dirrm share/gnome/help/ghex2/C
-@dirrm share/gnome/help/ghex2/ja/stylesheet-images
-@dirrm share/gnome/help/ghex2/ja
@dirrm share/gnome/help/ghex2
+@dirrm include/gtkhex
@dirrm etc/gconf/gconf.xml.defaults/schemas/apps/ghex2
@dirrm etc/gconf/gconf.xml.defaults/apps/ghex2
@unexec scrollkeeper-uninstall -q %D/share/gnome/omf/ghex/ghex-C.omf 2>/dev/null || /usr/bin/true
-@unexec scrollkeeper-uninstall -q %D/share/gnome/omf/ghex/ghex-ja.omf 2>/dev/null || /usr/bin/true
+@unexec scrollkeeper-uninstall -q %D/share/gnome/omf/ghex/ghex2-de.omf 2>/dev/null || /usr/bin/true
+@unexec scrollkeeper-uninstall -q %D/share/gnome/omf/ghex/ghex2-es.omf 2>/dev/null || /usr/bin/true
+@unexec scrollkeeper-uninstall -q %D/share/gnome/omf/ghex/ghex2-fr.omf 2>/dev/null || /usr/bin/true
+@unexec scrollkeeper-uninstall -q %D/share/gnome/omf/ghex/ghex2-it.omf 2>/dev/null || /usr/bin/true
+@unexec scrollkeeper-uninstall -q %D/share/gnome/omf/ghex/ghex2-ja.omf 2>/dev/null || /usr/bin/true
+@unexec scrollkeeper-uninstall -q %D/share/gnome/omf/ghex/ghex2-ko.omf 2>/dev/null || /usr/bin/true
+@unexec scrollkeeper-uninstall -q %D/share/gnome/omf/ghex/ghex2-sv.omf 2>/dev/null || /usr/bin/true
+@unexec scrollkeeper-uninstall -q %D/share/gnome/omf/ghex/ghex2-zh_CN.omf 2>/dev/null || /usr/bin/true
+@unexec scrollkeeper-uninstall -q %D/share/gnome/omf/ghex/ghex2-zh_TW.omf 2>/dev/null || /usr/bin/true