aboutsummaryrefslogtreecommitdiff
path: root/editors/gmanedit
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-06-21 15:52:35 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-06-21 15:52:35 +0000
commit4fcd623a911ebff1fb406f959932040af7ed40b2 (patch)
tree3179f0030b56361bd63473d24ab0af7ddce20dbf /editors/gmanedit
parent15b35ffaea08acdf8c14ea61767dbb931ac1b83f (diff)
downloadports-4fcd623a911ebff1fb406f959932040af7ed40b2.tar.gz
ports-4fcd623a911ebff1fb406f959932040af7ed40b2.zip
Notes
Diffstat (limited to 'editors/gmanedit')
-rw-r--r--editors/gmanedit/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/editors/gmanedit/Makefile b/editors/gmanedit/Makefile
index d7ddc385c0f7..ba80cec22f4b 100644
--- a/editors/gmanedit/Makefile
+++ b/editors/gmanedit/Makefile
@@ -14,6 +14,7 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
+USE_REINPLACE= yes
USE_BZIP2= yes
USE_X_PREFIX= yes
USE_GMAKE= yes
@@ -28,10 +29,11 @@ post-extract:
@${RM} -rf ${WRKSRC}/config.cache
pre-patch:
- @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
- @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
- 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
- s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
+ @find ${WRKSRC} -name "Makefile.in" | xargs ${REINPLACE_CMD} -e \
+ 's|\$(datadir)/gnome/|\$(datadir)/|g'
+ @find ${WRKSRC} -name "Makefile.in" | xargs ${REINPLACE_CMD} -e \
+ 's|\$(datadir)/locale|\$(prefix)/share/locale|g'
.include <bsd.port.mk>