aboutsummaryrefslogtreecommitdiff
path: root/editors/gobby
diff options
context:
space:
mode:
authorSofian Brabez <sbz@FreeBSD.org>2014-07-24 14:40:59 +0000
committerSofian Brabez <sbz@FreeBSD.org>2014-07-24 14:40:59 +0000
commit10bba6a8155577db53afdb53d068b5507fe79d3f (patch)
tree9df59e17bc0aef0bdabdadd3749df65ed8e12bc9 /editors/gobby
parentd2c30c50cc381a4205dca204e5894ab8acbbc4dc (diff)
downloadports-10bba6a8155577db53afdb53d068b5507fe79d3f.tar.gz
ports-10bba6a8155577db53afdb53d068b5507fe79d3f.zip
Notes
Diffstat (limited to 'editors/gobby')
-rw-r--r--editors/gobby/Makefile5
-rw-r--r--editors/gobby/files/patch-inc__config.hpp38
-rw-r--r--editors/gobby/files/patch-inc__preferencesdialog.hpp11
3 files changed, 52 insertions, 2 deletions
diff --git a/editors/gobby/Makefile b/editors/gobby/Makefile
index 0fd174f84f74..b783f5f7e7d5 100644
--- a/editors/gobby/Makefile
+++ b/editors/gobby/Makefile
@@ -2,6 +2,7 @@
PORTNAME= gobby
PORTVERSION= 0.4.13
+PORTREVISION= 1
CATEGORIES= editors
MASTER_SITES= http://releases.0x539.de/gobby/ \
LOCAL/${MAINTAINER:C/([^@]*)@.*/\1/}
@@ -19,8 +20,8 @@ LIB_DEPENDS= libobby.so:${PORTSDIR}/devel/obby \
OPTIONS_DEFINE= GTKSPELL NLS
GTKSPELL_DESC= Enable GtkSpell support
-USE_GNOME= gnomehack gtksourceview2 intltool
-USES= gmake pkgconfig
+USE_GNOME= gtksourceview2 intltool
+USES= gmake pkgconfig pathfix
GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
diff --git a/editors/gobby/files/patch-inc__config.hpp b/editors/gobby/files/patch-inc__config.hpp
new file mode 100644
index 000000000000..0c999edc14ac
--- /dev/null
+++ b/editors/gobby/files/patch-inc__config.hpp
@@ -0,0 +1,38 @@
+--- ./inc/config.hpp.orig 2012-01-30 01:27:51.000000000 +0100
++++ ./inc/config.hpp 2014-07-24 13:11:27.000000000 +0200
+@@ -31,6 +31,19 @@
+ #include <libxml++/nodes/element.h>
+ #include <libxml++/nodes/textnode.h>
+
++
++namespace serialise
++{
++template<>
++class default_context_to<Glib::ustring>: public context_base_to<Glib::ustring>
++{
++public:
++ typedef Glib::ustring data_type;
++
++ virtual std::string to_string(const data_type& from) const;
++};
++}
++
+ namespace Gobby
+ {
+
+@@ -460,15 +473,6 @@
+ };
+
+ template<>
+-class default_context_to<Glib::ustring>: public context_base_to<Glib::ustring>
+-{
+-public:
+- typedef Glib::ustring data_type;
+-
+- virtual std::string to_string(const data_type& from) const;
+-};
+-
+-template<>
+ class default_context_from<Glib::ustring>:
+ public context_base_from<Glib::ustring>
+ {
diff --git a/editors/gobby/files/patch-inc__preferencesdialog.hpp b/editors/gobby/files/patch-inc__preferencesdialog.hpp
new file mode 100644
index 000000000000..6cdaa6680e47
--- /dev/null
+++ b/editors/gobby/files/patch-inc__preferencesdialog.hpp
@@ -0,0 +1,11 @@
+--- ./inc/preferencesdialog.hpp.orig 2012-01-30 01:27:51.000000000 +0100
++++ ./inc/preferencesdialog.hpp 2014-07-24 13:12:17.000000000 +0200
+@@ -198,7 +198,7 @@
+ protected:
+ struct LangCompare
+ {
+- bool operator()(GtkSourceLanguage* first, GtkSourceLanguage* second)
++ bool operator()(const GtkSourceLanguage* first, const GtkSourceLanguage* second) const
+ {
+ return first < second;
+ }