aboutsummaryrefslogtreecommitdiff
path: root/editors/gphpedit/Makefile
diff options
context:
space:
mode:
authorJeremy Messenger <mezz@FreeBSD.org>2004-12-22 07:30:30 +0000
committerJeremy Messenger <mezz@FreeBSD.org>2004-12-22 07:30:30 +0000
commitdf10209cbc1538a40a54c206d131c8d940e3b919 (patch)
treed77c350a3470667d092590183ea655716c97dde5 /editors/gphpedit/Makefile
parent0bf9e0843624275254fabbbf289fb0bb756965a9 (diff)
downloadports-df10209cbc1538a40a54c206d131c8d940e3b919.tar.gz
ports-df10209cbc1538a40a54c206d131c8d940e3b919.zip
Notes
Diffstat (limited to 'editors/gphpedit/Makefile')
-rw-r--r--editors/gphpedit/Makefile52
1 files changed, 52 insertions, 0 deletions
diff --git a/editors/gphpedit/Makefile b/editors/gphpedit/Makefile
new file mode 100644
index 000000000000..73e71eef2571
--- /dev/null
+++ b/editors/gphpedit/Makefile
@@ -0,0 +1,52 @@
+# New ports collection makefile for: gphpedit
+# Date created: 2004-11-21
+# Whom: Roman Bogorodskiy <bogorodskiy@inbox.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gphpedit
+PORTVERSION= 0.9.50
+CATEGORIES= editors gnome
+MASTER_SITES= http://www.gphpedit.org/download/store/
+
+MAINTAINER= bogorodskiy@inbox.ru
+COMMENT= PHP, HTML and CSS development environment for GNOME 2.x
+
+USE_GMAKE= yes
+USE_GNOME= gnomeprefix gnomehack libgnomeui libgtkhtml
+USE_X_PREFIX= yes
+USE_LIBTOOL_VER=15
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+.if !defined(WITHOUT_PHP)
+USE_PHP= yes
+WANT_PHP_CLI= yes
+.endif
+
+.if !defined(WITHOUT_PHPDOC)
+RUN_DEPENDS+= ${LOCALBASE}/share/doc/php-en/about.html:${PORTSDIR}/lang/php_doc
+.endif
+
+pre-everything::
+.if !defined(WITHOUT_PHP) || !defined(WITHOUT_PHPDOC)
+ @${ECHO_MSG} "You may specify the following on the command line:"
+ @${ECHO_MSG} " "
+.endif
+.if !defined(WITHOUT_PHP)
+ @${ECHO_MSG} "WITHOUT_PHP=yes to not install php, debug script will not work without it."
+.endif
+.if !defined(WITHOUT_PHPDOC)
+ @${ECHO_MSG} "WITHOUT_PHPDOC=yes to not install php_doc, help will be disable."
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|/usr/local/share|${PREFIX}/share/gnome|g' \
+ ${WRKSRC}/src/main.h
+ @${REINPLACE_CMD} -e 's|/usr/share|${PREFIX}/share/gnome|g' \
+ ${WRKSRC}/src/calltip.c ${WRKSRC}/src/main_window.c
+ @${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
+ ${WRKSRC}/src/tab.c
+
+.include <bsd.port.mk>