aboutsummaryrefslogtreecommitdiff
path: root/editors/heme
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2014-01-17 02:56:01 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2014-01-17 02:56:01 +0000
commit07bf79600789dd39fb71809edbc5535bbca218b2 (patch)
tree3616488789bfc2f49086579d04e4b2492a1c9b53 /editors/heme
parent57bbcc44c1edcf31eb7386ebec4436ca087bd043 (diff)
downloadports-07bf79600789dd39fb71809edbc5535bbca218b2.tar.gz
ports-07bf79600789dd39fb71809edbc5535bbca218b2.zip
Notes
Diffstat (limited to 'editors/heme')
-rw-r--r--editors/heme/Makefile15
1 files changed, 5 insertions, 10 deletions
diff --git a/editors/heme/Makefile b/editors/heme/Makefile
index 8066054c0e6b..4b64ddba88c7 100644
--- a/editors/heme/Makefile
+++ b/editors/heme/Makefile
@@ -12,21 +12,16 @@ COMMENT= Small and fast console hex editor for Unix-like systems
LICENSE= GPLv2
ALL_TARGET= ${PORTNAME}
-MAKE_ARGS= CFLAGS="${CFLAGS} -Wall -DHAVE_MMAP" INSTALL_PREFIX="${PREFIX}"
+MAKE_ARGS= CFLAGS="${CFLAGS} -Wall -DHAVE_MMAP" \
+ INSTALL_PREFIX="${STAGEDIR}${PREFIX}"
-PLIST_FILES= bin/${PORTNAME}
-MAN1= ${PORTNAME}.1
+PLIST_FILES= bin/${PORTNAME} man/man1/${PORTNAME}.1.gz
PORTDOCS= README
OPTIONS_DEFINE= DOCS
-NO_STAGE= yes
-.include <bsd.port.options.mk>
-
post-install:
-.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${DOCSDIR}
-.endif
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>