aboutsummaryrefslogtreecommitdiff
path: root/editors/hnb/Makefile
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2013-10-01 05:45:56 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2013-10-01 05:45:56 +0000
commit595c4dc8ff12cea3f745a37da68abe7a3917b19d (patch)
tree25ea183aab3c092b864677d566403ee4d3220bdb /editors/hnb/Makefile
parent54a29b023c68dd3d18b332fd51f5d2c4dda38d1a (diff)
downloadports-595c4dc8ff12cea3f745a37da68abe7a3917b19d.tar.gz
ports-595c4dc8ff12cea3f745a37da68abe7a3917b19d.zip
Notes
Diffstat (limited to 'editors/hnb/Makefile')
-rw-r--r--editors/hnb/Makefile22
1 files changed, 12 insertions, 10 deletions
diff --git a/editors/hnb/Makefile b/editors/hnb/Makefile
index 2fae1c31ad44..91322dba87ae 100644
--- a/editors/hnb/Makefile
+++ b/editors/hnb/Makefile
@@ -10,14 +10,15 @@ MASTER_SITES= SF
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Hierarchical NoteBook a data organizer
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/src
-USE_GMAKE= yes
-ALL_TARGET=
+USES= gmake
+ALL_TARGET= # empty
MAKE_JOBS_UNSAFE= yes
-MAN1= hnb.1
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/src
+
+PLIST_FILES= bin/${PORTNAME} man/man1/${PORTNAME}.1.gz
+PORTDOCS= *
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${ARCH} != "i386"
@@ -25,16 +26,17 @@ BROKEN= segfaults on 64bit systems
.endif
post-patch:
- @${REINPLACE_CMD} -e 's|^CFLAGS=|CFLAGS+=|' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's|^CFLAGS=|CFLAGS+=|; s|make|$${MAKE}|' \
+ ${WRKSRC}/Makefile
@${REINPLACE_CMD} -e '/^CFLAGS/d' ${WRKSRC}/libcli/Makefile
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/hnb ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/../doc/hnb.1 ${MANPREFIX}/man/man1
+ ${INSTALL_PROGRAM} ${WRKSRC}/hnb ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/../doc/hnb.1 ${STAGEDIR}${MAN1PREFIX}/man/man1
.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
.for FILE in Documentation.hnb Documentation.html hnbrc
- ${INSTALL_DATA} ${WRKSRC}/../doc/${FILE} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/../doc/${FILE} ${STAGEDIR}${DOCSDIR}
.endfor
.endif